404 Error with New Menu Items

Discussion regarding Joomla! 2.5 Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
Talaysen
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Mon Mar 01, 2010 6:21 am

404 Error with New Menu Items

Post by Talaysen » Mon Jun 27, 2011 7:04 am

Hello,

I installed Joomla 1.6 for a new website about two days ago,
I created a new menu item linking to a new article, but the link results in:
An error has occurred.
The requested page cannot be found.

Home Page
If difficulties persist, please contact the System Administrator of this site and report the error below.
#404 Article not found
I have tried disabling the search engine friendly links, but the problem remains the same regardless of the settings.
(I purge the cache inbetween setting changes, as well, to no avail).

Was wondering if anyone had any suggestions.
Site can be viewed at http://www.donhoes.com/

Amita S
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 245
Joined: Mon Jun 20, 2011 8:42 am
Location: Pune , India

Re: 404 Error with New Menu Items

Post by Amita S » Mon Jun 27, 2011 7:51 am

Hi
You can check all these settings :
1. Global configuration>site settings>SEO settings....set all 3 radio buttons to "no" or off.
2. If you renamed htaccess.txt to .htaccess ...you can switch it back to htaccess.txt, for the time being.
3.global configuration>system>cache settings - no
4.enable web services>no
5.In plugins manager>SEF system plugin - disable and system cache plugin>disable
6.If you were running a cache, dump it>Tools>Clean Cache and Tools>global check in can help, too.

Also check your system date & time.

I hope this will helpful for you.


Thanks & Regards

Talaysen
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Mon Mar 01, 2010 6:21 am

Re: 404 Error with New Menu Items

Post by Talaysen » Mon Jun 27, 2011 5:18 pm

Amita S wrote: 1. Global configuration>site settings>SEO settings....set all 3 radio buttons to "no" or off.
Done
Amita S wrote: 2. If you renamed htaccess.txt to .htaccess ...you can switch it back to htaccess.txt, for the time being.
Done
Amita S wrote: 3.global configuration>system>cache settings - no
4.enable web services>no
Amita S wrote: 5.In plugins manager>SEF system plugin - disable and system cache plugin>disable
Done, Disabled SEF plugin, cache was not enabled.
Amita S wrote: 6.If you were running a cache, dump it>Tools>Clean Cache and Tools>global check in can help, too.
N/A

Well. :-[ After going through all of that, I was looking at the article and noticed that it was marked as unpublished/expired.
I removed the start and finish publish dates/times and it resolved the issue.
I'm a bit peeved that I made such a simple mistake, but thank you so much for your help.

I must have populated those two fields without realizing it, unless it does it automatically.
I'm going to go sit in the corner for a while and be disgusted with myself. Thanks again.

Edit: Went back through and re-enabled all the SEF stuff. Works as intended. :-[

abdulrehman007
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Jul 29, 2016 6:38 am

Re: 404 Error with New Menu Items

Post by abdulrehman007 » Wed Oct 19, 2016 8:46 am

@Amita S, bundles of thanks,
its start working by only changing 1. Global configuration>site settings>SEO settings....set all 3 radio buttons to "no" or off.


Post Reply

Return to “Performance - Joomla! 2.5”