All kinds of problems after switching hosts!

Discussion regarding Joomla! 2.5 Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
ronsieber
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Aug 23, 2012 1:27 pm

All kinds of problems after switching hosts!

Post by ronsieber » Thu Nov 06, 2014 6:43 pm

Hi, please help me figure out what's going on! I just switched from GoDaddy to ASmallOrange and ever since then I started having error messages show up on my website, which I believe are concerning my GCalendar extension linked to my Google Calendars:

Authentication with Google failed. Reason: BadAuthentication
Authentication with Google failed. Reason: BadAuthentication
Authentication with Google failed. Reason: BadAuthentication

Just like that... several times in a row.
I tried authenticating it on my Google account where it said "Was this you?" Nothing.
I tried purging the expired cache and clearing the cache, but that seemed to make it WORSE!!!

Now I'm also showing a message:

JFolder::create: Could not create directory
JFolder::create: Could not create directory

Someone please help! All of this is a result of trying to upgrade to Joomla 3, but my Joomla Update is not showing any updates past version 2.5.6

My new host tried helping me figure it out but they said they weren't able to get any results.
Here's what my new host support said:
I can see your site outputting a lot of PHP errors, because it's joomla 2.5, which is pretty out-of-date and not likely compatible with 'strict standards' introduced in PHP 5.4. We do have an alternative installation of PHP 5.3 on the server, so I tried switching you over to that to see if it would help, but the site didn't load at all on that!
And then...
Unfortunately, I couldn't make that error go away. I've also noticed that each time I try to save the configuration, the configuration.php file from public_html goes blank. Probably something went wrong on the previous update.

I hope that's enough info for someone to help me out! Thank you! :)

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 25956
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: All kinds of problems after switching hosts!

Post by Per Yngve Berg » Thu Nov 06, 2014 7:27 pm

The latest version is 2.5.27, you are 11 versions behind.

How did you move the site? Akeeba Backup+ Kickstart or something else.

Have you corrected the tmp and log path in configuration.php to reflect the new server?

Please use the Forum Post Assistant so we can check your new server's set-up.

ronsieber
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Aug 23, 2012 1:27 pm

Re: All kinds of problems after switching hosts!

Post by ronsieber » Thu Nov 06, 2014 7:41 pm

So, somewhere along the line the update function stopped working?

By the way, all the "Authentication with Google failed. Reason: BadAuthentication" errors have now vanished!

The only error left is "JFolder::create: Could not create directory" 2X in a row.

I'll try to get the forum post assistant set up, but I'm reluctant to continue screwing up my site. Not exactly a pro web designer :(

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19666
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: All kinds of problems after switching hosts!

Post by leolam » Sun Nov 09, 2014 5:57 am

ronsieber wrote:So, somewhere along the line the update function stopped working?
We have no automated update function. You (!) are the updater. So you download Joomla 2.5.27 and you extract locally and than with ftp you upload and overwrite all files and folders (but not the 'installation-folder' ) and your site is on Joomla 2.5.27. You should no longer have those errors after that.

Once errors gone you follow what I wrote here: http://forum.joomla.org/viewtopic.php?f=710&t=793171

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

ronsieber
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Aug 23, 2012 1:27 pm

Re: All kinds of problems after switching hosts!

Post by ronsieber » Tue Nov 18, 2014 8:21 pm

Thanks for helping me through my issues as I am in way over my head! I was able to get rid of my error messages from before, and I tried following the steps provided by Leolam in migrating from 2.5 to 3.

The problem was I still did not get Joomla to recognize there was an update available (as you mention in Step 5). So I downloaded Joomla 3 and tried to upload the zipped file through extensions manager. Now I have the white screen of death -- completely blank --on both my website and the /administrator page.

Can you please help me get out of this mess?? I've tried everything and I have no clue what I'm doing. I'm afraid I may need to completely start over again.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 25956
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: All kinds of problems after switching hosts!

Post by Per Yngve Berg » Tue Nov 18, 2014 8:31 pm

Restore your 2.5 site from backup.

Did you use the J3.x update package?
http://joomlacode.org/gf/download/frsre ... ackage.zip

ronsieber
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Aug 23, 2012 1:27 pm

Re: All kinds of problems after switching hosts!

Post by ronsieber » Tue Nov 18, 2014 8:40 pm

Per,

I'm pretty sure I used that package. Also, I'm trying to restore right now in cPanel and it says "Restoring Files..." but I'm pretty sure nothing is happening.

Should the backup file say "cpbackup-exclude.conf"? I have a feeling a screwed this up big time!

***EDIT: Yep, I screwed up big time! I just noticed that file is a whole 1 byte in size. In the process of fixing my other issue I must've deleted the backup file somehow. UGH.

ronsieber
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Aug 23, 2012 1:27 pm

Re: All kinds of problems after switching hosts!

Post by ronsieber » Tue Nov 18, 2014 9:01 pm

Here's a list of errors if this helps at all...

PHP Warning: Creating default object from empty value in /home/harvests/public_html/libraries/joomla/updater/adapters/extension.php(38) : eval()'d code on line 1

PHP Warning: require_once(/home/harvests/public_html/libraries/import.legacy.php): failed to open stream: No such file or directory in /home/harvests/public_html/administrator/includes/framework.php on line 33

PHP Fatal error: require_once(): Failed opening required '/home/harvests/public_html/libraries/import.legacy.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/harvests/public_html/administrator/includes/framework.php on line 33

PHP Fatal error: Call to undefined method JLoader::registerNamespace() in /home/harvests/public_html/libraries/cms.php on line 33


Locked

Return to “Performance - Joomla! 2.5”