falang: error 404 when ι enable the Language Filter

General questions regarding the use of languages in Joomla! 2.5.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
prototypo
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Mar 19, 2012 6:31 pm

falang: error 404 when ι enable the Language Filter

Post by prototypo » Thu Mar 22, 2012 4:54 pm

Hello all! :D

I make the following steps.

1. Install the Greek Language for admin and front end. version 1.7.0 01-09-2011 Joomla.gr team
2. Add Greeks to content
3. Enable the module language swicher (Falang) -> flags are displayed in home page
4. Activate the plugin System - Language Filter, and I have no access to the home page.

error 404 Item not found

Menus and Articles are all currently in the language "ALL".

I read that this may be due to the SEF and the htaccess so I disabled all functions completely SEF but again nothing.

What else could be?

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 27809
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: error 404 item not found when ι enable the Language Filt

Post by imanickam » Thu Mar 22, 2012 5:13 pm

(a) Are you building a multi-lingual site? If not, there is no need to enable the plug-in "System - Language Filter" and to publish the module "Language Switcher".

If you are indeed building a multi-lingual site, suggest reviewing the multilingual tutorial site at http://multilingual-joomla-demo.cloudac ... steps.html. This being a demo site also, you can log into the site's back-end and see how things are setup.

(b) Are you using the extension (Falang)?
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Joomla! - Global Moderators Team | Joomla! Core - Tamil (தமிழ்) Translation Team Coordinator
ex-Joomla! Translations Coordination Team
Eegan - Support the poor and underprivileged

prototypo
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Mar 19, 2012 6:31 pm

Re: error 404 item not found when ι enable the Language Filt

Post by prototypo » Mon Mar 26, 2012 6:59 pm

imanickam wrote:(a) Are you building a multi-lingual site? If not, there is no need to enable the plug-in "System - Language Filter" and to publish the module "Language Switcher".

If you are indeed building a multi-lingual site, suggest reviewing the multilingual tutorial site at http://multilingual-joomla-demo.cloudac ... steps.html. This being a demo site also, you can log into the site's back-end and see how things are setup.

(b) Are you using the extension (Falang)?
Thanks for Reply imanickam
Yes im using Falang trying to make 2 Language site.
I changed the ALL from menu items and K2 Items to Greek and the GR main page opens now. The problem is when i switch the language to EN.
Any successions please?

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 19124
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: error 404 item not found when ι enable the Language Filt

Post by infograf768 » Wed Mar 28, 2012 6:43 am

I am changing the title of this topic as it only concerns falang and not native Joomla multilang funtionnality
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

biirc
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 141
Joined: Thu Mar 12, 2009 11:34 am

Re: falang: error 404 when ι enable the Language Filter

Post by biirc » Wed Mar 28, 2012 12:23 pm

Hi,

Falang work with sef of joomla.
The problem is not here.
Do yo use another sef component ?

Stéphane

prototypo
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Mar 19, 2012 6:31 pm

Re: falang: error 404 when ι enable the Language Filter

Post by prototypo » Wed Mar 28, 2012 1:39 pm

biirc wrote:Hi,

Falang work with sef of joomla.
The problem is not here.
Do yo use another sef component ?

Stéphane
No others SEF components installed. .httacess is there and writeable.

all enables plugins
Content - ObfuscateMe content ObfuscateMe Public 10076
Editor - None editors none Public 411
System - NoNumber! Framework system nnframework Public 10085
Search - Newsfeeds search newsfeeds Public 420
Content - Vote content vote Public 409
Search - Weblinks search weblinks Public 421
Editor - TinyMCE editors tinymce Public 412
System - Redirect system redirect Public 427
Content - Image gallery - sigplus content sigplus Public 10053
System - P3P Policy system p3p Public 423
Content - Pagebreak content pagebreak Public 407
Button - Pagebreak editors-xtd pagebreak Public 415
Content - Page Navigation content pagenavigation Public 408
System - RokExtender system rokextender Public 10021
System - Remember Me system remember Public 428
Button - Readmore editors-xtd readmore Public 416
User - Joomla! user joomla Public 432
System - Logout system logout Public 430
System - Log system log Public 426
System - Advanced Module Manager system advancedmodules Public 10073
System - Gantry system gantry Public 10003
Content - Email Cloaking content emailcloak Public 404
System - Debug system debug Public 425
Search - Content search content Public 419
Search - Contacts search contacts Public 418
Editor - CodeMirror editors codemirror Public 410
Search - Categories search categories Public 417
Button - Image editors-xtd image Public 414
ImageSizer system imagesizer Public 10062
Editor - JCE editors jce Public 10060
Content - Load Modules content loadmodule Public 406
User - K2 user k2 Public 10018
System - K2 system k2 Public 10017
Search - K2 search k2 Public 10016
Simple Image Gallery Pro (by JoomlaWorks) content jw_sigpro Public 10070
Extension - Joomla extension joomla Public 434
Content - Joomla content joomla Public 435
Authentication - Joomla authentication joomla Public 401
Button - Article editors-xtd article Public 413



All modules

Open in modal window Main Menu position-7 Menu Selected only Public All 1

Open in modal window Main Menu header-a Menu Selected only Public All 25

Open in modal window This Site position-7 Menu All except selected Public All 26

Open in modal window Menu Example :: None :: Menu Selected only Public All 45

Open in modal window Search header-a K2 Tools All Public All 83

Open in modal window Χάρτης maintop-a JGMap - Google Map Selected only Public All 90

Open in modal window Επικοινωνία footer-d Custom HTML All Public All 105

Open in modal window Συμμετοχή σε εκθέσεις sidebar-a K2 Content Selected only Public All 156

Open in modal window Οι στρατηγικοί στόχοι μας mainbottom-a Menu Selected only Public All 171

Open in modal window Flash feature-a Custom HTML Selected only Public All 178

Open in modal window Προϊόντα footer-a Menu All Public All 179

Open in modal window Main Top Articles maintop-a K2 Content Selected only Public All 182

Open in modal window Εταιρικό Προφίλ mainbottom-b Custom HTML Selected only Public All 183

Open in modal window Οι Συνεργάτες μας mainbottom-a Custom HTML Selected only Public All 184

Open in modal window Εγκαταστάσεις mainbottom-a Custom HTML Selected only Public All 185

Open in modal window Εγκαταστάσεις & εξοπλισμός mainbottom-b Custom HTML Selected only Public All 187

Open in modal window Top menu Buttons top-c Custom HTML All Public All 189

Open in modal window Επικοινωνία maintop-b Custom HTML Selected only Public All 191

Open in modal window prorotypo footer-a Custom HTML All Public All 195

prototypo
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Mar 19, 2012 6:31 pm

Re: falang: error 404 when ι enable the Language Filter

Post by prototypo » Wed Mar 28, 2012 10:16 pm

On the same web site i had problem with some images that i published by using K2 item manager and wysityg editor when i had SEF settings enabled the images was not showing in front end and the problem solved by turned SEF settings off. When i had SEF on the image url's from http://www.domain.gr/images/image.jpg was turning to http://www.domain.gr/somecategory/images/image.jpg

I tried to solve the languages problem by turning off the SEF settings but nothing...

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 19124
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: falang: error 404 when ι enable the Language Filter

Post by infograf768 » Thu Mar 29, 2012 9:13 am

It is suggested you contact the falang developper
http://www.faboba.com/en/contact.html
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

sthrss
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Oct 26, 2013 2:59 am

Re: falang: error 404 when ι enable the Language Filter

Post by sthrss » Sat Oct 26, 2013 3:53 am

Greetings, i'm posting here, cause i have a similar problem but in order to get FaLang Support i must pay, so i prefer to try to get some advices/directions from here :)

This is what i have done until now:
1.installed greek language@"Language Manager", set it main language only for the Site, not Administrator.

2. setup greek content language in "Content Languages"@"Language Manager" with the correct tag, language code and image prefix.

3. fixed plugin and module ordering

3.1 Enabled Plug-in's: "name" [ordering]
"System - Language Filter" [1]
"System - Language Code" [10]
"System - FaLang Database Driver" [0]

3.2 Published the Modules
"name" [Position] [Ordering] [Type] [Pages] [Access] [Language] [ID]
"Breadcrumbs" [position-2] [Breadcrumbs] [All] [Public] [Greek (GR)] [17]
"FaLang Language [Switcher"] [position-7] [FaLang] [Language] [Switcher] [All] [Public] [All] [87]
"Main Menu" [position-7] [Menu] [All] [Public] [Greek (GR)] [1]
"Login Form" [position-7] [Login] [All] [Public] [Greek (GR)] [16]

4. set all possible relevant tables (content, categories, menu, contact_details, modules) language to the native language, greek, with the following simple sql queries below (in case it's useful to anyone):

Code: Select all

UPDATE j25_content
SET language="el-GR"
WHERE language="*";

UPDATE j25_categories
SET language="el-GR"
WHERE language="*";

UPDATE j25_menu
SET language="el-GR"
WHERE language="*";

UPDATE j25_contact_details
SET language="el-GR"
WHERE language="*";

UPDATE j25_modules
SET language="el-GR"
WHERE language="*";
5. @"Global Configuration" -> "Server" -> "SEO Settings" -> "Search Engine Friendly URLs" set it to "No".

DEBUG INFO:

I activated debugging at joomla/administrator and this is what i get when the module "Main Menu" Language is set to:

a) greek ["Greek (GR)"]:

Image

b) "All":

Image

c) This is what debug returns at a Falang's "Translation" function:

c1) At a not translated Element:

Image

c2) "Contents" or any other Element with translated and published sub-elements (e.g. "Categories", ""):

Image




The problem is i get 404 just when i change language from the language switcher. My template is the default Joomla 2.5 template " Beez2 - Default".

If anyone can give me any insight, based on the above configuration i would be really grateful! Tomorrow i might manage to upload the website to a friend server and hopefully give you a better information source, if anyone is willing to give it a shot :)

Thank you in advance for any hint/insight/help/advice/direction/curse :P

sthrss
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Oct 26, 2013 2:59 am

Re: falang: error 404 when ι enable the Language Filter

Post by sthrss » Sat Oct 26, 2013 1:39 pm

problem solved :D

i had to set all the previous mentioned elements default language to "All", not site's native language and it worked like a charm :D


Locked

Return to “Language - Joomla! 2.5”