upgrade from 3.0 to 3.1 errors

General questions regarding the use of languages in Joomla! 2.5.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
luciew
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue May 07, 2013 12:57 am

upgrade from 3.0 to 3.1 errors

Post by luciew » Tue May 07, 2013 1:08 am

from the front end I have the menu but nothing below..
ERROR 1146
Table 'mya_joomla1363896657.jos_contentitem_tag_map' doesn't exist SQL=SELECT `m`.`tag_id`,`t`.* FROM `jos_contentitem_tag_map` AS m INNER JOIN `jos_tags` AS t ON `m`.`tag_id` = `t`.`id` WHERE `m`.`type_alias` = 'com_content.article' AND `m`.`content_item_id` = 1 AND `t`.`published` = 1 AND t.access IN (1,1,5)


from the back end - under Article or Category
same error #
1146 Table 'mya_joomla1363896657.jos_tags' doesn't exist SQL=SELECT a.id, a.title, a.level FROM jos_tags AS a WHERE a.parent_id > 0 ORDER BY a.lft

what should I do??? what does this mean?

the configuration file is correct..

luciew
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue May 07, 2013 12:57 am

Re: upgrade from 3.0 to 3.1 errors

Post by luciew » Tue May 07, 2013 6:02 pm

nobody run into that problem???

I did this too and it does not work either!
-----------------
Updating to 3.1.1 may solve this issue.

If it does not or for some reason you cannot update to 3.1.1 the following steps will resolve it.

In your file system go to /administration/components/com_admin/sql and find the file 3.1.0.sql. Open it in a plain text editor.
Determine your database prefix by looking at the server tab in global configuration or by looking at your database table names in phpmyadmin or whatever system your host provides for managing your database. For example you may see xyz123_assets ... in this case xyz123 is your prefix.
In the text editor search and replace #_ with your prefix. Note that the replace should only replace the first underscore ... so now you should have for example xyz123_content_types.
In phpmyadmin go to the SQL tab and paste the full file from the editor (or do similar in another system).
click Go (or do similar in another system)

-----------------------------

I get those errors:

Error
SQL query:

--
-- Table structure for table `jos_content_types`
--
CREATE TABLE IF NOT EXISTS `jos_content_types` (

`type_id` INT( 10 ) UNSIGNED NOT NULL AUTO_INCREMENT ,
`type_title` VARCHAR( 255 ) NOT NULL DEFAULT '',
`type_alias` VARCHAR( 255 ) NOT NULL DEFAULT '',
`table` VARCHAR( 255 ) NOT NULL DEFAULT '',
`rules` TEXT NOT NULL ,
`field_mappings` TEXT NOT NULL ,
`router` VARCHAR( 255 ) NOT NULL DEFAULT '',
PRIMARY KEY ( `type_id` ) ,
KEY `idx_alias` ( `type_alias` )
) ENGINE = INNODB DEFAULT CHARSET = utf8 AUTO_INCREMENT =10000;



anybody??

luciew
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue May 07, 2013 12:57 am

Re: upgrade from 3.0 to 3.1 errors

Post by luciew » Tue May 07, 2013 6:13 pm

thanks for nobody out there.. thanks to the webhostingeeks and my friend Tom who found htem.

i solved it finally:
http://answers.webhostinggeeks.com/joom ... error-3078

User avatar
SunNadimpalli
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Thu Sep 27, 2012 10:28 am
Location: Bangalore, India
Contact:

Re: upgrade from 3.0 to 3.1 errors

Post by SunNadimpalli » Tue May 21, 2013 5:21 am

Thank you for posting the solution. I faced the same problem and used the solution you posted to fix it.
Sundar Nadimpalli - Signum Product Solutions. www.signumsol.com

Vering
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Mar 17, 2012 6:53 pm

Re: upgrade from 3.0 to 3.1 errors

Post by Vering » Sat Mar 22, 2014 6:44 pm

Thanks a lot! I still had a 3.0.2 installation running, which I could not manage to upgrade until now. Thank you!

User avatar
prem726
Joomla! Intern
Joomla! Intern
Posts: 87
Joined: Sat May 15, 2010 10:27 am
Location: Korat, THAILAND

Re: upgrade from 3.0 to 3.1 errors

Post by prem726 » Wed Oct 29, 2014 10:49 am

i found this problem too!
and i expecting to solve it again with my sites
happykorat.com outloei.com lamphuonline.com happyburiram.com


Locked

Return to “Language - Joomla! 2.5”