Page 1 of 1

Problem with email activation account in multilanguage site

Posted: Sat Jul 06, 2013 9:02 am
by r1si
Hi all,
I have a problem with my new site.
I make a multilingual site with: English and Italian( ita as default)

The registration user is disable, so only an admin can add some new user to website
But there is a problem, when I (admin) add an English user to site, it can show fontend and backend in English, but he receive an activation mail in Italian.

the contents of the e-mail speaks of an admin add you to website, here your user and password.

thanks in advance for all reply.
Cheers
Elia

Re: Problem with email activation account in multilanguage s

Posted: Sat Jul 06, 2013 9:04 am
by r1si
to Moderators:

i make a site with joomla 2.5, so i have I was wrong section of the forum.
sorry, can you move it or i must re-write?
thanks in advance

Re: Problem with email activation account in multilanguage s

Posted: Sat Jul 06, 2013 9:18 am
by pe7er
[Mod note: moved to Language - Joomla! 2.5]

Re: Problem with email activation account in multilanguage s

Posted: Mon Jul 08, 2013 4:17 pm
by r1si
up :(

someone can help me?

Re: Problem with email activation account in multilanguage s

Posted: Thu Jul 11, 2013 8:21 am
by infograf768
r1si wrote:Hi all,
I have a problem with my new site.
I make a multilingual site with: English and Italian( ita as default)

The registration user is disable, so only an admin can add some new user to website
But there is a problem, when I (admin) add an English user to site, it can show fontend and backend in English, but he receive an activation mail in Italian.

the contents of the e-mail speaks of an admin add you to website, here your user and password.

thanks in advance for all reply.
Cheers
Elia
How does the user register exactly?
Try to change the default language to English when necessary before sending activation mail.

Re: Problem with email activation account in multilanguage s

Posted: Fri Jan 31, 2014 3:24 pm
by fonny
Any progress on this bug?

Joomla v3.2.1 multilingual site (FR+EN+NL) with FR as default.
Login as admin with language NL and create a new user with default language FR.
The user receives an email in Dutch.

The mail is send in the language the admin is logged in in the backend and not in the language selected as the users front or backend language.

regards
Fonny

Re: Problem with email activation account in multilanguage s

Posted: Sun Feb 02, 2014 11:33 am
by infograf768
For 3.2.1, please test the attached patched file:
Unzip and replace /plugins/user/joomla/joomla.php
joomla.php.zip
If ok for you please comment here:
http://joomlacode.org/gf/project/joomla ... 21&start=0

Re: Problem with email activation account in multilanguage s

Posted: Mon Feb 03, 2014 1:50 pm
by shiftsrl
Same problem here but my site is not multilanguage. The email to the user is always sent in english and should have been in italian...