language switcher flags problem after language pack update.

General questions regarding the use of languages in Joomla! 2.5.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
Nadjaji
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Feb 15, 2013 6:47 pm

language switcher flags problem after language pack update.

Post by Nadjaji » Thu May 01, 2014 11:03 am

Hi, I updated the French language pack to v 2.5.20 this morning, while in process to install the language switcher.
At this moment my English and Dutch flag are showing, but for the French I have the written word français. (see screenshot). Any insights?
Thanks,
Nadja
Screen Shot 2014-05-01 at 12.45.05 PM.png
You do not have the required permissions to view the files attached to this post.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22148
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: language switcher flags problem after language pack upda

Post by pe7er » Thu May 01, 2014 11:07 am

Could you check in Extensions > Language Manager > Content Languages
how the settings for French have been configured?

Maybe you have to change the field that is used to determine the language flag from
FR to fr or fr-fr...
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

Nadjaji
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Feb 15, 2013 6:47 pm

Re: language switcher flags problem after language pack upda

Post by Nadjaji » Thu May 01, 2014 12:32 pm

That might be it. I remember changing something in the letters, to have a unity in the three languages. I can't remember how the standard setting was though.
This is how it is now in content mode.

I will try some combinations out and post the result when successful.
Bedankt pe7et
You do not have the required permissions to view the files attached to this post.

Nadjaji
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Feb 15, 2013 6:47 pm

Re: language switcher flags problem after language pack upda

Post by Nadjaji » Thu May 01, 2014 12:47 pm

OK. I got it solved. This is how it should have been.
Thanks again for your input Peter.
You do not have the required permissions to view the files attached to this post.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22148
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: language switcher flags problem after language pack upda

Post by pe7er » Thu May 01, 2014 12:51 pm

Good to hear that you've solved it & thanks for sharing your solution!
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content


Locked

Return to “Language - Joomla! 2.5”