Page 1 of 1

Multilanguage problem

Posted: Fri May 02, 2014 8:59 pm
by Branwell
Hi,

I'm running a multilingual website with Joomla 2.5.7

I'm using default multilingual tool, I tried Falang with no improvement.

Everything works well, except if you try to follow a link to a French page when you have another page in English already open...

Try it yourselves : the site is : http://www.musinfo.fr

Switch to English and follow this link : http://www.musinfo.fr/index.php/present ... nscription

404! :'(

Any clue? I'm really struggling!

Thanks!

Re: Multilanguage problem

Posted: Sat May 03, 2014 9:02 am
by pe7er
Branwell wrote:I'm running a multilingual website with Joomla 2.5.7
Could you please upgrade (backup your site before doing so) to the latest Joomla version within the same series first before trying to solve errors with an older version?

Possible bugs might have been solved in the meantime. It's a waste of time for you trying to solve issues that are caused because of non-updated software...

The latest version in the 2.5 series is Joomla 2.5.20: http://www.joomla.org/download.html

Re: Multilanguage problem

Posted: Sat May 03, 2014 1:10 pm
by Branwell
OK, I'll do this right away. Thanks for your answer!

Re: Multilanguage problem

Posted: Sat May 03, 2014 9:41 pm
by Branwell
It seems that I'm unable to upgrade my Joomla.

I tried to upgrade from 2.5.7 to 2.5.20 using Joomla update component.

Any attempt leads to numerous errors and website malfunction.

I went through all sorts of trouble these last hours and have learnt that it is actually crucial to backup your site before trying to upgrade...

I know this is too vague and not the right place anymore, but what can I do?

Re: Multilanguage problem

Posted: Sun May 04, 2014 10:14 am
by pe7er
Branwell wrote:Any attempt leads to numerous errors and website malfunction.
What kind of errors? Front-end or back-end?
Did you empty your Joomla + browser cache after the update?

Did you modify Joomla's 2.5.7 source code?

Do you have any HTML overrides from Joomla 2.5.7 that might give errors with Joomla 2.5.20?
(check your template's folder for fodlers in /html/ and temporary disable your /html/ overrides by renaming it to /html-old/ and test your site again.

Re: Multilanguage problem

Posted: Wed May 07, 2014 8:31 pm
by Branwell
Actually it seems that the problem was the default language of my Joomla install is French... I could update by installing the French package.

Thanks for your help!

Re: Multilanguage problem

Posted: Thu May 22, 2014 2:40 pm
by faisslam
I had the same problem, and I will make you my say, and now it works fine thank you very much.

Re: Multilanguage problem

Posted: Fri Jun 06, 2014 2:40 pm
by royhiggs
Hi pe7er

New to this Forum and way short of being an expert in Joomla or websites in general however I have built my own site in Joomla 2.5 and have taken the site multilingual using the JA Lang extension.

I have followed the tutorials and installed 4 new languages and created separate templates for each one, 3 languages work fine and have there own mega menus as well as a default menu and a menu for my site language of English.

The problem is that the fifth language will not show even though it has a menu, a template, articles (associated) and categories (associated).

I can install new languages no problem so I assume I have made a mistake somewhere in the Polish installation and don't know how to fix it.

All help gratefully received as it's driving me bananas and I keep just going around in circles

Re: Multilanguage problem

Posted: Thu Jun 12, 2014 6:15 am
by infograf768
@royhiggs

Please attach here a screencapture of the multilanguage status module
See: http://forum.joomla.org/viewtopic.php?f=617&t=658605