Why my plugin description change???

General questions regarding the use of languages in Joomla! 2.5.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
daniele-nyx
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Oct 29, 2013 5:32 pm

Why my plugin description change???

Post by daniele-nyx » Wed May 07, 2014 9:44 am

Hi guys,
in relation to my previous post (http://forum.joomla.org/viewtopic.php?f=617&t=824511) I discovered this strange behavior.

Somebody can explain me why the description of my plugin change when it's enabled?

I have in en-GB.plg_system_my_plugin.ini

Code: Select all

PLG_LR_ISTRUCTIONS="This are the instructions...."
and in en-GB.plg_system_my_plugin.sys.ini

Code: Select all

PLG_LR_ISTRUCTIONS="Thank you for installing my plugin. You will find the instructions for setting up in the plugin page."
The first is showed when the plugin is disabled, the second if the plugin is enabled.
Somebody know why? I'm using language files in a wrong way?

Thanks,
Daniele

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18881
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Why my plugin description change???

Post by infograf768 » Sat May 17, 2014 5:58 am

This is confusing:
http://forum.joomla.org/viewtopic.php?f ... 1#p3169511
Can you attach the plugin or post a link to download it?
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

daniele-nyx
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Oct 29, 2013 5:32 pm

Re: Why my plugin description change???

Post by daniele-nyx » Tue Jun 03, 2014 1:46 pm

this is my installation xml:

Code: Select all

<extension version="2.5" type="plugin" group="system" method="upgrade">
  <name>My Plugin</name>
  <author>Nyx OfficinaWeb</author>
  <creationDate>October 2013</creationDate>
  <copyright></copyright>
  <license>GPLv2 or later</license>
  <authorEmail>daniele.megna@xxxx.it</authorEmail>
  <authorUrl>www.officinaweb.pro</authorUrl>
  <version>1.0.0</version>
  <description>PLG_LR_ISTRUCTIONS</description>
  <files>
    <filename plugin="my_plugin">my_plugin.php</filename>
    <filename>index.html</filename>
    <folder>img</folder>
    <folder>language</folder>
  </files>
  <languages folder="language">
    <language tag="it-IT">it-IT/it-IT.plg_system_my_plugin.ini</language>
    <language tag="it-IT">it-IT/it-IT.plg_system_my_plugin.sys.ini</language>
    <language tag="en-GB">en-GB/en-GB.plg_system_my_plugin.ini</language>
    <language tag="en-GB">en-GB/en-GB.plg_system_my_plugin.sys.ini</language>
  </languages>
  <config>
    .....
  </config>
</extension>
this are my language files...
en-GB/en-GB.plg_system_my_plugin.ini:

Code: Select all

PLG_LR_ISTRUCTIONS="
<table class='contentDocument'>
    <tr>
        <td>
           Here instructions...
        </td>
    </tr>
</table>"
en-GB/en-GB.plg_system_my_plugin.sys.ini:

Code: Select all

PLG_LR_ISTRUCTIONS="Thank you for installing my plugin."
(same thing for the IT language files)
Is it clear now? :( :'(
Thank you!

daniele-nyx
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Oct 29, 2013 5:32 pm

Re: Why my plugin description change???

Post by daniele-nyx » Fri Jul 18, 2014 7:33 am

Nothing else? :(


Locked

Return to “Language - Joomla! 2.5”