Https and 404 Errors in Joomla Multilanguage sites

General questions regarding the use of languages in Joomla! 2.5.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
Harry_Paraskeva
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Jan 07, 2014 5:16 pm

Https and 404 Errors in Joomla Multilanguage sites

Post by Harry_Paraskeva » Wed Jun 18, 2014 10:21 am

This is more of a question rather than an issue and is mainly due to reports of Crawl errors in Google Webmaster tools.

The situation is the following:
- I have a multilingual site at: https:\\www.aca-cy.org
- I have enabled across the site SSL for security reasons, hence the https.
- If when browsing the site you manually remove from the address bar the term "https://" and try to either reload the page or switch language you get a 404 error.

Why does that happen? Do I need to create redirect instructions for every page in order to avoid this?

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18668
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Https and 404 Errors in Joomla Multilanguage sites

Post by infograf768 » Thu Jun 19, 2014 2:17 pm

I would use an htaccess with the code provided here
http://serverfault.com/questions/116206 ... p-to-https
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

cannydog
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat Mar 31, 2012 10:25 pm

Re: Https and 404 Errors in Joomla Multilanguage sites

Post by cannydog » Fri Jan 29, 2016 9:30 am

Hi

I have a similar, but strange issue. I too have a multilingual site at: https://www.cannyco.com, with seven languages and have enabled SSL across the entire site. I have just started using sh404sef (great tool so far) as of yesterday to try and eliminate some duplicate content issues and other problems showing up in Google Webmaster Tools.

When checking the 404 logs, I can see some errors where the 404 page is, for example, https://www.cannyco.com/vmchk/Laisses-d ... duits.html. When I check GWT, it tells me that the link comes from the same page but on http - http://www.cannyco.com/vmchk/Laisses-de ... duits.html.

The problem is that neither of these pages are on my site! I recognise the 'vmchk' part as being from Virtuemart but we haven't used VM for at least 6 years now so I have no idea where these URLs are being generated from and why they keep appearing in GWT.

I would be grateful for any insight from a pair of expert eyes. I'm sure the solution is very simple, perhaps tied in with something in the database (?) but my level of expertise is not sufficient to get to the bottom of it.

Thank you in advance.


Locked

Return to “Language - Joomla! 2.5”