When language filter is enabled modules disappear

General questions regarding the use of languages in Joomla! 2.5.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
petrosjoomla
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri May 26, 2017 8:40 am

When language filter is enabled modules disappear

Post by petrosjoomla » Fri May 26, 2017 8:47 am

I'm trying to add a new language to my website but when I turn on the language filter all the modules that I have on the home page disappear. The articles are showing fine.

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 26762
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: When language filter is enabled modules disappear

Post by imanickam » Fri May 26, 2017 10:56 am

Whether the modules are assigned to any specific language or assigned to ALL languages?

Are you building a multilingual site? If the answer is No, the plugin "System - Language Filter" should not be Enabled.

Note:
Be known that Joomla! 2.5 is no longer supported. The latest version of Joomla! is 3.7.2.
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

petrosjoomla
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri May 26, 2017 8:40 am

Re: When language filter is enabled modules disappear

Post by petrosjoomla » Fri May 26, 2017 11:12 am

The language for the modules on the home page are all set to ALL.

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 26762
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: When language filter is enabled modules disappear

Post by imanickam » Fri May 26, 2017 12:05 pm

imanickam wrote:Are you building a multilingual site?
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

petrosjoomla
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri May 26, 2017 8:40 am

Re: When language filter is enabled modules disappear

Post by petrosjoomla » Fri May 26, 2017 1:22 pm

Yes I'm building a multilingual site. Modules disappear only on the home page. A module that is set to be displayed on the home page and on some other pages displays fine on the other pages but not on the home page.

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 26762
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: When language filter is enabled modules disappear

Post by imanickam » Fri May 26, 2017 2:02 pm

What is your site's URL?

Also, try the following:
- Publish the Administrator's module Multilingual Status
- Click on the link "Multilingual Status" that is in the status bar of the admin
- A pop-up window with various multilingual settings would be shown
- Take a screen-shot of the pop-up window and paste it in your reply
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18685
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: When language filter is enabled modules disappear

Post by infograf768 » Fri May 26, 2017 3:14 pm

As you are building a multingual site, you do have one home page per language. Make sure these modules set to ALL languages are set to display on each of these home pages (if that is what you want).
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

petrosjoomla
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri May 26, 2017 8:40 am

Re: When language filter is enabled modules disappear

Post by petrosjoomla » Mon May 29, 2017 8:26 am

Thank you both for your help but the issue was my poor understanding on how the translation process work. I followed a tutorial step by step and everything now seems to be working. Sorry for the trouble and thank you again for your help


Post Reply

Return to “Language - Joomla! 2.5”