Page 1 of 1

Redirect URLs doesn't work

Posted: Sun Nov 20, 2011 1:03 pm
by morsagmon
Hello all.
Using Joomla 1.7.2
The Redirect component does not work for me.
I turned on the redirect URLs parameter in the SEO part on the global Configuration page.
RewriteRules that I enter directly in .htaccess work just fine.

Any ideas?
Thanks!

Re: Redirect URLs doesn't work

Posted: Wed Nov 23, 2011 2:48 pm
by Alextampa
is the redirect plugin enabled?

Have you put the new url in the redirect manager? Is the link enabled?

Re: Redirect URLs doesn't work

Posted: Sun Nov 27, 2011 7:10 pm
by gilman01
I'm using Joomla 1.7.3 and having the same problem.

Confirmed redirect plugin is enabled
Confirmed link in redirect component is enabled
Confirmed url rerwrite in global configurations is enabled

I too can get manually entered redirects to work inside a plain .htaccess file

I am using LiteSpeed web server and not sure if that might have something to do with this.

Any other suggestions???

Re: Redirect URLs doesn't work

Posted: Mon Nov 28, 2011 7:54 pm
by Alextampa
try changing the order of the redirect plugin to -1000

ALSO, any other redirect plugins enabled? admin tools redirect enabled?

Re: Redirect URLs doesn't work

Posted: Fri Dec 02, 2011 5:49 pm
by Bundberg
jimmybrion wrote:Normally i will prefer login to server with FTP details and write 301 redirection script in .htaccess file.
Thanks, I had a similar problem and it is fixed now. A little bit complicated stuff for beginner :)

Re: Redirect URLs doesn't work

Posted: Fri Dec 02, 2011 6:23 pm
by inyong
I am Using Joomla 1.7.3 from 1.7.2 has same problem redirect 301 /old-url to new url not function
any one help

Re: Redirect URLs doesn't work

Posted: Mon Dec 05, 2011 8:03 pm
by morsagmon
What I eventually do is use .htaccess for redirects now.
Still, it troubles me that neither the redirect component nor the friendly URL's work for me :(

Re: Redirect URLs doesn't work

Posted: Tue Dec 06, 2011 7:12 pm
by DJsOak4
I am using Joomla 1.7.3 and, after being suggested to get redirect working, I found it as part of the system. I enabled the plug-in, got a 404 and entered the home page as where it should go but it is not working. I do not understand htaccess as I am a novice. Can someone suggest how I can get this to work? (I knew it sounded too good to be true :):)) Thanks for any help, DJ

Re: Redirect URLs doesn't work

Posted: Tue Dec 06, 2011 8:42 pm
by anoble87
I have a nice script I purchased with a custom 404 error page that has a 6 second delayed redirect, problem is it keeps redirecting to the 404 error page instead of my index. its located at http://test3.anoble87.com if someone could look at it and tell me what they think, I don't know if my problem is within the htaccess file or the redirect manager on the admin side. you can view the error page by looking under the template features sub menu. Thanks for the help!

Re: Redirect URLs doesn't work

Posted: Thu Dec 22, 2011 3:42 pm
by DJsOak4
My server changed the name of the htaccess file and now the redirect "seems" to work; time will tell.

Re: Redirect URLs doesn't work

Posted: Tue Dec 27, 2011 6:21 am
by marinos
ok guys I got mine to work and here is how I did it

Apache host - joomla 1.7.3

1- first I had to eliminate any problems when a user gets to the site using www or not, ie a user can visit your site with either URL

http : // www . your domian . com
or just
your domain . com (remove spaces)

but I want them both to be the same so either one they choose I want them to land on http://www . your domain . com (remove spaces). This is how
- if you haven't already done so on an apache host, rename your htaccess.txt file in the root of your joomla install to .htaccess so we just cut of the .txt and added a .(dot) in front.
- go to your site administration - global configurations - site, find 'Use URL rewriting' and select yes.
- go back to your .htaccess file to edit
- find code

Code: Select all

RewriteEngine On
right bellow it add this

Code: Select all

RewriteCond %{HTTP_HOST} ^blacksoldierflyfarming.com$ [NC]
RewriteRule ^(.*)$ http://www.blacksoldierflyfarming.com/$1 [R=301,L]
[*]obviously change the domain to your own
so now it looks like this

Code: Select all

RewriteEngine On

RewriteCond %{HTTP_HOST} ^blacksoldierflyfarming.com$ [NC]
RewriteRule ^(.*)$ http://www.blacksoldierflyfarming.com/$1 [R=301,L]
- now we dont have to do anything more in the .htaccess file and all your users will be redirected to your site with www included before your domain.

2. using joomlas inbuilt redirect
- go to your site administration - components - redirect
- [*] important! make sure you delete anything that is there that is disabled or not working, sometimes it conflicts with your new redirects, so go to your trash folder using the drop down on the right and empty trash
- click new to create a new redirect
- for 'Source URL' enter your whole url including http://www, in step one we force every url to end up as a www url so you wont miss a single visit doing it this way. in my case I entered http://www.my site.com/ignite-image-gallery (remove spaces)
- I wanted to redirect the url to http://www.my site.com/photo-galleries (remove spaces) so in 'Destination URL' I entered JUST 'photo-galleries' (without the commas, without the http:// without the domain, and without the www, just photo-galleries).
- set status to 'enabled'
- click save

works like a charm now so if someone visits my site using http://my site.com/ignite-image-gallery, (notice no www) because of the first step in .htaccess file they will be redirected to http://www.my site.com/ignite-image-gallery (notice the www) and then because of the joomla backend redirect they fall on the correct page which is http://www.my site.com/photo-galleries

This ended up a lot longer than what I thought, hope it helps

Re: Redirect URLs doesn't work

Posted: Wed May 15, 2013 4:35 pm
by repoman71
When I enter in the source URL, I'm getting hit with this error: Save failed with the following error: The source URL must be unique.

I don't see the address in the list, so I'm kinda at a loss. It's Joomla 2.5

Re: Redirect URLs doesn't work

Posted: Sat Jun 22, 2013 3:28 am
by John384
repoman71 wrote:When I enter in the source URL, I'm getting hit with this error: Save failed with the following error: The source URL must be unique.
When this happened to me I found that emptying the trash solved the problem.

Re: Redirect URLs doesn't work

Posted: Thu Jul 18, 2013 9:00 pm
by mlvfx
Hi,

if Redirect 301 command isn't working, it's usually not enabled on you provider's admin platform. So just check out your administartion settings (not joomla admin! Hosting server administration!). It's something like "Enable .htaccess". Without this, the local .htacces on your ftp ins't working.

Hope it helps!
Cheers!

Re: Redirect URLs doesn't work

Posted: Fri Jul 19, 2013 8:35 am
by Joombg
I had the same problem. I downloaded ReDj Manager and unchecked the Request Only box. Now all the redirects work great. Much less messing than through .htaccess.

Re: Redirect Manager URLs doesn't work

Posted: Wed Oct 25, 2017 11:09 am
by venkatgopu
How Joomla’s Redirect Manager System Plugin Works

The Source URL must generate a 404 error on the Joomla website. In other words, the 404 error must be generated by the Joomla website, and not by Apache, this is because the Redirect Manager system plugin does all its work in the handleError event that is triggered when an error (non-fatal) happens on the Joomla website.



this link will give you more calarity about how joomla redirect manager will work exactly...


https://www.itoctopus.com/how-joomlas-r ... ugin-works