/component/content/?view=featured

Discuss Search Engine Optimization in relation to Joomla! 2.5. This forum will also have discussions on SEF/SEO Joomla! 2.5 extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
EvanGR
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 229
Joined: Fri Oct 10, 2008 5:30 pm
Location: Greece

/component/content/?view=featured

Post by EvanGR » Wed Dec 14, 2011 2:11 am

I finished a multilingual website recently, based on 1.7.3 and submitted to Google.

In my surprise, I find that one of the first URLs indexed by google is in the following form: "/component/content/?view=featured"

Nowhere in my site, nor in my sitemaps (that I submitted to webmaster tools), does this URL appear. And it doesn't lead anywhere other than a blank page with the site template but no main content.

So my first question is.... how come this got indexed? I spent considerable amount of time to optimize my site SEO... and I get that indexed first?

I am a little frustrated, I'd love an explanation and some workarounds. Thanks!

vectorlost
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Sep 05, 2009 10:55 pm

Re: /component/content/?view=featured

Post by vectorlost » Tue Jan 31, 2012 3:11 pm

I have the same problem here....
Any answer to this..?

lalili
Joomla! Apprentice
Joomla! Apprentice
Posts: 42
Joined: Fri Apr 02, 2010 3:51 am
Location: Indonesia
Contact:

Re: /component/content/?view=featured

Post by lalili » Tue Jan 31, 2012 4:19 pm

You can redirect it from back end, put exact url then it will be redirect

tinamaria
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Sun Feb 05, 2012 2:58 pm

Re: /component/content/?view=featured

Post by tinamaria » Mon Mar 05, 2012 8:38 pm

I have this problem too... have to try that redirect

tinamaria
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Sun Feb 05, 2012 2:58 pm

Re: /component/content/?view=featured

Post by tinamaria » Mon Mar 05, 2012 9:04 pm

Redirect does not not work with this link... ??

karimlo
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sun Mar 23, 2008 4:28 pm

Re: /component/content/?view=featured

Post by karimlo » Tue Mar 06, 2012 5:29 pm

I am having the same problem. Not sure why Google picks that one among all the other URLs?
Is that may be related to a template malfunction? Or a bad URL rewrite on the apache side?

What iz ze problem? I don't know, either.

User avatar
dunxmax
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Mon Sep 21, 2009 9:33 am
Location: UK
Contact:

Re: /component/content/?view=featured

Post by dunxmax » Thu Mar 08, 2012 9:54 pm

Hi,

Anyone figured this out yet?

I'm getting a similar problem.

On my home page i get "?view=featured" at the end of the url and on category blog pages I'm getting "?layout=blog".

Single article pages are fine.

I'm currently going through an upgrade for a site from 1.5 to 2.5 whilst also transferring to a new host. Used SP upgrade for the upgrade, didn't go perfectly so was thinking the problem was due to the upgrade. But seeing as other people are getting the same I'm starting to think its something I need to turn off in 2.5 somewhere.

Guidance from anyone is always appreciated.

Regards

Duncan
The more we learn the less we know!

http://www.aquamandesign.co.uk
Committed to the Joomla way of life, based in the UK.

quran21
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Feb 09, 2012 11:25 pm

Re: /component/content/?view=featured

Post by quran21 » Fri Mar 09, 2012 8:30 pm

i am not an expert on this but if you don't want this link just try putting in htaccess file and report to google from webmaster tools as well, it will get removed after some time

Digital man
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Mar 09, 2012 3:22 pm

Re: /component/content/?view=featured

Post by Digital man » Sat Mar 10, 2012 12:10 am

Did you get this sorted i think i have the same problem.
my front page is a featured article layout but im getting some strange urls in the search engine for example:

www.mysite.co.uk/?limitstart=0
www.mysite.co.uk/component/content/?view=featured
www.mysite.co.uk/component/content/?vie ... ed&start=4
www.mysite.co.uk//component/mailto/?tmp ... cb3db9b17b

Deafalt page should be www.mysite.co.uk

all single article pages are clean urls

tinamaria
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Sun Feb 05, 2012 2:58 pm

Re: /component/content/?view=featured

Post by tinamaria » Sat Mar 10, 2012 12:58 pm

Still same problem... redirect does not work.

tinamaria
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Sun Feb 05, 2012 2:58 pm

Re: /component/content/?view=featured

Post by tinamaria » Sat Mar 10, 2012 1:18 pm

I don't understand how i can disallow useragent to register /component/content/?view=featured because there is no such folder on server as component? There is components, but it is already disallowed. Can you disallow the whole path? How?


this is my robots.txt:

User-agent: *
Disallow: /administrator/
Disallow: /cache/
Disallow: /cli/
Disallow: /components/
Disallow: /images/
Disallow: /includes/
Disallow: /installation/
Disallow: /language/
Disallow: /libraries/
Disallow: /logs/
Disallow: /media/
Disallow: /modules/
Disallow: /plugins/
Disallow: /templates/
Disallow: /tmp/

Now if i add the this line:
Disallow: /component/content/?view=featured/

Will it help? Although there is no component-folder on the server?
Also i don't know what to do in google webmaster tools... how to prevent Google?

tinamaria
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Sun Feb 05, 2012 2:58 pm

Re: /component/content/?view=featured

Post by tinamaria » Sat Mar 10, 2012 1:52 pm

I just noticed that Google finds front page article as separate article without navigation! This address is domain.com/component/content/article/articlenumber&name.

Maybe i should disallow /component/content/ in robots.txt?

User avatar
Leftfield
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4432
Joined: Fri Dec 08, 2006 3:33 am
Contact:

Re: /component/content/?view=featured

Post by Leftfield » Sun Mar 11, 2012 1:10 am

That's very weird that Google is picking something which is forbidden in robots.txt. I am using, ALWAYS, 3rd party SEF extension. Lately I played with all of them and would highly recommend AceSEF: http://extensions.joomla.org/extensions ... /sef/10019
Joomla Templates and Plugins /https://youjoomla.com/

User avatar
dunxmax
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Mon Sep 21, 2009 9:33 am
Location: UK
Contact:

Re: /component/content/?view=featured

Post by dunxmax » Mon Mar 12, 2012 11:20 am

I'm still needing a bit of guidance on this as I don't know if I'm getting an error or not. My problem is not directly related to how google is crawling my site.

I'm getting ?view=featured and ?layout=blog added to the end of my urls when I click through my site, which I've just upgraded from 1.5 - 2.5.

I would like to find out why this is happening? should it be happening? and how do I remove it from my urls?

As always help greatly appreciated.

Thanks
The more we learn the less we know!

http://www.aquamandesign.co.uk
Committed to the Joomla way of life, based in the UK.

User avatar
brunoalec
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Tue Sep 02, 2008 5:49 pm
Location: Rio - Brasil
Contact:

Re: /component/content/?view=featured

Post by brunoalec » Tue Mar 13, 2012 12:30 pm

Leftfield, using ACESEF do you have this issue in your sites or not ?
Thanks
Bruno Alecrim
Bruno Alecrim
Rio - Belem - Brasil
http://www.unicasite.com

tinamaria
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Sun Feb 05, 2012 2:58 pm

Re: /component/content/?view=featured

Post by tinamaria » Wed Mar 14, 2012 10:58 am

Would be interesting to know why the redirect does not work on these component/content addresses. Anyone know?

edit: redirect is for nonexistent pages only?

Beebee999
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Mar 19, 2012 1:41 am

Re: /component/content/?view=featured

Post by Beebee999 » Mon Mar 19, 2012 4:18 am

This happened to me too and i was wondering why it was indexed.

For me i deactivated the Mobile menu/ mobile version of my site and when i visit my site from my iphone, it automatically goes to this page. For me iam assuming this is the default mobile page when mobile menu is deactivated and i think this might be why Google is indexing it.

User avatar
dunxmax
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Mon Sep 21, 2009 9:33 am
Location: UK
Contact:

Re: /component/content/?view=featured

Post by dunxmax » Mon Mar 19, 2012 4:08 pm

Just want to say I found the answer to my issue, it had nothing to do whatosoever with what the rest of you guys in this thread are trying to find out, so apologies for that - my problem was a faulty module. Posted it here: http://forum.joomla.org/viewtopic.php?f ... 8#p2769208
The more we learn the less we know!

http://www.aquamandesign.co.uk
Committed to the Joomla way of life, based in the UK.

steph_aws
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Mar 22, 2012 1:42 pm
Contact:

Re: /component/content/?view=featured

Post by steph_aws » Thu Mar 22, 2012 3:56 pm

I have the same issue with google and joomla 1.7.
In my case, Google find the noisy URL in RSS and ATOM Feeds.
In the code source of home page there are links to RSS or/and ATOM.

<link href="/?format=feed&type=rss" rel="alternate" type="application/rss+xml" title="RSS 2.0" />
<link href="/?format=feed&type=atom" rel="alternate" type="application/atom+xml" title="Atom 1.0" />

corresponding for me at:
http://www.aws-informatique.com/ + ?format=feed&type=rss

and open the source code, you can read the /component/content/?view=featured URL.

A workaround is to add in, the rss and atom file, this line
if ($data->link == "/component/content/?view=featured")$data->link="";
after $data = &$this->_doc; (line 44 for my version )

files are in directory : libraries\joomla\document\feed\renderer

But it isn't the good solution, because it will be deleted with joomla update.

***** Manual signatures are NOT allowed *****___

Stéphane
Applications Web Services
http://www.aws-informatique.com

steph_aws
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Mar 22, 2012 1:42 pm
Contact:

Re: /component/content/?view=featured

Post by steph_aws » Mon Apr 02, 2012 4:34 pm

with the workaround and after a week, google replaced format=feed&type=rss by my home page.
;D

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2242
Joined: Sun May 04, 2008 12:37 pm

Re: /component/content/?view=featured

Post by waarnemer » Fri Sep 27, 2013 6:38 am

I created the xtra robot.txt rule, removed the code lines on the scripts, put in a request in Google webmaster tools to remove the URL from their index afterwards..

After a week it still shows..:(

UPDATE! BREAKING NEWS :) it has gone in webmaster tools... It took a long while...

wardin
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Feb 26, 2016 1:25 pm
Location: Czech Republic
Contact:

Re: /component/content/?view=featured

Post by wardin » Fri Feb 26, 2016 2:07 pm

steph_aws wrote: Files are in directory : libraries\joomla\document\feed\renderer
Thank you for the path to RSS renderer! I needed to remove this shitty URL with parameters from the RSS XML, so I just manually changed the content of the "link" tag to a nice URL and it's done.

I would've let it be, but it seems some Czech RSS aggregators are copying "link" URL to the profile page of my channel (as "original source URL" etc.). So it was really helpful for me and it works in J2.5 too. ;)

User avatar
sohrab330
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 108
Joined: Sat Apr 28, 2012 3:20 pm
Location: TX, US
Contact:

Re: /component/content/?view=featured

Post by sohrab330 » Thu Apr 27, 2017 10:35 pm

Hello everyone,

I am having the same problem on my Joomla 3.5 website.
google has picked this mysite.ir/fa/component/content/featured as a main page.
I disallowed it in robot.txt
I demoted the url in Google webmasters tool and I redirected the page both on my hosting panel and joomla panel (which is ofcourse in vain since it is not receiving any 404 error).
I forgot to mention that I also used the .htaccess file for a redirection. (no effect at all)
I still see the link.
any solution yet?

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 7740
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: /component/content/?view=featured

Post by sozzled » Thu Apr 27, 2017 11:24 pm

I'm always suspicious when people resurrect old topics that have been "dead" for several years after they started (especially when suggestions to address those old issues have been posted all over this forum).
sohrab330 wrote:I am having the same problem on my Joomla 3.5 website.
Why are you using J! 3.5? The last release for J! 3.5 (J! 3.5.1) was released over 12 months ago. Since that time there have been seven later releases; the current supported version is J! 3.7.0.

Why are you asking for a "solution" for an old version of Joomla? Have you tried updating to J! 3.7.0?

What other advice are you seeking?

Have you considered the possibility that your existing website is broken, has old/outdated extensions that are unsupported or that may be causing the problem(s) you're having? Have you considered using the Forum Post Assistant tool to provide us with more information that may indicate the probable/possible causes for your problem(s)?
https://www.kuneze.com/blog
I need your help to help reduce spam at the Joomla forum. You can help with your ideas, questions and opinions at viewtopic.php?f=7&t=974006. Together we can make a difference :)

User avatar
sohrab330
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 108
Joined: Sat Apr 28, 2012 3:20 pm
Location: TX, US
Contact:

Re: /component/content/?view=featured

Post by sohrab330 » Fri Apr 28, 2017 12:21 am

Oh Hello sozzled. thanks for your reply.
Do you know if there is a relevant topic in joomla 3 pages?
I meant J! 3.5.1. do you know there is 3.7 out there? it's cool.

User avatar
sohrab330
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 108
Joined: Sat Apr 28, 2012 3:20 pm
Location: TX, US
Contact:

Re: /component/content/?view=featured

Post by sohrab330 » Fri Apr 28, 2017 12:29 am

For anyone else who might find this topic via google search and know their website is not broken like many other people who have this issue. I finally found a trick for the issue on my own website.
I did several things but I am not sure which one led to a correction.

I put this in my htaccess:
RewriteCond %{QUERY_STRING} ^view=featured$
RewriteRule ^component/content/$ http://www.Yourwebsite.ir/fa/? [L,R=301]
and put this in my robot.txt:
Redirect 301 /fa/component/content/featured/ /fa/
I also made a menu in my PHPMyAdmin as an alias menu and redirected the troublesome featured into my homepage.
In the end, I changed the component/com_content URL name and then corrected it again.
it is working now.
Hope this will be of some use to anyone.

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 7740
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: /component/content/?view=featured

Post by sozzled » Fri Apr 28, 2017 12:50 am

sohrab330 wrote:Oh Hello sozzled. thanks for your reply.
Do you know if there is a relevant topic in joomla 3 pages?
I meant J! 3.5.1. do you know there is 3.7 out there? it's cool.
Whether or not there is a specific topic relating to J! 3.5.1 (or J! 3.6.0-5 or J! 3.7.0 for that matter) is not something I've been inclined to investigate. I don't have the "problems" that you're confronted with.

My concerns in addressing this topic were twofold:

1) This topic is very old: it began 5½ years ago; it petered out over a year ago and it was then resurrected today. Who knows what "issues" were being discussed over the course of that long period of time or, for that matter, how those "issues" in any way implicated Joomla, per se?

2) A lot of people ask for advice and help with old, outdated versions of Joomla. It's an unfortunate sign of the times that people are reluctant to upgrade or obdurate in utilising old, outdated versions of Joomla. Remembering that the primary focus of this forum is to assist people with Joomla-related issues, irrespective of whether people have "issues" with Google or some other search engine, I think it's reasonable to suggest (politely, of course) that people should look at their existing setup and be encouraged to update old, outdated software.

Having made these points, I'm pleased to read that you've resolved your problems, that the problems were completely unrelated to J! 3.5.1 (from the looks of things), that you were able to address your concerns by a judicious mix of modifying your .htaccess and robots.txt file and by correcting a faulting alias menu item. Good to see. Cheers 8)

These factors notwithstanding, I still feel that you have a few questions you might like to give further consideration in order to assist you in case you have other issues in future.
https://www.kuneze.com/blog
I need your help to help reduce spam at the Joomla forum. You can help with your ideas, questions and opinions at viewtopic.php?f=7&t=974006. Together we can make a difference :)


Locked

Return to “Search Engine Optimization (Joomla! SEO) in Joomla! 2.5”