500 Internal Server error with URL rewriting

Discuss Search Engine Optimization in relation to Joomla! 2.5. This forum will also have discussions on SEF/SEO Joomla! 2.5 extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
Sundog108
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Thu Mar 22, 2012 4:42 pm

500 Internal Server error with URL rewriting

Post by Sundog108 » Tue Jan 22, 2013 6:27 pm

Hi,

I previously tried everything in the book to get URL rewriting to work (to remove the "index.php"), but was on a temporary url.

see this thread: http://forum.joomla.org/viewtopic.php?f ... 3#p2976883

I explained every change I'd made to htaccess and pasted view of the file currently.

Now my site is on its proper domain, but only the home page shows up when I have URL rewriting set to yes. The other pages give me an "Internal server error 500"

site is: www.vigrahasacredart.com
joomla 2.5

Why won't it work?

Thanks for any help.
Sundog

User avatar
pemaileditor
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Fri Nov 23, 2012 8:46 am
Contact:

Re: 500 Internal Server error with URL rewriting

Post by pemaileditor » Tue Jan 22, 2013 6:56 pm

Sundog108 wrote:Hi,

I previously tried everything in the book to get URL rewriting to work (to remove the "index.php"), but was on a temporary url.

see this thread: http://forum.joomla.org/viewtopic.php?f ... 3#p2976883

I explained every change I'd made to htaccess and pasted view of the file currently.

Now my site is on its proper domain, but only the home page shows up when I have URL rewriting set to yes. The other pages give me an "Internal server error 500"

site is: http://www.vigrahasacredart.com
joomla 2.5

Why won't it work?

Thanks for any help.
Sundog
Your server must not loaded mod_rewrite
-> Go to your site back END
-> Site
-> System information
-> PHP information tab, in Loaded Modules settings check if you see mod_rewrite.

If mod_rewrite is not loaded, you need to ask your server administrator to enable it.
Powerful Email Editor
Professional email editor for Joomla
http://www.powerfulemaileditor.com

User avatar
egrovesys
Joomla! Intern
Joomla! Intern
Posts: 67
Joined: Fri Jul 29, 2011 10:08 am
Location: New Hamshre USA
Contact:

Re: 500 Internal Server error with URL rewriting

Post by egrovesys » Wed Jan 30, 2013 9:56 am

You cannot stop index.php form appearing, just do redirection to the home page

s_shaffer
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Dec 01, 2010 9:24 pm

Re: 500 Internal Server error with URL rewriting

Post by s_shaffer » Tue Jul 16, 2013 12:34 am

One other tip the following may need to be activated in the .htaccess file:

Code: Select all

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /
Remove the # in front of the RewriteBase to activate relative paths.

tindramin
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Sep 25, 2013 1:45 pm

Re: 500 Internal Server error with URL rewriting

Post by tindramin » Sat Nov 28, 2015 1:58 pm

Hello everyone.
I have tested all the proposals you have suggested in this topic.
Nothing has worked and received 500 internal server error on any adjustments that are in this topic.
Found another solution that worked for me and maybe for you that no proposal has helped.
Had trouble with 2 pieces sites but now it is corrected and everything works as it should.

I changed to the following in the .htaccess file:

From:
# RewriteBase /

To:
RewriteBase /

Small adjustment, but works fine for the problem that I have received on these sites..

http://seohuset.se

http://alltomskonhet.nu



Hope it works out for you who have not found a solution yet!

Best Regards/Tony Holmqvist


Locked

Return to “Search Engine Optimization (Joomla! SEO) in Joomla! 2.5”