Page 1 of 1

Bullet Points not showing on Siteground template

Posted: Wed Jun 05, 2013 10:03 am
by jazz_mavericks
Hi all,

Hopefully I'm posting in the right place - always get nervous posting in new forums!

I'm using the free Siteground template, 'Imagination' (or j16-38) as a very basic site to replicate our company site with. You can see the original template here, http://www.siteground.com/template-prev ... und-j16-38 , as I am working on our site offline.

My problem is, that I can't get bullet points to display on lists in the main content. I have done loads of searching around, and tried various techniques, like changing 'list-style:none' to 'list-style:disc' and so on, but this didn't make a difference.

Another search, suggested adding something along the lines of a new CSS rule, kind of like:

.mailcol ul li {
list-style:disc;
}

but this didn't work either. In the back end, I've set all the formatting and menu options to use the discs, but still nothing.

Any ideas? I'm sure it is something simple, but I've been trying to sort it for so long, I fear I have gone in too many circles and confused myself!

Thanks in advance!

Re: Bullet Points not showing on Siteground template

Posted: Wed Jun 05, 2013 11:14 am
by guywalder
Hi,

I know it's not the most elegant way of doing things but here's a solution I encountered in one of the templates I was working on. They created a small PNG bullet image and inserted it in the CSS code.
The template was jm-business-marketing. Check it out, maybe you can copy their solution to your template. The CSS is reset.css and the png file called li-white.png.

Hope this helps and good lock.

Re: Bullet Points not showing on Siteground template

Posted: Wed Jun 05, 2013 1:01 pm
by jazz_mavericks
Thanks - will have a look :)

Re: Bullet Points not showing on Siteground template

Posted: Wed Jun 05, 2013 2:03 pm
by JTema
In template.css try to delete this line (at the upper)
ul{list-style:none;}

Re: Bullet Points not showing on Siteground template

Posted: Fri Jun 07, 2013 10:11 am
by jazz_mavericks
Nope - still no joy. Might just have to search for a better template and rework it. There are a few other formatting issues with this template, and it's beginning to get a little annoying!

Re: Bullet Points not showing on Siteground template

Posted: Mon Jun 10, 2013 12:43 pm
by HristoP
Hello,

The issue you're experiencing is all about css :) Try adding this:

.cont ul, {list-style: disk !important};

that should do the trick :)

Re: Bullet Points not showing on Siteground template

Posted: Thu Dec 05, 2013 12:39 am
by StevesJoomla
I'm having the same problem, no bullets showing using a siteground template and Joomla 3.2

What fixed it for me was adding the following to template.css just under the heading sizes

ul {
list-style:disc;
}

Re: Bullet Points not showing on Siteground template

Posted: Fri Aug 26, 2016 9:59 pm
by mikeli88
I have a similar problem with the template: siteground-j16-24.
Bullet items (list) are squeezed into one line. After testing everything I found on line and out of luck, I decided to debug it myself and found this working.

In the template CSS file: templates/siteground-j16-24/css/template.css,
look for this line:

.cont li {display:inline; margin:0 10px 0 0;}.maincol .cont {float: left; width: 522px;}

Change it to:

.cont li {}.maincol .cont {float: left; width: 522px;}

Save it. And test it.

If you can't find this line, then try to find anything that has display:inline. It is the display:inline statement that causes this problem. I don't know why this is used to remove the list function. But, after removing this line, it works for me. Now I can start appreciating SiteGround's great work.