Unable to upgrade template - will not install.

Everything to do with Joomla! 2.5 templates and templating.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
enovikoff
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 120
Joined: Tue Oct 17, 2006 5:58 pm
Location: Denver, CO
Contact:

Unable to upgrade template - will not install.

Post by enovikoff » Fri Aug 26, 2016 5:11 pm

I'm attempting to upgrade Joomla from 2.5.28 to 3.6 and have made it to the point where I have to upgradet eh template. I have a RocketTheme template called Panacea - a popular one. They recommend upgrading it before the Joomla auto-upgrade, they have instructions at http://www.rockettheme.com/forum/joomla ... =0#1170437

However, when I try to upgrade my current Panacea 1.6.6 template with the Extension Manager Install function, I get a blank screen with a little error message from nginx saying that there was an error... oh so helpful.

Under the covers I have:
Linux www.enki.co 2.6.32-642.3.1.el6.x86_64 #1 SMP Tue Jul 12 18:30:56 UTC 2016 x86_64
Database Version 5.5.50-38.0
Database Collation utf8_general_ci
PHP Version 5.4.23
Web Server nginx/1.4.4
WebServer to PHP Interface fpm-fcgi
Joomla! Version Joomla! 2.5.28 Stable [ Ember ] 10-December-2014 15:00 GMT
Joomla! Platform Version Joomla Platform 11.4.0 Stable [ Brian Kernighan ] 03-Jan-2012 00:00 GMT
User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36

The error.log for nginx has a cryptic error in it:
2016/08/24 14:22:04 [error] 8232#0: *821 upstream sent invalid status "-1 Copy failed" while reading response header from upstream, client: 172.17.17.12, server: enki.co, request: "POST /administrator/index.php?option=com_installer&view=install HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "devel.enki.co", referrer: " devel.enki.co/administrator/index.php?option=com_installer "

memory_limit is 256M, nginx and PHP set the maximum upload size to 20M.

Any ideas?

If I can't figure out what's going wrong, I guess my fallback position would be to set my current template to be one of the default ones and delete the Panacea template, then re-install it after the Joomla upgrade, but this means I have to reconfigure it completely from scratch, which is a *lot* of work AFAIK.

Thanks for your help!
Eric

Former software engineer and web startup development director now following his Dharma in building a cloud computing company (build-to-order data centers and related services).

Locked

Return to “Templates for Joomla! 2.5”