Override TinyMCE theme mode per-page?

This forum is for general questions about extensions for Joomla! 2.5.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
lifo101
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jan 21, 2011 3:07 pm

Override TinyMCE theme mode per-page?

Post by lifo101 » Thu Feb 03, 2011 1:31 pm

I'm using J1.6 and I'm trying to find a way to customize the theme from "advanced" to "simple" on certain pages for the tinyMCE editor. Normally I want the advanced theme used, but for certain fields in my interface I only need some simple formatting options and I don't want to waste space by having a 3 line toolbar for every input on a page.

Any thoughts?

 
angrias
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Jan 27, 2011 10:19 pm

Re: Override TinyMCE theme mode per-page?

Post by angrias » Thu Feb 03, 2011 11:04 pm

I had a similar issue where the editor was garbling up my brackets for certain plugins. I was able to solve it by using JCE (Joomla! Content Editor) its a super rich / user friendly interface but it also has script color coding in the HTML edit screen.

Find out more here: http://www.joomlacontenteditor.net/

*edit: But to answer the question, as far as I know there is no per page way to enable / disable an editor.

Hope that helps.

lifo101
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jan 21, 2011 3:07 pm

Re: Override TinyMCE theme mode per-page?

Post by lifo101 » Fri Feb 04, 2011 12:32 am

Thanks for the suggestion. I had looked briefly at JCE but it didn't look like it was updated for 1.6 yet so I didn't bother trying it. Maybe I'll give it a shot. But as a suggestion to the dev team it would be nice to be able to provide an attribute for the "editor" form type to specify the theme to use for each field.

 

Locked

Return to “Extensions for Joomla! 2.5”