K2 Items not showing in frontend

This forum is for general questions about extensions for Joomla! 2.5.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
KizakiHero
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon May 28, 2012 8:14 pm

K2 Items not showing in frontend

Post by KizakiHero » Mon May 28, 2012 8:15 pm

I was really surprised when I realised that K2 didn't show my articles in the frontend! I created an item and put it into a sub-category but it disappeared. I also tried to make a direct link in the menu to the article but i got 404 error. I can see it in the backend but not in the frontend
Here it is the website, the article had to be in Windows\Utility
www.testing.softwarebay.it/

User avatar
designerweb
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 124
Joined: Fri Apr 08, 2011 9:19 pm
Contact:

Re: K2 Items not showing in frontend

Post by designerweb » Mon May 28, 2012 8:53 pm

To make K2 articles to display in frontpage just do the following

Components -> K2 -> Items and then click on the Featured icon beside the Item you want to display in the Front Page and it will change from Red to Green icon.

All the best, i hope it will help you. If you need any further assistance please feel free to contact.

Thank you and take care. :)
ColourDrift is a distinguished design and development studio providing a wide range of organized and well-presented, creative Web Design
Website:- http://www.colourdrift.com

KizakiHero
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon May 28, 2012 8:14 pm

Re: K2 Items not showing in frontend

Post by KizakiHero » Mon May 28, 2012 9:03 pm

designerweb wrote:To make K2 articles to display in frontpage just do the following

Components -> K2 -> Items and then click on the Featured icon beside the Item you want to display in the Front Page and it will change from Red to Green icon.

All the best, i hope it will help you. If you need any further assistance please feel free to contact.

Thank you and take care. :)
I don't want to have them on the homepage, i just want to be able to see them!
The problem is that I can't view them in any way, but I noticed something strange. Clicking on my username I can see all the articles that i published, that is the only place where I can see my articles in the frontend. The strange fact is that next to the titles there is written "Unpublished", but in the backend I can see that they are published. I tried to follow your procedure and some articles appeared but not all of them. I hope you understand what is the problem, I am Italian so my English isn't perfect :(

User avatar
designerweb
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 124
Joined: Fri Apr 08, 2011 9:19 pm
Contact:

Re: K2 Items not showing in frontend

Post by designerweb » Mon May 28, 2012 9:14 pm

Can you please explain the problem in detail so that i can help. And if possible please provide some screenshots it will help to recognize the problem.

Thank you and all the best.
ColourDrift is a distinguished design and development studio providing a wide range of organized and well-presented, creative Web Design
Website:- http://www.colourdrift.com

KizakiHero
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon May 28, 2012 8:14 pm

Re: K2 Items not showing in frontend

Post by KizakiHero » Mon May 28, 2012 9:26 pm

So, I write an article an I save it with the K2 editor. I can see it as published in the backend but if I go to the frontend it says it's unpublished.
In the screenshot you can see that in the frontend there's written "Pubblicato" that means "Published" and in the backend there's written "Non pubblicato" that means "Unpublished".
You do not have the required permissions to view the files attached to this post.

User avatar
designerweb
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 124
Joined: Fri Apr 08, 2011 9:19 pm
Contact:

Re: K2 Items not showing in frontend

Post by designerweb » Tue May 29, 2012 6:34 am

I have checked your site but Windows 8 Consumer Preview is published in the front-end. So i can get what is the problem. Sorry please don't mind

All the best and take care.
ColourDrift is a distinguished design and development studio providing a wide range of organized and well-presented, creative Web Design
Website:- http://www.colourdrift.com

KizakiHero
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon May 28, 2012 8:14 pm

Re: K2 Items not showing in frontend

Post by KizakiHero » Tue May 29, 2012 7:44 pm

designerweb wrote:I have checked your site but Windows 8 Consumer Preview is published in the front-end. So i can get what is the problem. Sorry please don't mind

All the best and take care.
Ok, I noticed that it's working BUT the articles are published about five hours after i save them!!
It could be a cache problem but how to solve it?
Thank you for your help :)

User avatar
designerweb
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 124
Joined: Fri Apr 08, 2011 9:19 pm
Contact:

Re: K2 Items not showing in frontend

Post by designerweb » Wed May 30, 2012 8:35 pm

Yeah! I also think that it is a cache problem. You can clear the cache in Joomla 2.5 in the following way
Site -> Maintenance -> Clear Cache

All the best and take care buddy. :)
ColourDrift is a distinguished design and development studio providing a wide range of organized and well-presented, creative Web Design
Website:- http://www.colourdrift.com

KizakiHero
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon May 28, 2012 8:14 pm

Re: K2 Items not showing in frontend

Post by KizakiHero » Wed May 30, 2012 8:38 pm

designerweb wrote:Yeah! I also think that it is a cache problem. You can clear the cache in Joomla 2.5 in the following way
Site -> Maintenance -> Clear Cache

All the best and take care buddy. :)
I know but it doesn't work. I also tried to use Cache Cleaner but it doesn't solve the problem.

User avatar
designerweb
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 124
Joined: Fri Apr 08, 2011 9:19 pm
Contact:

Re: K2 Items not showing in frontend

Post by designerweb » Wed May 30, 2012 8:51 pm

You can check out the link below

https://www.gavick.com/documentation/jo ... ce-plugin/

Thank you. :)
ColourDrift is a distinguished design and development studio providing a wide range of organized and well-presented, creative Web Design
Website:- http://www.colourdrift.com

KizakiHero
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon May 28, 2012 8:14 pm

Re: K2 Items not showing in frontend

Post by KizakiHero » Wed May 30, 2012 9:01 pm

designerweb wrote:You can check out the link below

https://www.gavick.com/documentation/jo ... ce-plugin/

Thank you. :)
I had already activated GK plugins for cache, also in the template and they don't solve anything.
Thank you for answering me so fast :D

citydan
Joomla! Intern
Joomla! Intern
Posts: 98
Joined: Mon May 11, 2009 3:00 am
Contact:

Re: K2 Items not showing in frontend

Post by citydan » Fri Jul 06, 2012 8:18 pm

I am having a similar problem:

I have installed K2, created categories, sub categories, tags, fields, field groups and sample items.

I have created menu items for K2 category view, K2 tag view and K2 Item view, but can not see any K2 content in the front-end of the site.

I have also created a joomla article and can't get it to show either. I've never seen this before and this is my 15th joomla site.

I don't get any errors, just blank pages. I can see all my content as expected in the back-end.

Caching is off.

I thought it might be a time zone problem, so I changed the created and published dates of my items and an article to 3 days ago, but it didn't help.

All K2 plugins are published.

I'm using Joomla 2.5.6
K2 v2.5.7
Web Server Apache
PHP version 5.2.17
MySQL version 5.0.92-log
Memory limit 128M

Does anyone have any suggestions on what else to check? I'm using the same hosting account as serveral other Joomla sites, so I know the hosting environment works.
Landscape Architecture Resource
everything useful for landscape architects
http://landscapearchitectureresource.com
jobs | schools | materials | news | firms | lare

locolbd
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Nov 14, 2005 9:01 pm

Re: K2 Items not showing in frontend

Post by locolbd » Fri Jul 20, 2012 9:21 am

okay i have been having this problem too. I posted something and it did not show up until four hours after.

What i noticed was that on the right side where it says creation, publish date and time was set about 3-4 hours ahead.

So I published an article around 2am PST but the publish and creation date and time were set for 5am. I am more than sure this is the issue.

If this works for you let me know!!!

silverrabbit
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Jan 06, 2013 2:17 am

Re: K2 Items not showing in frontend

Post by silverrabbit » Sun Jan 06, 2013 2:20 am

Clear the cookies in your browser, specifically websitetestlink.com which affects the login for Joomla. Clear the cookies, clear the cache, quit your application if you have to - something to do with the cookies.

notmyteddy
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Jan 06, 2012 2:51 pm

Re: K2 Items not showing in frontend

Post by notmyteddy » Sat Oct 19, 2013 9:46 pm

i ran into the same problem, and i sorted it out by going to the K2 menu item > advanced options > user settings > Selected users (sort with drag & drop).. I needed to select the users of whom the K2 items would be shown.

If someone else has this problem, hope this helps

axil42
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Sep 26, 2013 10:02 am

Re: K2 Items not showing in frontend

Post by axil42 » Tue Nov 05, 2013 12:45 pm

notmyteddy wrote:i ran into the same problem, and i sorted it out by going to the K2 menu item > advanced options > user settings > Selected users (sort with drag & drop).. I needed to select the users of whom the K2 items would be shown.

If someone else has this problem, hope this helps
I am having the same problem.
Where exactly is this path? I can't find it.

scpm123
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Jan 06, 2018 10:28 am

Re: K2 Items not showing in frontend

Post by scpm123 » Sat Jan 06, 2018 10:50 am

I'm with the same problem can anyone help?

User avatar
wwhite
Joomla! Explorer
Joomla! Explorer
Posts: 469
Joined: Wed Jul 30, 2008 4:40 am
Location: SC USA

Re: K2 Items not showing in frontend

Post by wwhite » Sat Jan 06, 2018 11:41 am

This is a long thread. Are you getting blank screen like some above?
Joomla - K2
Funeral Director - Every Day Above Ground is a Good Day!
Saying - This old world keeps spinning round, it a wonder tall trees aint laying down https://www.[youtube].com/watch?v=c_W9aaQ1Apo

scpm123
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Jan 06, 2018 10:28 am

Re: K2 Items not showing in frontend

Post by scpm123 » Sat Jan 06, 2018 7:23 pm

Yes. Only the body of the site appears. The K2 item does not appear.
Neither the title of the item

User avatar
wwhite
Joomla! Explorer
Joomla! Explorer
Posts: 469
Joined: Wed Jul 30, 2008 4:40 am
Location: SC USA

Re: K2 Items not showing in frontend

Post by wwhite » Sat Jan 06, 2018 7:45 pm

If the body of the site apears then you are not getting a blank screen.
Please try to create a new top level menu item of the type k2 item and point it to a single k2 item. Does the title and item text and image show like this. If this works, change it to a category view, and see if it acts as it should.
Check the menu item settings for show title etc
Check the category setting for the same
Does your template use a built in override for k2 that was shipped with it
Joomla - K2
Funeral Director - Every Day Above Ground is a Good Day!
Saying - This old world keeps spinning round, it a wonder tall trees aint laying down https://www.[youtube].com/watch?v=c_W9aaQ1Apo


Post Reply

Return to “Extensions for Joomla! 2.5”