Page 1 of 1

joomla errors

Posted: Thu Oct 05, 2017 6:21 pm
by angie_s
Hello! From Joomla! error reporting i got the following lines.
What is it about?
The main and most important problem of the site is that many K2 items don't open returning an http error 500.

Can someone help me please?!

Thank you!


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/synehizo/public_html/libraries/joomla/filter/input.php on line 652

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/synehizo/public_html/libraries/joomla/filter/input.php on line 654

Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in /home/synehizo/public_html/libraries/joomla/string/string.php on line 28

Deprecated: iconv_set_encoding(): Use of iconv.input_encoding is deprecated in /home/synehizo/public_html/libraries/joomla/string/string.php on line 29

Deprecated: iconv_set_encoding(): Use of iconv.output_encoding is deprecated in /home/synehizo/public_html/libraries/joomla/string/string.php on line 30

Strict Standards: Only variables should be assigned by reference in /home/synehizo/public_html/plugins/system/rokextender/rokextender.php on line 32

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/synehizo/public_html/libraries/joomla/filter/input.php on line 652

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/synehizo/public_html/libraries/joomla/filter/input.php on line 654

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/synehizo/public_html/libraries/joomla/filter/input.php on line 652

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/synehizo/public_html/libraries/joomla/filter/input.php on line 654

Re: joomla errors

Posted: Thu Oct 05, 2017 7:10 pm
by jackrabbit
Is your K2 updated to 2.7.1? The php version at your host most likely have been updated so your site now throws error from deprecated coding. You can also turn off error reporting in Global Configuration > Server

Do consider updating to Joomla 3.8

Re: joomla errors

Posted: Thu Oct 05, 2017 7:20 pm
by angie_s
There is no option for now for any update.
How can I solve this?

Re: joomla errors

Posted: Thu Oct 05, 2017 7:59 pm
by jackrabbit
Do you mean your admin area does not display? If it is displayed, download the K2 file at https://getk2.org/ and install normally with the extension manager.

If the admin is not displayed, what was the last thing you did before the error occurred? It most likely is that your host updated the server side php application.

Re: joomla errors

Posted: Thu Oct 05, 2017 8:23 pm
by angie_s
Everything works fine. The problem occurs when we try to open a K2 item and it doesn't open. Well, not all but the most recent.

Try visit synehizo.org and open the first article from the list below the four images.

Re: joomla errors

Posted: Thu Oct 05, 2017 9:19 pm
by jackrabbit
All good, but you haven't confirmed that K2 is up to date. Do the steps noted in the previous post to update K2 otherwise I can't determine where the error could lie.

Re: joomla errors

Posted: Thu Oct 05, 2017 9:24 pm
by angie_s
No it's not updated.

Re: joomla errors

Posted: Thu Oct 05, 2017 9:34 pm
by jackrabbit
Also check your K2 trash to see if there may be items with duplicate aliases. Early versions of K2 had that flaw to allow multiple items with similar alias and the error you have is typical to what was happening then. The new version has eliminated that. You should just entirely empty the K2 trash just to be sure.

Re: joomla errors

Posted: Thu Oct 05, 2017 10:18 pm
by mbabker
This error message was fixed in core for both Joomla 2.5 and 3.x when PHP 5.5 support was finalized. This means you are not running the latest Joomla release and need to update core. Note that Joomla 2.5.28 (the last 2.5 release) will work OK on PHP 5.6 but PHP 7 is not officially supported (and Joomla 2.5 may not run at all or incorrectly).