Page 1 of 1

Need a EU cookie consent extension for J 2.5

Posted: Fri Nov 09, 2018 7:35 pm
by blues_mack
Hello everybody.

I need some free EU cookie consent extension for J2.5. I have one site that runs on that system, and it's too complicated and unnecessary to upgrade it to 3.0, since the client will not stick to it for another year or so.

Unfortunately, all extensions for J 2.5 seems to be removed from Joomla.org.

Can somebody help, please?

Re: Need a EU cookie consent extension for J 2.5

Posted: Fri Nov 09, 2018 7:55 pm
by sozzled
blues_mack wrote:
Fri Nov 09, 2018 7:35 pm
I need some free EU cookie consent extension for J2.5.
Why does it have to be free? Actually, your client feels they "need" this, not you.

blues_mack wrote:
Fri Nov 09, 2018 7:35 pm
I have one site that runs on [J! 2.5], and it's too complicated and unnecessary to upgrade it to 3.0, since the client will not stick to it for another year or so.
Then, if it's "too complicated" for you, give the job to someone else. Let them worry about the complexity. Saying that it's "unnecessary" to upgrade a J! 2.5 site to J! 3.x is an comment not supported by the evidence. It's like saying that it's "unnecessary" to do anything about global warming because governments refuse to listen to the experts. If your client wants to stay with J! 2.5 for "another year or so" then let them worry about the consequences.

J! 2.5 is dead! It has been dead for four years. If people want to use outdated technology then they do it at their own risk. The world has moved on but some people want to live in the past. All J! 2.5 extensions were removed from the JED; this isn't "unfortunate"; the removal was clearly signposted and the removal occurred after an extensive publicity campaign. People were told, over a period of a couple of years, that the JED would remove J! 2.5 extensions.

The EU cookie consent "matter" was promulgated by regulation in 2011. This is not a "new" thing. This requirement came into effect seven years ago.

Re: Need a EU cookie consent extension for J 2.5

Posted: Fri Nov 09, 2018 9:53 pm
by blues_mack
Sozzled, if you don't have intention to help, please rather save your time. And mine. Thanks. J 2.5 site is my risk, not yours.

Re: Need a EU cookie consent extension for J 2.5

Posted: Fri Nov 09, 2018 11:49 pm
by Webdongle
@blues_mack he would be irresponsible if he did not warn you of the risks of running a vulnerable version of Joomla. We (the volunteers on the forum) have all sorts of excuses for not updating Joomla but it useually comes done to one of three reasons:
1. The owner/developer is too lazy to look for alternative extensions for the newer Joomla version.
2. The developer did not factor in maintaining the site into their original quote.
3. The site owner is to stingy to pay for maintenance of their site.

Joomla 2.5 is eol and end of support

Re: Need a EU cookie consent extension for J 2.5

Posted: Sat Nov 10, 2018 7:44 am
by blues_mack
Third one. He doesn't even understand what I'm telling him about.

It's clear to me that J 2.5 is obsolete, and all the risk is mine. This is Joomla community forum, not an extension directory.

Every single point from the sozzled's reply is clear to me, but that does not help much.

Re: Need a EU cookie consent extension for J 2.5

Posted: Sat Nov 10, 2018 8:28 am
by Per Yngve Berg
I can only suggest searching the JED for extensions that have been there for a while. Then visit the vendor's site and see if a 2.5 version is available. I believe the laws and these extensions have been added after 2.5 was the latest main version.

PS. You know that the site will cease to work when your host is removing php 5.6 from the server? It will not work with php 7.x.

Re: Need a EU cookie consent extension for J 2.5

Posted: Sat Nov 10, 2018 9:20 am
by Webdongle
blues_mack wrote:
Sat Nov 10, 2018 7:44 am
Third one. He doesn't even understand what I'm telling him about. ...
Perhaps change the php on the server to 7.x ? You could then tell the client that the Host updated the php and now the site (because it's old) no longer works. Perhaps he will understand that ?

Other than that https://extensions.joomla.org/extension ... ie-notify/
Compatible with Joomla 1.5.x , 2.5.x , 3.x.x

https://www.smartaddons.com/tags/top-8- ... for-joomla but would suggest you find them on JED (and check the developers site) rather than download from that link.

Addendum
A couple of other options

#a ... Give them a price for updating the site and a bigger one for adapting an extension to run on an obsolete site.

#b ... Create a page that has details of how they handle data, cookies etc. (Suggest they do the wording).
Then use a popup window (with a link to the privacy policy) stating the site uses cookies. There are extensions for that.


btw
In my experience, site owners who fail to see the importance of updating ... usually say (when they get hacked) that it was not made clear to them.

An email sent to them (when they have been told) is a good 'told you so and even sent you an email at the time). :laugh:

Re: Need a EU cookie consent extension for J 2.5

Posted: Mon Nov 12, 2018 1:09 pm
by blues_mack
Per Yngve Berg wrote:
Sat Nov 10, 2018 8:28 am
I can only suggest searching the JED for extensions that have been there for a while. Then visit the vendor's site and see if a 2.5 version is available. I believe the laws and these extensions have been added after 2.5 was the latest main version.

PS. You know that the site will cease to work when your host is removing php 5.6 from the server? It will not work with php 7.x.
I've tried on a vendor's sites, with no luck so far.

It looks like I have to convince him to upgrade.

Meanwhile, if someone find that extension in archive, I'll be grateful.

Re: Need a EU cookie consent extension for J 2.5

Posted: Mon Nov 12, 2018 1:22 pm
by Webdongle
https://extensions.joomla.org/extension ... tive-lite/
Their download has versions for 2.5

Re: Need a EU cookie consent extension for J 2.5

Posted: Mon Nov 12, 2018 1:31 pm
by blues_mack
Webdongle wrote:
Mon Nov 12, 2018 1:22 pm
https://extensions.joomla.org/extension ... tive-lite/
Their download has versions for 2.5
Thank you!

Re: Need a EU cookie consent extension for J 2.5

Posted: Mon Nov 12, 2018 1:46 pm
by Webdongle
You could have found that yourself.