Fancybox strict standard

This forum is for general questions about extensions for Joomla! 2.5.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
qiuguat_123
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue Apr 02, 2019 12:39 pm

Fancybox strict standard

Post by qiuguat_123 » Wed Apr 03, 2019 9:30 am

Hi all,

currently im facing this error

Strict Standards: Declaration of fancyboxClass::getHeaderLibrary() should be compatible with JAPopupHelper::getHeaderLibrary($bodyString, $identifierString, $headerString) in C:\xampp\htdocs\Demo\plugins\system\japopup\fancybox\fancybox.php on line 18

my current environment is
JOOMLA : 2.5.28
PHP version : 5.6.8
DB version : 5.6.24
Apache : 2.4.12

i'm using T3 framework 2.7.4 and purity III template.

May i know what is causing this error to happen? Is it template not compatible ? Or do i need update to 3.5.1 JOOMLA then only this error will be gone?
because i would like to make sure there is no any errors / warnings in current version of joomla in order to avoid the same errors / warning happen in the next joomla version.

gws
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3811
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: Fancybox strict standard

Post by gws » Wed Apr 03, 2019 9:48 am

Current joomla is 3.9.4 php should be 7.2.x or better.Probably many of your plugins ,templates etc will need updating. See viewtopic.php?f=710&t=793171 for a guide how to update.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11122
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK

Re: Fancybox strict standard

Post by toivo » Wed Apr 03, 2019 9:59 am

Are you using the latest version of the JA Popup Plugin, released on 20 Dec 2017? The latest version is likely to have fixed the Strict Standards error (not tested).

Otherwise use the following instructions to filter Strict Standards messages:
https://www.balbooa.com/knowledgebase/3 ... -in-joomla

Before updating to 3.5.1 and beyond, your third party extensions need to be uptodate, disabled or uninstalled, if you are unable to find a version that supports 3.x.

If your site is on your workstation on XAMPP, make a backup first using an older version of Akeeba Backup and then do a trial upgrade.

As @gws pointed out, you should also update your local environment to be similar to remote live servers. You probably have to install a new version of XAMPP, if it supports only one version of PHP at a time, or install Wampserver, which allows you to switch between PHP versions.
Toivo Talikka, Global Moderator
troubleshooting smtp and other articles http://talikka.com/joomla

qiuguat_123
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue Apr 02, 2019 12:39 pm

Re: Fancybox strict standard

Post by qiuguat_123 » Thu Apr 04, 2019 6:15 am

gws wrote:
Wed Apr 03, 2019 9:48 am
Current joomla is 3.9.4 php should be 7.2.x or better.Probably many of your plugins ,templates etc will need updating. See viewtopic.php?f=710&t=793171 for a guide how to update.
Yea i would like to try update as latest as i can.

qiuguat_123
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue Apr 02, 2019 12:39 pm

Re: Fancybox strict standard

Post by qiuguat_123 » Thu Apr 04, 2019 7:29 am

toivo wrote:
Wed Apr 03, 2019 9:59 am
Are you using the latest version of the JA Popup Plugin, released on 20 Dec 2017? The latest version is likely to have fixed the Strict Standards error (not tested).

Otherwise use the following instructions to filter Strict Standards messages:
https://www.balbooa.com/knowledgebase/3 ... -in-joomla

Before updating to 3.5.1 and beyond, your third party extensions need to be uptodate, disabled or uninstalled, if you are unable to find a version that supports 3.x.

If your site is on your workstation on XAMPP, make a backup first using an older version of Akeeba Backup and then do a trial upgrade.

As @gws pointed out, you should also update your local environment to be similar to remote live servers. You probably have to install a new version of XAMPP, if it supports only one version of PHP at a time, or install Wampserver, which allows you to switch between PHP versions.
I believe that i am using the version that is older than the version that released on 20 Dec 2017.
I have try to disable the plugin and the error is missing.
My live server version of JOOMLA is still at 2.5.14. So now im trying to upgrade as latest as i could.

By the way, is there any plugin that is free and can replace this JA pop up plugin?
Is there still have any free template that is able compatible with T3 framework ?
So far i tried, purify III is the best suit to T3 framework. So is there any other free template.

qiuguat_123
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue Apr 02, 2019 12:39 pm

Re: Fancybox strict standard

Post by qiuguat_123 » Thu Apr 04, 2019 7:32 am

toivo wrote:
Wed Apr 03, 2019 9:59 am
Are you using the latest version of the JA Popup Plugin, released on 20 Dec 2017? The latest version is likely to have fixed the Strict Standards error (not tested).

Otherwise use the following instructions to filter Strict Standards messages:
https://www.balbooa.com/knowledgebase/3 ... -in-joomla

Before updating to 3.5.1 and beyond, your third party extensions need to be uptodate, disabled or uninstalled, if you are unable to find a version that supports 3.x.

If your site is on your workstation on XAMPP, make a backup first using an older version of Akeeba Backup and then do a trial upgrade.

As @gws pointed out, you should also update your local environment to be similar to remote live servers. You probably have to install a new version of XAMPP, if it supports only one version of PHP at a time, or install Wampserver, which allows you to switch between PHP versions.
Probably the JA Popup plugin is older than the release date that you mentioned.

Thank you for the suggestions. As this is my first time using Joomla, i would like to try all the opinion that suggested here.

Thanks alot. Really appreciate it.


Post Reply

Return to “Extensions for Joomla! 2.5”