Minimum permissions required for a database user to run site

Discussion regarding Joomla! 2.5 security issues.

Moderators: Bernard T, mandville, fcoulter, PhilD, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant / FPA - If you are serious about wanting help, you will use this tool to help you post.
Locked
harvarinder
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun May 17, 2009 9:38 pm

Minimum permissions required for a database user to run site

Post by harvarinder » Fri Apr 15, 2011 4:11 am

Hi Guys,

What are the minimum permissions required by user on mySQL Database or any other database so that it can cater the requests from joomla application.

I believe those permission will be, I will be using mySQL:

select
inset
update
delete

Let me know if Joomla have got the set of minimum permissions required by user for the site.
Please note that http://docs.joomla.org/Category:Security_Checklist do not provide what I want.

Any help will be greatly appreciated.
Thank you.
--Harvey

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22278
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Minimum permissions required for a database user to run

Post by pe7er » Fri Apr 15, 2011 7:52 am

SELECT, INSERT, UPDATE, DELETE are indeed required for normal usage.
If you want to install new components (which need to create new tables) you will also need CREATE and DROP and maybe ALTER (for components that need to update their old tables when upgrading).
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

harvarinder
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun May 17, 2009 9:38 pm

Re: Minimum permissions required for a database user to run

Post by harvarinder » Fri Apr 15, 2011 8:42 am

Thanks for the information.


Locked

Return to “Security in Joomla! 2.5”