file_get_content... Failed to open stream...

Discussion regarding Joomla! 2.5 security issues.

Moderators: Bernard T, mandville, fcoulter, PhilD, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant / FPA - If you are serious about wanting help, you will use this tool to help you post.
Locked
Yr3000
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Jan 16, 2015 10:07 pm

file_get_content... Failed to open stream...

Post by Yr3000 » Sat Jan 24, 2015 7:58 pm

I unpublished a module, then immediately republished it and now, on most page loads, the site loads slowly and shows this error along the top of the page:

Warning: file_get_contents(http://www.popculte.com/modules/mod_stats/432432.php) [function.file-get-contents]: failed to open stream: Connection timed out in /home/ariseia/ariseia.org/index.php on line 60

Can anyone decipher?

Just after it started, my browser, Chrome, refused to load the site, instead displaying a canned screen, all red, with ominous warnings of hackers hacking, but we're a non-profit with no valuable info... not a likely target. I contacted my web host, but they didn't see a problem... simply recommended that I turn on caching on the site, but that seems more band-aid than antidote.

I backed up the site using XCloner just the day before the problem began, but it would appear that the backup protocol is smarter than I am... I don't really understand what I'm supposed to do to restore the site, and flying blind seems like a bad idea.

Any guidance is appreciated (this is my first post, so be gentle) -- thanks.
Last edited by imanickam on Sun Jan 25, 2015 3:27 am, edited 1 time in total.
Reason: Moved the topic from the forum Administration Joomla! 2.5 to the forum Security in Joomla! 2.5

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11199
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: file_get_content... Failed to open stream...

Post by toivo » Sat Jan 24, 2015 8:21 pm

Just after it started, my browser, Chrome, refused to load the site, instead displaying a canned screen, all red, with ominous warnings of hackers hacking
Chrome was right because:
1) Joomla 2.5 has the a core folder called modules/mod_stats but the file 432432.php should not be there
2) the file index.php has only 54 lines, not 60 - it is obvious that malicious code has been added to it

Your XCloner backup will become handy, but you should also go to the Security forum at http://forum.joomla.org/viewforum.php?f=621 and study the announcements and sticky topics at the top of the forum, post the FPA output so that you can get advice from the experts which extension may be vulnerable.
Toivo Talikka, Global Moderator

Yr3000
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Jan 16, 2015 10:07 pm

Re: file_get_content... Failed to open stream...

Post by Yr3000 » Sat Jan 24, 2015 9:08 pm

Thanks very much, toivo, for your response. Sorry, what's FPA?

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11199
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: file_get_content... Failed to open stream...

Post by toivo » Sat Jan 24, 2015 9:36 pm

FPA is Forum Post Assistant which documents the server configuration and the extensions installed at the site, among other details. You will find the user instructions and a download link in one of the sticky posts.
Toivo Talikka, Global Moderator

Yr3000
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Jan 16, 2015 10:07 pm

Re: file_get_content... Failed to open stream...

Post by Yr3000 » Sat Jan 24, 2015 9:42 pm

Excellent -- thank you very much for your help.


Locked

Return to “Security in Joomla! 2.5”