Trouble installing website backup on localhost

Need help installing Joomla! 2.5? For all Joomla! 2.5 installation issues please use this forum. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Kamal_149
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Jun 13, 2018 4:09 pm

Trouble installing website backup on localhost

Postby Kamal_149 » Thu Jun 14, 2018 12:34 am

I’m trying to get some Joomla sites running on my localhost (osx Yosemite 10.10.5) and have not been able to achieve this so far. I have installed version of XAMPP relative to Joomla version installed on website (XAMPP 5.3.36 for Joomla 3.5 with PHP 5.6.36). I have only worked on live Joomla sites, so this is the first time developing on localhost. I would really appreciate some experienced advice.
These have been the 2 processes I have tried so far:

Process 1 using Akeeba

1. Login to Joomla Admin and backup site using latest Akeeba backup
2. Download Backup via cPanel
3. Download Akeeba Kickstart
4. Download and install XAMPP-osx 5.6.36
5. Launch XAMPP app and start all servers
6. Copy website backup (jpa file) and kickstart.php to empty folder XAMPP/xamppfiles/htdocs/website
7. Edit Sharing & Permissions to Read & Write for all enclosed items in folder
8. In browser (Chrome) go to http://localhost/website/kickstart.php
9. Using default settings start extraction
10. Enter Database server host name: localhost, user name: root and db name) – database is restored successfully
11. Site set up default remains the same – when prompted click Clean Up
12. Click “Visit your site’s frontend” and I get 404 error message
13. When I click on “Visit your site’s backend” I get a blank white screen

Process 2 without Akeeba

1. Go to website cPanel and download all files in public_html and corresponding sql database
2. Copy public_html folder to XAMPP/xamppfiles/htdocs/ and rename folder (eg website_2)
3. Edit Sharing & Permissions to Read & Write for all enclosed items in folder
4. Launch XAMPP app and start all servers
5. Go to localhost/phpmyadmin and create a new database matching sql file downloaded and import file
6. In website root folder (website_2) edit configuration.php as follows:

- public $user = 'root'
- public $password = '';
- public $db = 'database_name’;
- public $log_path = '/Applications/XAMPP/xamppfiles/htdocs/website_2/log';
- public $tmp_path = '/Applications/XAMPP/xamppfiles/htdocs/website_2/tmp';
- public $cookie_domain = '';
- public $cookie_path = '';

7. In browser (Chrome) go to http://localhost/website_2 and I get the same 404 error message
8. When I go to http://localhost/website_2/administrator I get a blank white screen

I have tried both processes with a couple of Joomla sites – both failing to load up once installed on localhost using XAMPP – I have also tried using AMPP and I got less further as it wouldn’t recognise sql databases (tried various fixes that got me nowhere). Tried using MAMP, which installed everything, but again showed error in browser.

Any help in getting this resolved would be massively appreciated… THANK YOU!

jdran
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 180
Joined: Thu Aug 16, 2012 5:32 pm

Re: Trouble installing website backup on localhost

Postby jdran » Fri Jun 15, 2018 8:18 am

My first guess (without being an expert) is that there's possibly a bug with Yosemite.
Check Jose Torres' answer here:
https://stackoverflow.com/questions/138 ... ing-in-osx
but I have a feeling it won't help you.. at least I hope it will gives you a direction?
Have you tried moving the website to another server online and not locally?


Return to “Installation Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 5 guests