Page 1 of 2

[Help] Strict Standards error after installing

Posted: Wed Jul 20, 2011 6:09 pm
by Junior_Soares
I`m getting these error messages when I load my page.

Code: Select all

Strict Standards: Static function JDatabase::test() should not be abstract in C:\Desenvolvimento\EasyPHP\www\joomla\libraries\joomla\database\database.php on line 350

Strict Standards: Accessing static property JCache::$_handler as non static in C:\Desenvolvimento\EasyPHP\www\joomla\libraries\joomla\cache\cache.php on line 394

Strict Standards: Accessing static property JCache::$_handler as non static in C:\Desenvolvimento\EasyPHP\www\joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in C:\Desenvolvimento\EasyPHP\www\joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in C:\Desenvolvimento\EasyPHP\www\joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in C:\Desenvolvimento\EasyPHP\www\joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in C:\Desenvolvimento\EasyPHP\www\joomla\libraries\joomla\cache\cache.php on line 394

Strict Standards: Accessing static property JCache::$_handler as non static in C:\Desenvolvimento\EasyPHP\www\joomla\libraries\joomla\cache\cache.php on line 396
I tried to edit configuration.php in joomla directory...setting public $error_reporting = '0';
But I keep getting that same error messages. I`m using EasyPHP-5.3.6.1. What should I do? Thanks.

Re: [Help] Strict Standards error after installing

Posted: Thu Jul 21, 2011 10:13 am
by camaris
I had the same problem. It's overzealous error reporting. You need to change your php.ini file so it won't display it. This is the link I used to figure it out:

http://forum.joomla.org/viewtopic.php?t=271244

I changed it to match code displayed in Nik_c's post (about the 15th post down). Depending on where you installed it local computer, shared server, etc. the php.ini file may be in different locations - http://forum.joomla.org/viewtopic.php?f=429&t=350630

I installed it on my local computer using XAMPP and this is what I did to correct it:

Typed in C:\xampp\php\php.ini in the file directory and it brought the php.ini file up in notepad. Had to scroll down quite a ways to the Error Handling and Logging section

changed this:

error_reporting = E_ALL | E_STRICT

to this:

error_reporting = E_ALL & ~E_NOTICE

And changed this:

display_errors = On

To this:

display_errors = Off

That did the trick. Should work for you, you'll just need to locate your file.

Re: [Help] Strict Standards error after installing

Posted: Thu Jul 21, 2011 12:08 pm
by Junior_Soares
That worked!
Thank you very much for helping.

Re: [Help] Strict Standards error after installing

Posted: Thu Jul 21, 2011 1:04 pm
by camaris
You're welcome. :)

Re: [Help] Strict Standards error after installing

Posted: Fri Jul 22, 2011 3:52 pm
by BigFerret
Strangely this is not fixing it on my box. I have the same issue, but changing the reporting and display errors is having no effect?

Re: [Help] Strict Standards error after installing

Posted: Fri Jul 22, 2011 4:04 pm
by camaris
Perhaps try to simply change your error reporting in the global configuration to 'none' or 'simple' (I think its under your site settings tab) and see if that works. That would be my only other suggestion, if that doesn't work maybe read through this old post to see if they have any other suggestions, it was for 1.5 but helped me:

http://forum.joomla.org/viewtopic.php?t=271244

Re: [Help] Strict Standards error after installing

Posted: Fri Jul 22, 2011 4:43 pm
by BigFerret
Thanks for the link. I changed this line in the configuration.php file:
$error_reporting = '-1';
-to-
$error_reporting = '6135';

Not entirely sure why this works now, but it does... so far :)

Thanks again.

Re: [Help] Strict Standards error after installing

Posted: Sun Jul 24, 2011 10:50 pm
by lolocandy
BigFerret wrote:Thanks for the link. I changed this line in the configuration.php file:
$error_reporting = '-1';
-to-
$error_reporting = '6135';

Not entirely sure why this works now, but it does... so far :)

Thanks again.
Thank you very much, I just follow your steps and I alreay fix the issue too. honestly i dont know why it works now, hopefully someone could explain a little :D

Re: [Help] Strict Standards error after installing

Posted: Tue Jul 26, 2011 2:56 am
by jrkahrhoff
Changing the Global settings worked for me - I wonder if this is just a windows issue...would love to hear from an expert on the issue!

Re: [Help] Strict Standards error after installing

Posted: Tue Jul 26, 2011 8:19 am
by ozista
camaris wrote:I had the same problem. It's overzealous error reporting. You need to change your php.ini file so it won't display it. This is the link I used to figure it out:

http://forum.joomla.org/viewtopic.php?t=271244

I changed it to match code displayed in Nik_c's post (about the 15th post down). Depending on where you installed it local computer, shared server, etc. the php.ini file may be in different locations - http://forum.joomla.org/viewtopic.php?f=429&t=350630

I installed it on my local computer using XAMPP and this is what I did to correct it:

Typed in C:\xampp\php\php.ini in the file directory and it brought the php.ini file up in notepad. Had to scroll down quite a ways to the Error Handling and Logging section

changed this:

error_reporting = E_ALL | E_STRICT

to this:

error_reporting = E_ALL & ~E_NOTICE

And changed this:

display_errors = On

To this:

display_errors = Off

That did the trick. Should work for you, you'll just need to locate your file.
That did the trick for me too! Thank you for a clear and concise solution. Ozista

Re: [Help] Strict Standards error after installing

Posted: Wed Jul 27, 2011 12:23 am
by jonmacias
I managed to change the display errors to off and also the error reporting to E_ALL & ~E_NOTICE
but yet i still get this message.
what do i do.
im new to this and i really have no idea what im doing but if someone could help me then i would be really appreciated.

thank you!

heres my error codes



Strict Standards: Static function JDatabase::test() should not be abstract in C:\xampp\htdocs\mysite\libraries\joomla\database\database.php on line 350

Strict Standards: Accessing static property JCache::$_handler as non static in C:\xampp\htdocs\mysite\libraries\joomla\cache\cache.php on line 394

Strict Standards: Accessing static property JCache::$_handler as non static in C:\xampp\htdocs\mysite\libraries\joomla\cache\cache.php on line 396

Re: [Help] Strict Standards error after installing

Posted: Thu Jul 28, 2011 5:34 am
by jrkahrhoff
I think you may be taking the more difficult path. In login to your admin and then go to global configuration and then to server settings. There you will see ERROR REPORTING. Simply change the level in this drop-down box!

Re: [Help] Strict Standards error after installing

Posted: Sun Jul 31, 2011 8:11 pm
by hieroglif
Maybe my post can help.

I had the same problem.
Then I realized that my Apache installation has been set without passwords for MySQL and Xampp.
After I have set those passwords "Strict standards" error disappeared without any intervention in php.ini


OS: Vista 64
Apache: 1.7.4
Joomla 1.7

Re: [Help] Strict Standards error after installing

Posted: Sun Jul 31, 2011 8:29 pm
by jrkahrhoff
Glad that worked for you hieroglif, but I have no idea why...their is no connection between security on your server and error reporting that I am aware of...

I think some of these gents may have a cache issue with their browser and/or after making their mods they may need to stop and then restart their server if running on localhost.

I hope we hear from more experienced developers on this issue!

Re: [Help] Strict Standards error after installing

Posted: Mon Aug 01, 2011 10:52 pm
by bluelightH
jrkahrhoff wrote:I think you may be taking the more difficult path. In login to your admin and then go to global configuration and then to server settings. There you will see ERROR REPORTING. Simply change the level in this drop-down box!
:p I can't believe this fixed the problem!!! that was so simply THANK YOU!

Re: [Help] Strict Standards error after installing

Posted: Tue Aug 02, 2011 12:31 pm
by edheal
Is it possible to correct the strict errors without resorting to changing the php.ini file?

Re: [Help] Strict Standards error after installing

Posted: Wed Aug 03, 2011 7:19 am
by edheal
Could the people that created the code ensure that the line endings are consistent. SVN complains otherwise.

Re: [Help] Strict Standards error after installing

Posted: Sat Aug 06, 2011 12:25 am
by raxy80
Here what worked for me (xampp and Joomla 1.7):
In php.ini file in line 516 add ; before "error_reporting = E_ALL | E_STRICT"
Save file and restart.

Re: [Help] Strict Standards error after installing

Posted: Sat Aug 06, 2011 6:07 am
by smokeybehr
I just did a clean install from scratch with Win2k8 Server R2/XAMPP/J1.7, and after doing the above two solutions, everything is running nice and smooth. Time to start putting everything together!

Re: [Help] Strict Standards error after installing

Posted: Sat Aug 06, 2011 6:25 am
by caprice
I have read this thread and the replies, tried all of the suggestions including the commenting-out of the E_ALL | E_STRICT line in php.ini and nothing works. I have Xampp /Mysql already set with passwords and I have turned off display errors in both the php.ini and the global config in the back-end.

I am getting 20 error messages on start-up and a similar number in the back-end administrator pages.

I am running Win XP and an Apache package inc.Xampp and MySQL

What is it with Joomla? I got tired of this sort of nonsense in Joomla 1.6 and went back to WordPress. Maybe Drupal will give me a better user experience?

Is there a definitive answer to this error reporting problem please?

Thanks

Re: [Help] Strict Standards error after installing

Posted: Sat Aug 06, 2011 4:28 pm
by edheal
I have made various changed to the code - I will noy make changes the php.ini file

Please could somebody PM/Email me to make those chanes into the current download.

Thanks.

Re: [Help] Strict Standards error after installing

Posted: Mon Aug 08, 2011 10:27 am
by sdpadre
lolocandy wrote:
BigFerret wrote:Thanks for the link. I changed this line in the configuration.php file:
$error_reporting = '-1';
-to-
$error_reporting = '6135';

Not entirely sure why this works now, but it does... so far :)

Thanks again.
Thank you very much, I just follow your steps and I alreay fix the issue too. honestly i dont know why it works now, hopefully someone could explain a little :D

This did it for me as well. But I do not know any code and I would think all this did was "hide" the problems/ THe error messages are still prevalent just not seen. (if this makes sense)

Re: [Help] Strict Standards error after installing

Posted: Mon Aug 08, 2011 1:18 pm
by edheal
I have found these corrects that remove some of the strict warnings. Have not found any other ones to date. If so please could you email me/pm me.

Thanks.

Ed

Index: J:/Projects/Experimental/administrator/components/com_content/models/article.php
===================================================================
--- J:/Projects/Experimental/administrator/components/com_content/models/article.php (revision 2)
+++ J:/Projects/Experimental/administrator/components/com_content/models/article.php (revision 3)
@@ -322,7 +322,7 @@

$table->reorder();

- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -347,7 +347,7 @@
*
* @since 1.6
*/
- protected function cleanCache()
+ protected function cleanAllCaches()
{
parent::cleanCache('com_content');
parent::cleanCache('mod_articles_archive');
Index: J:/Projects/Experimental/libraries/joomla/cache/cache.php
===================================================================
--- J:/Projects/Experimental/libraries/joomla/cache/cache.php (revision 2)
+++ J:/Projects/Experimental/libraries/joomla/cache/cache.php (revision 3)
@@ -31,7 +31,8 @@
* @var object Storage handler
* @since 11.1
*/
- public static $_handler = array();
+
+ private static $_handler = null;

/**
* @var Options
@@ -185,6 +186,7 @@
{
// Get the storage
$handler = $this->_getStorage();
+
if (!JError::isError($handler) && $this->_options['caching']) {
return $handler->getAll();
}
@@ -390,10 +392,10 @@
*/
public function &_getStorage()
{
- if (!isset($this->_handler)) {
- $this->_handler = JCacheStorage::getInstance($this->_options['storage'], $this->_options);
+ if (!isset(self::$_handler)) {
+ self::$_handler = JCacheStorage::getInstance($this->_options['storage'], $this->_options);
}
- return $this->_handler;
+ return self::$_handler;
}

/**
Index: J:/Projects/Experimental/libraries/joomla/form/form.php
===================================================================
--- J:/Projects/Experimental/libraries/joomla/form/form.php (revision 2)
+++ J:/Projects/Experimental/libraries/joomla/form/form.php (revision 3)
@@ -885,7 +885,8 @@
}

// Find the form field element from the definition.
- $element = & $this->findField($name, $group);
+ $field = $this->findField($name, $group);
+ $element = & $field;

// If the element doesn't exist return false.
if (!($element instanceof JXMLElement)) {

Re: [Help] Strict Standards error after installing

Posted: Mon Aug 08, 2011 1:33 pm
by edheal
Forgot one file

Index: J:/Projects/Experimental/libraries/joomla/database/database.php
===================================================================
--- J:/Projects/Experimental/libraries/joomla/database/database.php (revision 1)
+++ J:/Projects/Experimental/libraries/joomla/database/database.php (revision 5)
@@ -347,7 +347,7 @@
*
* @since 11.1
*/
- abstract public static function test();
+ //abstract public static function test();

/**
* Magic method to provide method alias support for quote() and quoteName().

Re: [Help] Strict Standards error after installing

Posted: Mon Aug 08, 2011 7:45 pm
by edheal
More fixes

Index: J:/Projects/Experimental/administrator/components/com_plugins/models/plugin.php
===================================================================
--- J:/Projects/Experimental/administrator/components/com_plugins/models/plugin.php (revision 7)
+++ J:/Projects/Experimental/administrator/components/com_plugins/models/plugin.php (revision 8)
@@ -321,7 +321,7 @@
*
* @since 1.6
*/
- function cleanCache() {
+ private function cleanAllCaches() {
parent::cleanCache('com_plugins', 0);
parent::cleanCache('com_plugins', 1);
}
Index: J:/Projects/Experimental/administrator/components/com_categories/models/category.php
===================================================================
--- J:/Projects/Experimental/administrator/components/com_categories/models/category.php (revision 7)
+++ J:/Projects/Experimental/administrator/components/com_categories/models/category.php (revision 8)
@@ -399,7 +399,7 @@
$this->setState($this->getName().'.id', $table->id);

// Clear the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -421,7 +421,7 @@
}

// Clear the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -445,7 +445,7 @@
}

// Clear the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;

@@ -770,7 +770,7 @@
*
* @since 1.6
*/
- protected function cleanCache()
+ protected function cleanAllCaches()
{
$extension = JRequest::getCmd('extension');
switch ($extension)
Index: J:/Projects/Experimental/administrator/components/com_menus/models/item.php
===================================================================
--- J:/Projects/Experimental/administrator/components/com_menus/models/item.php (revision 7)
+++ J:/Projects/Experimental/administrator/components/com_menus/models/item.php (revision 8)
@@ -302,7 +302,7 @@
}

// Clean the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -433,7 +433,7 @@
}

// Clean the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -983,7 +983,7 @@
}

// Clean the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -1099,7 +1099,7 @@
}

// Clean the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

if (isset($data['link'])) {
$base = JURI::base();
@@ -1135,7 +1135,7 @@
}

// Clean the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -1205,7 +1205,7 @@
}

// Clean the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -1239,7 +1239,7 @@
}

// Clean the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return parent::publish($pks,$value);
}
@@ -1279,7 +1279,7 @@
*
* @since 1.6
*/
- function cleanCache() {
+ private function cleanAllCaches() {
parent::cleanCache('com_modules');
parent::cleanCache('mod_menu');
}
Index: J:/Projects/Experimental/administrator/components/com_menus/models/menu.php
===================================================================
--- J:/Projects/Experimental/administrator/components/com_menus/models/menu.php (revision 7)
+++ J:/Projects/Experimental/administrator/components/com_menus/models/menu.php (revision 8)
@@ -203,7 +203,7 @@
$this->setState('menu.id', $table->id);

// Clean the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -235,7 +235,7 @@
}

// Clean the cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -280,7 +280,7 @@
*
* @since 1.6
*/
- function cleanCache($group = null, $client_id = 0) {
+ private function cleanAllCaches($group = null, $client_id = 0) {
parent::cleanCache('com_modules');
parent::cleanCache('mod_menu');
}
Index: J:/Projects/Experimental/administrator/components/com_templates/models/style.php
===================================================================
--- J:/Projects/Experimental/administrator/components/com_templates/models/style.php (revision 7)
+++ J:/Projects/Experimental/administrator/components/com_templates/models/style.php (revision 8)
@@ -98,7 +98,7 @@
}

// Clean cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -152,7 +152,7 @@
}

// Clean cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -453,7 +453,7 @@
}

// Clean the cache.
- $this->cleanCache();
+ $this->cleanAllCaches();

// Trigger the onExtensionAfterSave event.
$dispatcher->trigger('onExtensionAfterSave', array('com_templates.style', &$table, $isNew));
@@ -518,7 +518,7 @@
}

// Clean the cache.
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -572,7 +572,7 @@
}

// Clean the cache.
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -593,7 +593,7 @@
*
* @since 1.6
*/
- function cleanCache() {
+ private function cleanAllCaches() {
parent::cleanCache('com_templates');
parent::cleanCache('_system');
}
Index: J:/Projects/Experimental/administrator/components/com_languages/models/language.php
===================================================================
--- J:/Projects/Experimental/administrator/components/com_languages/models/language.php (revision 7)
+++ J:/Projects/Experimental/administrator/components/com_languages/models/language.php (revision 8)
@@ -178,7 +178,7 @@
$this->setState('language.id', $table->lang_id);

// Clean the cache.
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -217,7 +217,7 @@
}

// Clean the cache.
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -227,7 +227,7 @@
*
* @since 1.6
*/
- function cleanCache() {
+ private function cleanAllCaches() {
parent::cleanCache('_system', 0);
parent::cleanCache('_system', 1);
parent::cleanCache('com_languages', 0);
Index: J:/Projects/Experimental/administrator/components/com_languages/models/languages.php
===================================================================
--- J:/Projects/Experimental/administrator/components/com_languages/models/languages.php (revision 7)
+++ J:/Projects/Experimental/administrator/components/com_languages/models/languages.php (revision 8)
@@ -177,7 +177,7 @@
}

// Clean the cache.
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -187,7 +187,7 @@
*
* @since 1.6
*/
- function cleanCache() {
+ private function cleanAllCaches() {
parent::cleanCache('_system', 0);
parent::cleanCache('_system', 1);
parent::cleanCache('com_languages', 0);
Index: J:/Projects/Experimental/administrator/components/com_modules/models/module.php
===================================================================
--- J:/Projects/Experimental/administrator/components/com_modules/models/module.php (revision 7)
+++ J:/Projects/Experimental/administrator/components/com_modules/models/module.php (revision 8)
@@ -115,7 +115,7 @@
}

// Clear modules cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -197,7 +197,7 @@
}

// Clear modules cache
- $this->cleanCache();
+ $this->cleanAllCaches();

return true;
}
@@ -684,7 +684,7 @@
$this->setState('module.id', $table->id);

// Clear modules cache
- $this->cleanCache();
+ $this->cleanAllCaches();

// Clean module cache
parent::cleanCache($table->module, $table->client_id);
@@ -714,7 +714,7 @@
*
* @since 1.6
*/
- function cleanCache() {
+ private function cleanAllCaches() {
parent::cleanCache('com_modules', $this->getClient());
}
}

Re: [Help] Strict Standards error after installing

Posted: Tue Aug 09, 2011 7:35 pm
by TechGravy
hieroglif wrote:Maybe my post can help.

I had the same problem.
Then I realized that my Apache installation has been set without passwords for MySQL and Xampp.
After I have set those passwords "Strict standards" error disappeared without any intervention in php.ini


OS: Vista 64
Apache: 1.7.4
Joomla 1.7
Same problem for me. I tried changing the php.ini file. Tried changing the error settings. Then I realized I had not created a password for Xampp. Did that THEN changed error reporting from NONE to SIMPLE and presto all was well.

Re: [Help] Strict Standards error after installing

Posted: Thu Aug 11, 2011 6:27 am
by cassie4816
First, my apologies if the answer to this question is elsewhere - I have tried, in vain, to find the answer!

I have followed this thread as I expereinced the same errors. I have installed Joomla 1.7, running Windows.

I had trouble locating the php.ini files but found two called php ini-production and ini-development - I changed the error_reporting in both, as per above, using Notepad. I saved these files but am unsure if they are still ini files.

I then opened xampp and set a password for both MySql and Apache - didnt have one before.

When I open the backend (http://localhost/joomla17/administrator I now get the following error:

Strict Standards: Static function JDatabase::test() should not be abstract in C:\xampp\htdocs\joomla17\libraries\joomla\database\database.php on line 350
Infinite loop detected in JError

and nothing happens. Also, I tried to change the configuration settings but I didnt have any drop down menus (which I know exist as I trialed this in Cloudaccess.

Can someone please help? I am not a computer guru (I am a Mum trying to set up a website), so please be gentle! ;)

Re: [Help] Strict Standards error after installing

Posted: Thu Aug 11, 2011 6:47 am
by cassie4816
Ed, you sent me a message but I have a problem. When I open that file in Notepad, it is one continuous file - not broken into lines so I cant find line 350. What should I be looking for? I tried doing a search on JDatabase etc but couldnt find it. Thx!

Re: [Help] Strict Standards error after installing

Posted: Thu Aug 11, 2011 7:05 am
by cassie4816
Ed, sent you an email (can PM yet!) Thx.

Re: [Help] Strict Standards error after installing

Posted: Sat Oct 22, 2011 4:26 am
by around
cassie4816 wrote:First, my apologies if the answer to this question is elsewhere - I have tried, in vain, to find the answer!

I have followed this thread as I expereinced the same errors. I have installed Joomla 1.7, running Windows.

I had trouble locating the php.ini files but found two called php ini-production and ini-development - I changed the error_reporting in both, as per above, using Notepad. I saved these files but am unsure if they are still ini files.

I then opened xampp and set a password for both MySql and Apache - didnt have one before.

When I open the backend (http://localhost/joomla17/administrator I now get the following error:

Strict Standards: Static function JDatabase::test() should not be abstract in C:\xampp\htdocs\joomla17\libraries\joomla\database\database.php on line 350
Infinite loop detected in JError

and nothing happens. Also, I tried to change the configuration settings but I didnt have any drop down menus (which I know exist as I trialed this in Cloudaccess.

Can someone please help? I am not a computer guru (I am a Mum trying to set up a website), so please be gentle! ;)

I'm also a Joomla newbie running XAMPP on Win XP. I had the same sort of errors:
Strict Standards: Accessing static property JCache::$_handler as non static in C:\Desenvolvimento\EasyPHP\www\joomla\libraries\joomla\cache\cache.php on line 396

Have tried editing the php.ini file, then tried adding a password to mysql, myphpadmin, then XAMPP
but now I too have the same "Infinite loop detected in JError"

I thought that joomla was going to be a good idea, but as I know nothing about it at all, and can't even get the program running after three days, I'm wondering if it's worthwhile?

Any easy way to get the program running without these errors?