Joomla 2.5.4 issues on installation\controller.php

This forum is for issues with installing Joomla! 2.5 (All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.) on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
serebi
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat May 19, 2012 4:51 am

Joomla 2.5.4 issues on installation\controller.php

Postby serebi » Sat May 19, 2012 5:01 am

hi guys,
ok i need your help i dont know how to solve my problems
first some technical info
host: Ferozo.com
joomla version: 2.5.4

the first thing i do was upload all the joomla instalation file to my server using filezilla is not my first time so i upload the files in /public_html folder

then go to www.myhost.com to start my installation and i get this

Warning: Invalid argument supplied for foreach() in \\HMFSW\WEB\DTCWIN049\aadesu.com\public_html\libraries\joomla\language\language.php on line 1310

Fatal error: Call to undefined method JException::setModel() in \\HMFSW\WEB\DTCWIN049\aadesu.com\public_html\installation\controller.php on line 53

i check and all the files are there

i was thinking in some server configuration in the admin page i can change the php integration mode for
php 5.3.1 Clasic mode (Fast CGI)
php 5.3.1 integrated mode (Fast CGI)
PHP 5.2.17 clasic mode
php 5.2.17 integrated mode

mynomi008
Joomla! Explorer
Joomla! Explorer
Posts: 262
Joined: Mon Nov 21, 2011 6:31 am
Location: Pakistan
Contact:

Re: Joomla 2.5.4 issues on installation\controller.php

Postby mynomi008 » Sun May 20, 2012 6:18 am

installing joomla 1.5.23 will solve ur problem
Web Programming and IT Support Services
http://www.codingace.com

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Joomla 2.5.4 issues on installation\controller.php

Postby humvee » Sun May 20, 2012 6:54 am

mynomi008 wrote:installing joomla 1.5.23 will solve ur problem


Seriously? Why would he do that?
  1. He is already using J 2.5.4
  2. You are quoting the wrong current stable version of 1.5.x
  3. Support for 1.5.x ends in September!

[Mod note: Moved from General Forum to Installation Forum;]

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Joomla 2.5.4 issues on installation\controller.php

Postby humvee » Sun May 20, 2012 7:01 am

@ Serebi

  1. Please run the Forum post Assistant to provide the information to help us assess your current server settings.
  2. Assuming you are on Windows download a copy of 7-ZIP archive manager and a copy of WinSCP FTP manager.
  3. Install them both on your pc.
  4. Remove the current files you have uploaded to your host.
  5. Download a full fresh copy of the latest Joomla! release (2.5.4).
  6. Using 7-Zip extract the files to your PC
  7. Using WinSCP transfer the files to your host.
  8. Run the Joomla installation

serebi
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat May 19, 2012 4:51 am

Re: Joomla 2.5.4 issues on installation\controller.php

Postby serebi » Sun May 20, 2012 7:56 pm

ok i fix my problem how well
php 5.3.1 Clasic mode (Fast CGI)
php 5.3.1 integrated mode (Fast CGI)
PHP 5.2.17 clasic mode
php 5.2.17 integrated mode

for some wierd razon my host provider configure the php as php 5.3.1 clasic mode (FAST CGI)

the only thing i do was change the configuration from fast CGI to PHP 5.2.17 integrated mode and then i continue was able to finish the installation iwthout any inconvenient now the only problem i have is when i try yo go to category administration on the admin side

i get this

Warning: require_once(\hmfsw\web\DTCWIN049\aadesu.com\public_html\home\administrator\components\com_content\helpers\content.php) [function.require-once]: failed to open stream: No such file or directory in \\hmfsw\web\DTCWIN049\aadesu.com\public_html\home\administrator\components\com_categories\helpers\categories.php on line 46

Fatal error: require_once() [function.require]: Failed opening required '\hmfsw\web\DTCWIN049\aadesu.com\public_html\home\administrator\components\com_content\helpers\content.php' (include_path='.;E:\php5.2\ext;E:\php5.2\PEAR;E:\php5.2\PhpCommon') in \\hmfsw\web\DTCWIN049\aadesu.com\public_html\home\administrator\components\com_categories\helpers\categories.php on line 46

dunno why hope anyone can help me

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Joomla 2.5.4 issues on installation\controller.php

Postby humvee » Sun May 20, 2012 9:33 pm

Those warnings mean that either:
  • there was a problem during the transfer of the files to the host with Filezilla or
  • there was an issue with the way the Joomla zip was unarchived on your host machine.
Suggestion:

  • Delete the current installation and drop the database tables
  • Obtain a copy of 7-Zip archive manager to unzip the files on your local PC and never use Windows own archive manager, and
  • Obtain a copy of WinSCP to transfer the files to the host - I have always found this to be more reliable than Filezilla.
  • Rerun the installation process.

hth

Andy

serebi
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat May 19, 2012 4:51 am

Re: Joomla 2.5.4 issues on installation\controller.php

Postby serebi » Sun May 20, 2012 9:47 pm

Warning: require_once(\hmfsw\web\DTCWIN049\aadesu.com\public_html\home\administrator\components\com_content\helpers\content.php) [function.require-once]: failed to open stream: No such file or directory in \\hmfsw\web\DTCWIN049\aadesu.com\public_html\home\administrator\components\com_categories\helpers\categories.php on line 46

Fatal error: require_once() [function.require]: Failed opening required '\hmfsw\web\DTCWIN049\aadesu.com\public_html\home\administrator\components\com_content\helpers\content.php' (include_path='.;E:\php5.2\ext;E:\php5.2\PEAR;E:\php5.2\PhpCommon') in \\hmfsw\web\DTCWIN049\aadesu.com\public_html\home\administrator\components\com_categories\helpers\categories.php on line 46

this error is when i try to mange categories so the instalation is already finished and the site is runing is there any change to fix that problem without reinstalling joomla ?? i guess just changing some folder permisions or re-uploading that files ?

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Joomla 2.5.4 issues on installation\controller.php

Postby humvee » Sun May 20, 2012 9:59 pm

Well you could just try re-uploading the contents of the Joomla zip - excluding the installation directory - and try overwriting the files that are in the host joomla_root/ directory. But no guarantees that will always work.

serebi
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat May 19, 2012 4:51 am

Re: Joomla 2.5.4 issues on installation\controller.php

Postby serebi » Sun May 20, 2012 10:18 pm

i will try becouse i can create new catgories and everuthing is working i already isntall some components plugins so far everyting else is working is just that categories manager page

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Joomla 2.5.4 issues on installation\controller.php

Postby humvee » Mon May 21, 2012 6:52 am

serebi wrote:i will try becouse i can create new catgories and everuthing is working i already isntall some components plugins so far everyting else is working is just that categories manager page


Create a database backup just as a safety precaution.

serebi
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat May 19, 2012 4:51 am

Re: Joomla 2.5.4 issues on installation\controller.php

Postby serebi » Tue May 22, 2012 1:37 am

finally i was able to solve my problem

the problem was here
$file = JPath::clean(JPATH_ADMINISTRATOR.'/components/'.$component.'/helpers/'.$eName.'.php');
for some weird razon the page was unable to locate the file
i change that line of code for
$file = '/public_html/nuevo/administrator/components/com_content/helpers/content.php';

and the problem was solved
i think is becouse the server is windows based and not linux based or maybe becouse becouse some permisions on the folders but the weird thing is that the problem only show on the category page and not in all pages

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Joomla 2.5.4 issues on installation\controller.php

Postby humvee » Tue May 22, 2012 8:11 am

serebi wrote:finally i was able to solve my problem
the problem was here
$file = JPath::clean(JPATH_ADMINISTRATOR.'/components/'.$component.'/helpers/'.$eName.'.php');
for some weird razon the page was unable to locate the file
i change that line of code for
$file = '/public_html/nuevo/administrator/components/com_content/helpers/content.php';

and the problem was solved
Certainly the code indicated should be picking up the specified file path that is what it is intended to do. By hardcoding (hacking) the file you should be aware that any updates of the file in the future will lead to a recurrence of the issue, and you may not have solved the underlying problem, just the first presentation of it.
It appears that your site URL is pointing to the web_root/ (htdocs) whereas the joomla_root/ (htdocs/neuvo) is in fact a subdirectory of this.

Without quite knowing what you have done during the installation, whether you have a redirect function in the server control panel, or whether you have an .htaccess file created in the web_root/ that is properly configured to redirect the URL it is difficult to provide a complete answer but these are the factors you should be looking at to rectify the problem and NOT hacking the files. Essentially the $path is not being correctly picked up
i think is because the server is windows based and not Linux based or maybe because because some permissions on the folders but the weird thing is that the problem only show on the category page and not in all pages
SO why did you not inform us of this fact when you first posted?
In future, and possibly even this thread still if you want to find the real issue, you should complete the Forum Post Assistant as requested a number of posts previously.

[Mod Note: Moving to the IIS Installation forum]


Return to “Joomla! 2.5 on IIS webserver”

Who is online

Users browsing this forum: No registered users and 2 guests