500 DateTimeZone::__construct() [datetimezone.--construct]:

Joomla versions 2.5, 1.7 and 1.6 are all end-of-life since December 31st 2014 and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
rhymeroyal
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Mon Jan 09, 2012 10:45 am

500 DateTimeZone::__construct() [datetimezone.--construct]:

Post by rhymeroyal » Wed Jul 11, 2012 1:42 pm

This site has been online 4 days and now I keep getting
500 DateTimeZone::__construct() [datetimezone.--construct]: Unknown or bad timezone (8)

I really need help as the site is just crashing more and more

Database Version 5.1.63-cll
Database Collation utf8_general_ci
PHP Version 5.3.10
Web Server Apache
WebServer to PHP Interface cgi-fcgi
Joomla! Version Joomla! 2.5.6 Stable [ Ember ] 19-June-2012 14:00 GMT
Joomla! Platform Version Joomla Platform 11.4.0 Stable [
PHP Version 5.3.10

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: 500 DateTimeZone::__construct() [datetimezone.--constru

Post by humvee » Fri Jul 13, 2012 4:50 pm

This would appear to be a server misconfiguration.
Please locate the System Information => PHP Information page in the administrator.
Look down the page and identify the date table.
What is setting for date.timezone ?
This is where the error is originating from and you need to speak to your host to get it set correctly. If this is a self-administered site then you will need to edit the php.ini file -> date.timezone setting according to your location.

User avatar
DJsOak4
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 172
Joined: Thu Feb 18, 2010 5:11 pm

Re: 500 DateTimeZone::__construct() [datetimezone.--constru

Post by DJsOak4 » Fri Dec 21, 2012 6:47 pm

This error occurs on two RocketTheme templates (Radiance and Infuse), but not a template from another provider. If you “forget password” and go through all the hoops to where you can once again log in, you get this error: 500 - DateTime::__construct() [datetime.--construct]: Failed to parse time string (%2055-%07-%26) at position 0 (%): Unexpected character with a screen shot like the one attached. If you backspace the url to the site, it does log you in. I discussed what humvee said with our host and he said if it was a problem on the server end, it would be on many sites. The site with the problem is http://www.yahwehschildren.com and the one without the problem is http://www.yaim.org. I compared php information and the php.ini files and they are the same. Can anyone help?
You do not have the required permissions to view the files attached to this post.


Locked

Return to “Installation Joomla! 2.5”