Strict standards warnings

Joomla versions 2.5, 1.7 and 1.6 are all end-of-life since December 31st 2014 and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
MB Walker
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Aug 12, 2012 2:55 pm

Strict standards warnings

Post by MB Walker » Mon Apr 27, 2015 2:21 pm

I'm using 2.5.13. This has been moved to a new server, which I am setting up. Files have been restored from backup, I can access new db, but am getting a lot of strict standards warnings.

Any idea what causes these?

I copied a few typical warnings below -- there are quite a few more:


Strict Standards: Only variables should be assigned by reference in /home/netwarmglass/public_html/plugins/system/jumirouter/jumirouter.php on line 20

Strict Standards: Only variables should be assigned by reference in /home/netwarmglass/public_html/plugins/system/rokextender/rokextender.php on line 32

Strict Standards: Only variables should be assigned by reference in /home/netwarmglass/public_html/plugins/system/jumirouter/jumirouter.php on line 33

Strict Standards: Only variables should be assigned by reference in /home/netwarmglass/public_html/plugins/system/jumirouter/jumirouter.php on line 35

Strict Standards: Only variables should be assigned by reference in /home/netwarmglass/public_html/plugins/system/jumirouter/jumirouter.php on line 36

Strict Standards: Only variables should be assigned by reference in /home/netwarmglass/public_html/plugins/system/jumirouter/jumirouter.php on line 55
Monday, 27 April 2015

Warning: include_once(/home/netwarmglass/public_html/templates/system/html/modules.php): failed to open stream: No such file or directory in /home/netwarmglass/public_html/libraries/joomla/application/module/helper.php on line 186

Warning: include_once(): Failed opening '/home/netwarmglass/public_html/templates/system/html/modules.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/netwarmglass/public_html/libraries/joomla/application/module/helper.php on line 186

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 27333
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: Strict standards warnings

Post by imanickam » Mon Apr 27, 2015 4:23 pm

The errors could be due to how the error reporting is configured in PHP.

Try the following:

- Go to the Global Configuration
- Click on the tab Server
- For the option "Error Reporting" choose the value None
- Save the configuration change

See what happens after this.

First make sure that the technical requirements documented at http://www.joomla.org/technical-requirements.html are met in your new environment.

The last version of Joomla! 2.5 is 2.5.28. So, after the site functions properly, you have to plan to upgrade it to 2.5.28. Make sure to take a backup of the site files and the database content before attempting this.
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Joomla! - Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37533
Joined: Sat Apr 05, 2008 9:58 pm

Re: Strict standards warnings

Post by Webdongle » Mon Apr 27, 2015 4:28 pm

Suggest you update/upgrade your version of Joomla before you do anything else.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

MB Walker
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Aug 12, 2012 2:55 pm

Re: Strict standards warnings

Post by MB Walker » Mon Apr 27, 2015 6:49 pm

imanickam wrote:The errors could be due to how the error reporting is configured in PHP.

Try the following:

- Go to the Global Configuration
- Click on the tab Server
- For the option "Error Reporting" choose the value None
- Save the configuration change

See what happens after this..
Thanks. That got rid of the messages.

I actually want to upgrade to 3.4, but figured I needed to get 2.513 working first. Do I need to go from 2.5.13 to 2.5.28 to 3.41 or can I skip the middle step?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37533
Joined: Sat Apr 05, 2008 9:58 pm

Re: Strict standards warnings

Post by Webdongle » Mon Apr 27, 2015 6:56 pm

Suggest you do the upgrade on localhost xampp (or mamp on mac) use https://www.akeebabackup.com/compatibility.html to backup and move. Yes update to 2.5.8 first.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein


Locked

Return to “Installation Joomla! 2.5”