Install Joomla 2.5 on SQLSERVER

Joomla versions 2.5, 1.7 and 1.6 are all end-of-life since December 31st 2014 and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
bt1web
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Nov 05, 2015 6:19 am

Install Joomla 2.5 on SQLSERVER

Post by bt1web » Thu Nov 05, 2015 7:57 am

I apologize in advance if this has been answered previously, but I have searched the forums for more than a day and not managed to find anything that solved our problem. I'm trying to install Joomla 2.5.28 to run on MSSQL Server. Specs are as follows:

Joomla 2.5.28
MS Server 2008 R2
PHP 5.2.5

I'm stuck on step 4 to install joomla. Allways get this message - Could not connect to the database. Connector returned number: Unable to connect to the Database: JLIB_DATABASE_ERROR_CONNECT_SQLSRV

Maybe anybody had the same problem?

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11342
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Install Joomla 2.5 on SQLSERVER

Post by toivo » Thu Nov 05, 2015 8:32 am

Support for Joomla 2.5 ended almost a year ago. Is this a test installation in preparation to migrate to Joomla 3.4.5?

Are you using IIS as the web server? Have you created the database?
Toivo Talikka, Global Moderator

bt1web
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Nov 05, 2015 6:19 am

Re: Install Joomla 2.5 on SQLSERVER

Post by bt1web » Thu Nov 05, 2015 8:43 am

It is test installation. I would like to install Joomla 3.4.5, but it doesn't compatible with php 5.2.5
Yes, database is created.
I'm using Apache 2.2.25

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22275
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Install Joomla 2.5 on SQLSERVER

Post by pe7er » Thu Nov 05, 2015 9:23 am

bt1web wrote:I would like to install Joomla 3.4.5, but it doesn't compatible with php 5.2.5
That's because PHP 5.2 is end-of-life (it ended 4 years, 9 months ago) :
it's no longer supported by php.net and there won't be any security updates in the future.
Actually PHP 5.3 + 5.4 are both end-of-life too: http://php.net/supported-versions.php

I'd recommend to update your PHP version to PHP5.5 or 5.6.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content


Locked

Return to “Installation Joomla! 2.5”