Installation hangs after step 6 / admin panel unreachable.

This forum is for issues with installing Joomla! 2.5 (All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.) on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
JonGamble
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Jan 30, 2012 2:21 pm

Re: Installation hangs after step 6 / admin panel unreachabl

Post by JonGamble » Wed Feb 08, 2012 12:49 am

Hi,

I had the same symptoms, but installing J2.5 on Windows 2003/IIS6.

Although the spec for Joomla 2.5 indicates IIS7 as a minimum requirement (which by the way only ships with Windows Server 2008 according to everything I can find), I knew that J2.5 worked on IIS6 having upgraded an earlier J1.7 version to J2.5 using the joomla upgrade package.

The problem I had was during a brand new installation of J2.5 (i.e. versus an upgrade installation). Having spent an evening looking for answers to this issue of hanging on Stage 6 (Confirmation Step), I went back to look at my PHP.ini settings.

Basically, in the Joomla install test page (the page you get to when starting the install process) there are two boxes - one that shows absolute definite systems settings you need for Joomla to work, and a box that says the installation may be "OK" if the options are slightly different.

I had been trying to install with a couple of the "should be OK options" set wrong in my php.ini. Result = new installation of J2.5 hangs. I took some time to get ALL php.ini setting set correctly and voila - all cushty!

Hope this helps someone if the above discussed fix does n't work...

Sorry this is a bit wordy, but I often find these types of fix are useless without context.

J

osense
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Nov 26, 2011 3:06 am

Re: Installation hangs after step 6 / admin panel unreachabl

Post by osense » Thu Feb 09, 2012 4:36 am

Hi,
Did you tried my solution on my previous post of yours?

Windows servers by default don't grant the folder a full privilege, which is affecting the Joomla installation.

When I faced this problem at first, I keep searching with no luck on solving this problem, until I grant the website folder on the server a full privilege (right click on folder, properties, Security tab, select the PLESK/cPanel user and give him a full priv)...

Hope this will solve your case as it did to my J1.7 problem.

rickpowers01
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Feb 24, 2012 12:19 pm

Re: Installation hangs after step 6 / admin panel unreachabl

Post by rickpowers01 » Sat Feb 25, 2012 5:10 pm

You all seem to be on the right track but not very clear. Here is what I did when the installer stalled at step 6. First, understand what the installer is trying to do: It is composing a file called configuration.php that must reside at your site root. It fails because your ISP setup does not let your web user write to the httpdocs directory.

The good news is that you can create and edit this file locally and upload it through FTP or the Plesk File Manager. To create it locally unzip the installation package and copy the file called configuration.php-dist to configuration.php. Open it with a free text editor and edit the following parameters:

public $dbtype = 'mysql'; // Normally mysql
public $host = 'yourdomain.com'; // This is normally set to localhost - no! - put in your real domain name
public $user = 'root'; // MySQL username - whatever you entered on the installer dialog step 4
public $password = 'your db password'; // MySQL password - whatever you entered on the installer dialog step 4
public $db = 'your db name'; // MySQL database name -whatever you entered on the installer dialog step 4
public $dbprefix = 'xxxx_'; // Do not change unless you need to! -whatever you entered on the installer dialog step 4

Save and upload the file to the root of your website. Remove the installation directory. Try yourdomain/administrator and you should get the login. If you get SQL errors then check your db parameters with the phpadmin tool on plesk. Redit configuration.php and reupload.

If you got to step 6 then the database should have been created and these parameters should be what you put into the database creation dialogue. If this doesnt work then check that the database exists and and table names start with the prefix etc.

Web Destroyer
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Jul 14, 2012 3:29 pm

Re: Installation hangs after step 6 / admin panel unreachabl

Post by Web Destroyer » Sat Jul 14, 2012 3:33 pm

@rickpowers01: You're genius. It works.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Installation hangs after step 6 / admin panel unreachabl

Post by humvee » Tue Jul 17, 2012 5:53 pm

rickpowers01 wrote: If you got to step 6 then the database should have been created and these parameters should be what you put into the database creation dialogue. If this doesnt work then check that the database exists and and table names start with the prefix etc.
If you create the database first you will not run into the particular concern over this. Automatic creation works with many localhost "stack" servers such as XAMPP but this is not always the case on other installations of Windows AMP or WIMP.

szymkowiiak
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Jul 19, 2012 8:07 pm
Contact:

Re: Installation hangs after step 6 / admin panel unreachabl

Post by szymkowiiak » Thu Jul 19, 2012 8:16 pm

very Good.. But From System error Fatal. :(

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Installation hangs after step 6 / admin panel unreachabl

Post by humvee » Sun Jul 29, 2012 3:25 pm

szymkowiiak wrote:very Good.. But From System error Fatal. :(
Is this supposed to be a new occurrence of the same issue or just a spam message? If you would like more help provide more information of your circumstances.


Locked

Return to “Joomla! 2.5 on IIS webserver”