joomla on windows server with index.php or Index.php?

This forum is for issues with installing Joomla! 2.5 (All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.) on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
ArjanR
Joomla! Explorer
Joomla! Explorer
Posts: 449
Joined: Fri Jun 24, 2011 8:31 am
Contact:

joomla on windows server with index.php or Index.php?

Post by ArjanR » Sun May 20, 2012 8:50 am

Hi

I usually install joomla on common servers without problem but this time i'm installing joomla on a server with plesk panel and windows 2008. In the backend the 'view site' link is not working properly. I get a 404 error after clicking it. When I write in the browser http://mysite.nu/index.php then i can view the site. My serverhost then changed the index.php to Index.php, with a capital i. Then the 'view site' in the backend worked as it should but...no link worked properly in the frontend. I only get 404 error after clicking on a menu or submenu.
My serverhost doesn't have a solution for this. Anyone knows about this or heard about this problem?

I'm using the latest joomla and akeeba

ps i even get a 403 error access denied after 'view site'

User avatar
RussW
Joomla! Exemplar
Joomla! Exemplar
Posts: 9352
Joined: Sun Oct 22, 2006 4:42 am
Location: Sunshine Coast, Queensland, Australia
Contact:

Re: joomla on windows server with index.php or Index.php?

Post by RussW » Sun May 20, 2012 9:25 am

get them to check the "default" page settings in web server, maybe they have an upper-case "i" configured, instead of a lower case "i"
Joomla! on the fabulous Sunshine Coast...
hotmango, web & print http://www.hotmango.me/
The Styleguyz https://www.thestyleguyz.com/

User avatar
ArjanR
Joomla! Explorer
Joomla! Explorer
Posts: 449
Joined: Fri Jun 24, 2011 8:31 am
Contact:

Re: joomla on windows server with index.php or Index.php?

Post by ArjanR » Sun May 20, 2012 9:55 am

they checked it and changed it but it didn't help. I've had an other site there which gave the same problems. He then changed manually settings which took quite some time but there should be a quick solution to this...

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: joomla on windows server with index.php or Index.php?

Post by humvee » Sun May 20, 2012 3:54 pm

this server therefore running IIS 7/7.5?

Please run the Forum post Assistant to provide the information to help us try and resolve the issue.

User avatar
ArjanR
Joomla! Explorer
Joomla! Explorer
Posts: 449
Joined: Fri Jun 24, 2011 8:31 am
Contact:

Re: joomla on windows server with index.php or Index.php?

Post by ArjanR » Sun May 20, 2012 6:58 pm

I ran it. First time for me:-).
What i understand is that i just paste the post now. Hope i'm right so here u are ;) :
Forum Post Assistant (v1.2.1) : 20th May 2012 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 2.5.4-Stable (Ember) 2-April-2012
Joomla! Platform :: Joomla Platform 11.4.0-Stable (Brian Kernighan) 03-Jan-2012
Joomla! Configured :: Yes | Writable (666) | Owner: 0 (uid: /gid: ) | Group: 0 (gid: ) | Valid For: 1.5
Configuration Options :: Offline: 0 | SEF: 1 | SEF Suffix: 0 | SEF ReWrite: 0 | .htaccess/web.config: No | GZip: 0 | Cache: 0 | FTP Layer: 0 | SSL: 0 | Error Reporting: default | Site Debug: 0 | Language Debug: 0 | Default Access: N/A | Unicode Slugs: N/A | Database Credentials Present: Yes

Host Configuration :: OS: Windows NT | OS Version: 6.0 | Technology: i586 | Web Server: Microsoft-IIS/7.0 | Encoding: gzip,deflate,sdch | Doc Root: | System TMP Writable: No

PHP Configuration :: Version: 5.2.17 | PHP API: isapi | Session Path Writable: Unknown | Display Errors: 1 | Error Reporting: 6135 | Log Errors To: | Last Known Error: | Register Globals: 0 | Magic Quotes: 1 | Safe Mode: off | Open Base: d:\inetpub\vhosts\bragi.nu\httpdocs\ | Uploads: 1 | Max. Upload Size: 10M | Max. POST Size: 8M | Max. Input Time: 60 | Max. Execution Time: 60 | Memory Limit: 128M

MySQL Configuration :: Version: 5.1.56-community (Client:5.0.51a) | Host: --protected-- (--protected--) | Collation: latin1_swedish_ci (Character Set: latin1) | Database Size: 1.65 MiB | #of _FPA_TABLE: 270
Detailed Environment :: wrote:PHP Extensions :: bcmath () | calendar () | com_dotnet (0.1) | ctype () | date (5.2.17) | filter (0.11.0) | ftp () | hash (1.0) | iconv () | json (1.2.1) | odbc (1.0) | pcre () | Reflection (0.1) | session () | libxml () | standard (5.2.17) | tokenizer (0.1) | zlib (1.1) | SimpleXML (0.1) | dom (20031129) | SPL (0.2) | wddx () | xml () | xmlreader (0.1) | xmlwriter (0.1) | ISAPI () | curl () | gd () | gettext () | imap () | mbstring () | mssql () | mysql (1.0) | openssl () | PDO (1.0.4dev) | pdo_mysql (1.0.2) | pdo_sqlite (1.0.1) | sockets () | SQLite (2.0-dev) | xsl (0.1) | zip (1.8.11) | ionCube Loader () | Zend Engine (2.2.0) |
Potential Missing Extensions :: mysqli | mcrypt | suhosin |

Switch User Environment (Experimental) :: PHP CGI: No | Server SU: No | PHP SU: No | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (777) | components/ (777) | modules/ (777) | plugins/ (777) | language/ (777) | templates/ (777) | cache/ (777) | logs/ (777) | tmp/ (777) | administrator/components/ (777) | administrator/modules/ (777) | administrator/language/ (777) | administrator/templates/ (777) |

Elevated Permissions (First 10) :: None administrator/ (777) | administrator/cache/ (777) | administrator/components/ (777) | administrator/components/com_admin/ (777) | administrator/components/com_admin/controllers/ (777) | administrator/components/com_admin/helpers/ (777) | administrator/components/com_admin/helpers/html/ (777) | administrator/components/com_admin/models/ (777) | administrator/components/com_admin/models/forms/ (777) |
Extensions Discovered :: wrote:Components :: SITE :: WF_AGGREGATOR_VIMEO_TITLE (2.0.21) | WF_AGGREGATOR_[youtube]_TITLE (2.0.21) | WF_FILESYSTEM_JOOMLA_TITLE (2.0.21) | WF_LINKS_JOOMLALINKS_TITLE (2.0.21) | WF_MEDIAPLAYER_JCEPLAYER_TITLE (2.0.21) | WF_POPUPS_JCEMEDIABOX_TITLE (2.0.21) | WF_POPUPS_WINDOW_TITLE (2.0.21) | WF_ARTICLE_TITLE (2.0.21) | WF_AUTOSAVE_TITLE (2.0.21) | WF_BROWSER_TITLE (2.0.21) | WF_CLEANUP_TITLE (2.0.21) | WF_CONTEXTMENU_TITLE (2.0.21) | WF_DIRECTIONALITY_TITLE (2.0.21) | WF_FILEMANAGER_TITLE (2.0.10) | WF_FULLSCREEN_TITLE (2.0.21) | WF_IMGMANAGER_TITLE (2.0.21) | WF_INLINEPOPUPS_TITLE (2.0.21) | WF_LAYER_TITLE (2.0.21) | WF_LINK_TITLE (2.0.21) | WF_MEDIA_TITLE (2.0.21) | WF_NONBREAKING_TITLE (2.0.21) | WF_PASTE_TITLE (2.0.21) | WF_PREVIEW_TITLE (2.0.21) | WF_PRINT_TITLE (2.0.21) | WF_SEARCHREPLACE_TITLE (2.0.21) | WF_SOURCE_TITLE (2.0.21) | WF_SPELLCHECKER_TITLE (2.0.21) | WF_STYLE_TITLE (2.0.21) | WF_TABLE_TITLE (2.0.21) | WF_TEXTCASE_TITLE (2.0.21) | WF_VISUALCHARS_TITLE (2.0.21) | WF_XHTMLXTRAS_TITLE (2.0.21) | com_mailto (2.5.0) | com_wrapper (2.5.0) |
Components :: ADMIN :: com_admin (2.5.0) | Akeeba (3.4.3) | com_banners (2.5.0) | com_cache (2.5.0) | com_categories (2.5.0) | com_checkin (2.5.0) | com_config (2.5.0) | com_content (2.5.0) | com_cpanel (2.5.0) | com_finder (2.5.0) | com_installer (2.5.0) | JCE (2.0.21) | Unknown (-) | Editor - JCE (2.0.21) | com_joomlaupdate (2.5.0) | com_languages (2.5.0) | com_login (2.5.0) | com_media (2.5.0) | com_menus (2.5.0) | com_messages (2.5.0) | com_modules (2.5.0) | com_newsfeeds (2.5.0) | com_plugins (2.5.0) | com_redirect (2.5.0) | com_search (2.5.0) | com_templates (2.5.0) | com_users (2.5.0) | com_weblinks (2.5.0) |

Modules :: SITE :: mod_articles_archive (2.5.0) | mod_articles_categories (2.5.0) | mod_articles_category (2.5.0) | mod_articles_latest (2.5.0) | mod_articles_news (2.5.0) | mod_articles_popular (2.5.0) | mod_banners (2.5.0) | mod_breadcrumbs (2.5.0) | mod_custom (2.5.0) | mod_feed (2.5.0) | mod_finder (2.5.0) | mod_footer (2.5.0) | mod_languages (2.5.0) | mod_login (2.5.0) | mod_menu (2.5.0) | mod_random_image (2.5.0) | mod_related_items (2.5.0) | mod_search (2.5.0) | mod_stats (2.5.0) | mod_syndicate (2.5.0) | mod_users_latest (2.5.0) | mod_weblinks (2.5.0) | mod_whosonline (2.5.0) | mod_wrapper (2.5.0) |
Modules :: ADMIN :: Akeeba Backup Notification Mod (3.4.3) | mod_custom (2.5.0) | mod_feed (2.5.0) | mod_latest (2.5.0) | mod_logged (2.5.0) | mod_login (2.5.0) | mod_menu (2.5.0) | mod_multilangstatus (2.5.0) | mod_popular (2.5.0) | mod_quickicon (2.5.0) | mod_status (2.5.0) | mod_submenu (2.5.0) | mod_title (2.5.0) | mod_toolbar (2.5.0) | mod_version (2.5.0) |

Plugins :: SITE :: plg_authentication_gmail (2.5.0) | plg_authentication_joomla (2.5.0) | plg_authentication_ldap (2.5.0) | plg_captcha_recaptcha (2.5.0) | plg_content_emailcloak (2.5.0) | plg_content_finder (2.5.0) | plg_content_geshi (2.5.0) | plg_content_joomla (2.5.0) | plg_content_loadmodule (2.5.0) | plg_content_pagebreak (2.5.0) | plg_content_pagenavigation (2.5.0) | plg_content_vote (2.5.0) | plg_editors_codemirror (1.0) | Editor - JCE (2.0.21) | plg_editors_tinymce (3.4.9) | plg_editors-xtd_article (2.5.0) | plg_editors-xtd_image (2.5.0) | plg_editors-xtd_pagebreak (2.5.0) | plg_editors-xtd_readmore (2.5.0) | plg_extension_joomla (2.5.0) | plg_finder_categories (2.5.0) | plg_finder_contacts (2.5.0) | plg_finder_content (2.5.0) | plg_finder_newsfeeds (2.5.0) | plg_finder_weblinks (2.5.0) | plg_quickicon_extensionupdate (2.5.0) | plg_quickicon_joomlaupdate (2.5.0) | plg_search_categories (2.5.0) | plg_search_contacts (2.5.0) | plg_search_content (2.5.0) | plg_search_newsfeeds (2.5.0) | plg_search_weblinks (2.5.0) | Akeeba Backup Lazy Scheduling (3.3) | plg_system_cache (2.5.0) | plg_system_debug (2.5.0) | plg_system_highlight (2.5.0) | plg_system_languagecode (2.5.0) | plg_system_languagefilter (2.5.0) | plg_system_log (2.5.0) | plg_system_logout (2.5.0) | plg_system_p3p (2.5.0) | plg_system_redirect (2.5.0) | plg_system_remember (2.5.0) | plg_system_sef (2.5.0) | plg_user_contactcreator (2.5.0) | plg_user_joomla (2.5.0) | plg_user_profile (2.5.0) |
Templates Discovered :: wrote:Templates :: SITE :: atomic (2.5.0) | beez5 (2.5.0) | beez_20 (2.5.0) | GameOn-FJT (2.5.0) |
Templates :: ADMIN :: bluestork (2.5.0) | hathor (2.5.0) |

User avatar
ArjanR
Joomla! Explorer
Joomla! Explorer
Posts: 449
Joined: Fri Jun 24, 2011 8:31 am
Contact:

Re: joomla on windows server with index.php or Index.php?

Post by ArjanR » Sun May 20, 2012 7:01 pm

I used akeeba to do make a new install today but the same problem still is there. I noticed these two lines though when i reinstalled. I'm not sure it will help but i send it anyway. Thx for making time for this!

Warning: is_writable() [function.is-writable]: open_basedir restriction in effect. File(C:\Windows\Temp) is not within the allowed path(s): (d:\inetpub\vhosts\bragi.nu\httpdocs\) in D:\inetpub\vhosts\bragi.nu\httpdocs\installation\includes\storage.php on line 51

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../configuration.php) is not within the allowed path(s): (d:\inetpub\vhosts\bragi.nu\httpdocs\) in D:\inetpub\vhosts\bragi.nu\httpdocs\installation\includes\configuration.php on line 334

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: joomla on windows server with index.php or Index.php?

Post by humvee » Sun May 20, 2012 9:23 pm

Did you install Joomla on the host first before then trying to upload an existing site to it?
If Joomla is the only thing you are trying to have on this site I am a little surprise to see reference to ..\..\httdocs\installation\includes\..\.. in the references as there should not be an installation file if you are transferring a site, which clearly you are doing judging by the amount of extensions referenced.

Is there a chance that you thought about installing Joomla and did not complete this process before uploading the existing site?

Possibly at the very least you did complete the installation but did not remove the installation directory?

I think you probably need to back peddle a little a rerun the process again and following the Akeeba documentation closely.
Read the extensive documentation on-line at Akeeba Backup or download a copy of the same.;

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: joomla on windows server with index.php or Index.php?

Post by humvee » Sun May 20, 2012 9:24 pm

[Mod note: Moved from Installation Forum to IIS Installation Forum;]

User avatar
ArjanR
Joomla! Explorer
Joomla! Explorer
Posts: 449
Joined: Fri Jun 24, 2011 8:31 am
Contact:

Re: joomla on windows server with index.php or Index.php?

Post by ArjanR » Mon May 21, 2012 7:54 am

Hi again.
I always use Akeeba when uploading my website from localhost to a server. Using kickstart at the same time. That has not been any problem until i came upon this server.
Using ftp i tried to delete everything from the server yesterday but some directories could not be deleted, i don't know why. Haven't had that problem before. I uploaded again from localhost using akeeba. That's why it might look like it does now. I'm not sure it explain the problem i have though cause i have uploaded it before without a joomla install.

the directory i upload to is named http which i find odd because that's not what i'm used to from common servers
I will read akeeba again, maybe there is some documentation specially on plesk panel?
Last edited by ArjanR on Mon May 21, 2012 8:08 am, edited 1 time in total.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: joomla on windows server with index.php or Index.php?

Post by humvee » Mon May 21, 2012 7:58 am

I also just remembered not having mentioned that the permissions on your configuration.php file in joomla_root/ are incorrectly set at 666 and should be 644. Your folder permissions are also all incorrectly set at 777 and should be 755.

The system tmp/ file is also not writable and this needs to be rectified.

Look into the missing/not enabled extension mysqli/mcrypt/suhosin and make sure these are available or properly substituted. MySQLI is particularly important from my understanding.

Currently your server is only showing as suitable for Joomla! 1.5 so any work on Akeeba may well be unnecessary or at best diversionary from sorting out the key issues.

Sorry I got blinkered on Akeeba not on the underlying issues!!

The web_root/ directory can be called many things www/ or htdocs/ or httpd/.

Check with the host that http/ is indeed the location you should be using on their server

User avatar
ArjanR
Joomla! Explorer
Joomla! Explorer
Posts: 449
Joined: Fri Jun 24, 2011 8:31 am
Contact:

Re: joomla on windows server with index.php or Index.php?

Post by ArjanR » Mon May 21, 2012 8:29 am

Thanks for the reply. I will pass this on to the serverhost as i feel it is his resposibillity to solve the joomla! 1.5 issue.

i will return when that item is solved and the problems are still there. I could use some guiding in the issue with the permissions on the configuration.php and the system tmp if they still exist. Is it an issue i should solve or the serverhost?

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: joomla on windows server with index.php or Index.php?

Post by humvee » Mon May 21, 2012 6:38 pm

ArjanR wrote: i will return when that item is solved and the problems are still there. I could use some guiding in the issue with the permissions on the configuration.php and the system tmp if they still exist. Is it an issue i should solve or the serverhost?
Then I would hazard a guess at to be honest especially if you have changed nothing yourself, their system should not be doing this.
If you have done something then obviously it is down to you.
Sorry for the vagueness. :eek:
However, it is unsafe as it currently is so I would suggest ultimately it is down to you and your choice of host (or that of the client if applicable).

User avatar
ArjanR
Joomla! Explorer
Joomla! Explorer
Posts: 449
Joined: Fri Jun 24, 2011 8:31 am
Contact:

Re: joomla on windows server with index.php or Index.php?

Post by ArjanR » Tue May 22, 2012 5:01 am

I uploaded the same site to a subdirectory on the server i use for my own website and everything works fine. That leads to the conclusion that the problem lies not with the website i made but with the server.

I'll give u an update when it's fixed.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: joomla on windows server with index.php or Index.php?

Post by humvee » Tue May 22, 2012 8:56 am

ArjanR wrote:That leads to the conclusion that the problem lies not with the website i made but with the server.
Compare the configuration.php files and all the individual settings between the two installations.

Have you installed a Web_config file in the web_root/ directory?

Whilst I have yet to look in detail at any of the comparable settings between this and .htaccess myself, it might be something to do with the equivalent mod_rewrite settings in Web_config or the paths that are defined.

You can also set the sequence of "priority" of index.php, index.html, index.htm etc that a browser uses when encountering these in the root/

This is the link I found to the MS support pages for Web_config http://support.microsoft.com/search/def ... 057&mode=r but I don't currently have the time to look myself as in the middle of writing Joomla! support manuals (IIS is currently lower down the list I am afraid!!), as well as trying to help the considerable majority of users on AMP as opposed to WIMP (I love that acronym for Microsoft 8) ) on these forums.

User avatar
ArjanR
Joomla! Explorer
Joomla! Explorer
Posts: 449
Joined: Fri Jun 24, 2011 8:31 am
Contact:

Re: joomla on windows server with index.php or Index.php?

Post by ArjanR » Tue May 22, 2012 10:08 pm

Thx for spending time on this. I will take a look into this but i got an other assignment at the moment too and can't spend too much time on this.
I had contact with my server host after he changed the index.php into Index.php today. The result was that two websites i have running there didn't work anymore. According to hím the index files should always be with a big I on this kind of server. I stated that i never encounter any problems with my uploading websites from my pc to a server and he changed it back to a little i. He thinks it will be a problem when i install updates.
It certainly isn't my kind of field. If it was for me i would move to another server but i'm not the owner of the domains.

sincerely

User avatar
RussW
Joomla! Exemplar
Joomla! Exemplar
Posts: 9352
Joined: Sun Oct 22, 2006 4:42 am
Location: Sunshine Coast, Queensland, Australia
Contact:

Re: joomla on windows server with index.php or Index.php?

Post by RussW » Wed May 23, 2012 4:20 am

complete rubbish... index files should always, always be lowercase otherwise cAsE dependancy issues are observed, cross-platform and when calling for files in includes or by reference.
Joomla! on the fabulous Sunshine Coast...
hotmango, web & print http://www.hotmango.me/
The Styleguyz https://www.thestyleguyz.com/

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: joomla on windows server with index.php or Index.php?

Post by humvee » Wed May 23, 2012 9:19 am

What about the other issues I said to raise with the host? What was the outcome of this discussion or didn't you bother?

User avatar
ArjanR
Joomla! Explorer
Joomla! Explorer
Posts: 449
Joined: Fri Jun 24, 2011 8:31 am
Contact:

Re: joomla on windows server with index.php or Index.php?

Post by ArjanR » Tue May 29, 2012 8:39 am

Hi Humvee,

I certainly have not forgotten about these issues but i've been busy with another website lately (+ I have an other fulltime job and a family with 6 children :) ).
I gave a link of this thread to the host but haven't heard of him. I'm not sure he has been looking into this. I'm allso waiting for the go ahead from my customer to exchange the site he has at the moment with the one I made.

So, i'll be back to inform u how it worked out. Don't know exactly how long it will take though.

sincerely

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: joomla on windows server with index.php or Index.php?

Post by humvee » Tue May 29, 2012 11:27 am

Not to worry this thread is not going anywhere and Russ and I are around most days.


Locked

Return to “Joomla! 2.5 on IIS webserver”