Joomla! 2.5 step 1 line 1310 invalid argument for foreach()

This forum is for issues with installing Joomla! 2.5 (All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.) on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
AustinBirder
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Jun 12, 2012 12:26 am

Joomla! 2.5 step 1 line 1310 invalid argument for foreach()

Post by AustinBirder » Tue Jun 12, 2012 12:43 am

In initial installation of Joomla! 2.5, at the first step of the installation process, no languages appear for choice. Rather, an error message warns me "Invalid argument supplied for foreach() in [long path]\joomla\language\language.php on line 1310"

Line 1310 is
foreach ($subdirs as $path)

with $subdirs having been defined on line 1308 as
$subdirs = JFolder::folders($dir);

I tried reinstalling the software (4820 files!) to no avail.

Next step?

User avatar
creativesights
Joomla! Guru
Joomla! Guru
Posts: 636
Joined: Tue Jan 13, 2009 11:50 pm
Location: San Diego, California, USA
Contact:

Re: Joomla! 2.5 step 1 line 1310 invalid argument for foreac

Post by creativesights » Tue Jun 12, 2012 1:06 am

Tell us more about the platform you're installing on.

Does your platform meet all the technical requirements for Joomla!

What's the process you've used to get to where you are so far?

Did you move the files properly? Did you unzip the package properly?
Andrew Crossan
CreativeSights
Professional Custom Website Design & Development in San Diego
https://www.creativesights.com

AustinBirder
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Jun 12, 2012 12:26 am

Re: Joomla! 2.5 step 1 line 1310 invalid argument for foreac

Post by AustinBirder » Tue Jun 12, 2012 1:33 am

Platform: Web.com, which the fpa shows as a Windows NT 6.0, with Windows IIS/7.0 with less than half the memory in use.

My guess is that the platform does NOT meet all the technical requirements, but at my level of expertise, I can't tell what is missing which makes conversation with tech support at the host difficult.

I followed the steps in the Installation guide, and have it up and running on my PC, but ran into the described problem when trying to establish a web presence.

Gzip and FileZilla were used to get the files to the server.

Here is the FPA, which notes that the install was incomplete:
Forum Post Assistant (v1.2.1) : 11th June 2012 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 2.5.4-Stable (Ember) 2-April-2012
Joomla! Platform :: Joomla Platform 11.4.0-Stable (Brian Kernighan) 03-Jan-2012
Joomla! Configured :: Not Found

Host Configuration :: OS: Windows NT | OS Version: 6.0 | Technology: i586 | Web Server: Microsoft-IIS/7.0 | Encoding: gzip, deflate | Doc Root: //HOSTING/DFS/21/1/7/2/2176079271/user/sites/centraltexasbirders.org/www | System TMP Writable: Yes

PHP Configuration :: Version: 5.2.17 | PHP API: cgi-fcgi | Session Path Writable: Unknown | Display Errors: 1 | Error Reporting: 6135 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: 1 | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 2M | Max. POST Size: 8M | Max. Input Time: 60 | Max. Execution Time: 300 | Memory Limit: 128M

MySQL Configuration :: Database Credentials incomplete or not available Nothing to display.
Missing credentials detected: Connection Type missing | MySQL Host missing | Table Prefix missing | Database Username missing | Database Password missing |
Detailed Environment :: wrote:PHP Extensions :: bcmath () | calendar () | com_dotnet (0.1) | ctype () | date (5.2.17) | filter (0.11.0) | ftp () | hash (1.0) | iconv () | json (1.2.1) | odbc (1.0) | pcre () | Reflection (0.1) | session () | libxml () | standard (5.2.17) | tokenizer (0.1) | zlib (1.1) | SimpleXML (0.1) | dom (20031129) | SPL (0.2) | wddx () | xml () | xmlreader (0.1) | xmlwriter (0.1) | cgi-fcgi () | curl () | dba () | dbase () | gd () | imap () | mbstring () | exif (1.4 $Id: exif.c 293036 2010-01-03 09:23:27Z sebastian $) | mcrypt () | mssql () | mysql (1.0) | mysqli (0.1) | openssl () | PDO (1.0.4dev) | pdo_sqlsrv (2.0.1802.200) | shmop () | soap () | sockets () | SQLite (2.0-dev) | sqlsrv (2.0.1802.200) | wincache (1.2.411.0) | xmlrpc (0.51) | Zend Engine (2.2.0) |
Potential Missing Extensions :: zip | suhosin |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: No | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): No
Potential Ownership Issues: Maybe
Folder Permissions :: wrote:Core Folders :: images/ (777) | components/ (777) | modules/ (777) | plugins/ (777) | language/ (777) | templates/ (777) | cache/ (777) | logs/ (777) | tmp/ (777) | administrator/components/ (777) | administrator/modules/ (777) | administrator/language/ (777) | administrator/templates/ (777) |

Elevated Permissions (First 10) :: None _private/ (777) | _vti_log/ (777) | _vti_pvt/ (777) | _vti_script/ (777) | _vti_txt/ (777) | aspnet_client/ (777) | aspnet_client/system_web/ (777) | aspnet_client/system_web/1_1_4322/ (777) | aspnet_client/system_web/2_0_50727/ (777) |
Extensions Discovered :: wrote:Components :: SITE :: com_mailto (2.5.0) | com_wrapper (2.5.0) |
Components :: ADMIN :: com_admin (2.5.0) | com_banners (2.5.0) | com_cache (2.5.0) | com_categories (2.5.0) | com_checkin (2.5.0) | com_config (2.5.0) | com_content (2.5.0) | com_cpanel (2.5.0) | com_finder (2.5.0) | com_installer (2.5.0) | com_joomlaupdate (2.5.0) | com_languages (2.5.0) | com_login (2.5.0) | com_media (2.5.0) | com_menus (2.5.0) | com_messages (2.5.0) | com_modules (2.5.0) | com_newsfeeds (2.5.0) | com_plugins (2.5.0) | com_redirect (2.5.0) | com_search (2.5.0) | com_templates (2.5.0) | com_users (2.5.0) | com_weblinks (2.5.0) |

Modules :: SITE :: mod_articles_archive (2.5.0) | mod_articles_categories (2.5.0) | mod_articles_category (2.5.0) | mod_articles_latest (2.5.0) | mod_articles_news (2.5.0) | mod_articles_popular (2.5.0) | mod_banners (2.5.0) | mod_breadcrumbs (2.5.0) | mod_custom (2.5.0) | mod_feed (2.5.0) | mod_finder (2.5.0) | mod_footer (2.5.0) | mod_languages (2.5.0) | mod_login (2.5.0) | mod_menu (2.5.0) | mod_random_image (2.5.0) | mod_related_items (2.5.0) | mod_search (2.5.0) | mod_stats (2.5.0) | mod_syndicate (2.5.0) | mod_users_latest (2.5.0) | mod_weblinks (2.5.0) | mod_whosonline (2.5.0) | mod_wrapper (2.5.0) |
Modules :: ADMIN :: mod_custom (2.5.0) | mod_feed (2.5.0) | mod_latest (2.5.0) | mod_logged (2.5.0) | mod_login (2.5.0) | mod_menu (2.5.0) | mod_multilangstatus (2.5.0) | mod_popular (2.5.0) | mod_quickicon (2.5.0) | mod_status (2.5.0) | mod_submenu (2.5.0) | mod_title (2.5.0) | mod_toolbar (2.5.0) | mod_version (2.5.0) |

Plugins :: SITE :: plg_authentication_gmail (2.5.0) | plg_authentication_joomla (2.5.0) | plg_authentication_ldap (2.5.0) | plg_captcha_recaptcha (2.5.0) | plg_content_emailcloak (2.5.0) | plg_content_finder (2.5.0) | plg_content_geshi (2.5.0) | plg_content_joomla (2.5.0) | plg_content_loadmodule (2.5.0) | plg_content_pagebreak (2.5.0) | plg_content_pagenavigation (2.5.0) | plg_content_vote (2.5.0) | plg_editors_codemirror (1.0) | plg_editors_tinymce (3.4.9) | plg_editors-xtd_article (2.5.0) | plg_editors-xtd_image (2.5.0) | plg_editors-xtd_pagebreak (2.5.0) | plg_editors-xtd_readmore (2.5.0) | plg_extension_joomla (2.5.0) | plg_finder_categories (2.5.0) | plg_finder_contacts (2.5.0) | plg_finder_content (2.5.0) | plg_finder_newsfeeds (2.5.0) | plg_finder_weblinks (2.5.0) | plg_quickicon_extensionupdate (2.5.0) | plg_quickicon_joomlaupdate (2.5.0) | plg_search_categories (2.5.0) | plg_search_contacts (2.5.0) | plg_search_content (2.5.0) | plg_search_newsfeeds (2.5.0) | plg_search_weblinks (2.5.0) | plg_system_cache (2.5.0) | plg_system_debug (2.5.0) | plg_system_highlight (2.5.0) | plg_system_languagecode (2.5.0) | plg_system_languagefilter (2.5.0) | plg_system_log (2.5.0) | plg_system_logout (2.5.0) | plg_system_p3p (2.5.0) | plg_system_redirect (2.5.0) | plg_system_remember (2.5.0) | plg_system_sef (2.5.0) | plg_user_contactcreator (2.5.0) | plg_user_joomla (2.5.0) | plg_user_profile (2.5.0) |
Templates Discovered :: wrote:Templates :: SITE :: atomic (2.5.0) | beez5 (2.5.0) | beez_20 (2.5.0) |
Templates :: ADMIN :: bluestork (2.5.0) | hathor (2.5.0) |

User avatar
creativesights
Joomla! Guru
Joomla! Guru
Posts: 636
Joined: Tue Jan 13, 2009 11:50 pm
Location: San Diego, California, USA
Contact:

Re: Joomla! 2.5 step 1 line 1310 invalid argument for foreac

Post by creativesights » Tue Jun 12, 2012 1:46 am

You're also missing a MySQL installation which will make it impossible to complete your installation.

I recommend trying some different options with your webhost. I almost exclusively use Apache instead of IIS.

Having problems like this only this far in is not a good start....
Andrew Crossan
CreativeSights
Professional Custom Website Design & Development in San Diego
https://www.creativesights.com

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Joomla! 2.5 step 1 line 1310 invalid argument for foreac

Post by humvee » Tue Jun 12, 2012 10:57 pm

[Mod note: Moved from Installation Forum to IIS Installation Forum;]


Locked

Return to “Joomla! 2.5 on IIS webserver”