Only shows homepage

This forum is for issues with installing Joomla! 2.5 (All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.) on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
joaodaher
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Apr 27, 2012 5:20 pm

Only shows homepage

Post by joaodaher » Thu Jul 12, 2012 8:19 pm

Hi!
I've installed Joomla in my website and a template too. This installation works great on a local server (XAMPP) and on a Linux server.
But now I'm using a Windows Server 2008 and my website only shows the homepage. Whatever internal link a click, always shows the homepage.
My hosting support just gave up from helping me... :(
Any ideia?!

Here's the website: http://conseajr.com.br/camber/index.php

dkvaseeta
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 141
Joined: Mon Dec 08, 2008 3:03 pm
Location: India

Re: Only shows homepage

Post by dkvaseeta » Fri Jul 13, 2012 4:43 am

Hi, it seems that htaccess is not working here so always homepage shows.
Last edited by dkvaseeta on Mon Jul 16, 2012 6:19 am, edited 1 time in total.

joaodaher
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Apr 27, 2012 5:20 pm

Re: Only shows homepage

Post by joaodaher » Fri Jul 13, 2012 3:00 pm

dkvaseeta wrote:Hi, it seem htaccess not working here so always homepage shows.
Really?! I can fix by changing something in the .htacces?
Can you help to to figure out what is wrong?
Here's the content from the .htaccess file:

RewriteEngine On
RewriteCond %{REQUEST_URI} (/[^.]*|\.(html?|php))$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .* /index.php

Any ideas? Thanks a lot for the help! ;)


OBS: it's Joomla 2.5.4 in a IIS server.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Only shows homepage

Post by humvee » Sat Jul 14, 2012 12:08 pm

[Mod note: Moved from Installation Forum to IIS Installation Forum;]
.htaccess will have no effect on an IIS server, these changes need to be made in the web.config file instead.
As to how the settings are created/maintained - don't use it so can't help.
I can only suggest you read the first topic in this forum and use some of the links to find this out.

Alternatively, (for now) please run the Forum Post Assistant to provide the information to help us try and resolve the issue.
Please follow the instructions in the post and the program pack closely


Locked

Return to “Joomla! 2.5 on IIS webserver”