Page 1 of 1

Only shows homepage

Posted: Thu Jul 12, 2012 8:19 pm
by joaodaher
Hi!
I've installed Joomla in my website and a template too. This installation works great on a local server (XAMPP) and on a Linux server.
But now I'm using a Windows Server 2008 and my website only shows the homepage. Whatever internal link a click, always shows the homepage.
My hosting support just gave up from helping me... :(
Any ideia?!

Here's the website: http://conseajr.com.br/camber/index.php

Re: Only shows homepage

Posted: Fri Jul 13, 2012 4:43 am
by dkvaseeta
Hi, it seems that htaccess is not working here so always homepage shows.

Re: Only shows homepage

Posted: Fri Jul 13, 2012 3:00 pm
by joaodaher
dkvaseeta wrote:Hi, it seem htaccess not working here so always homepage shows.
Really?! I can fix by changing something in the .htacces?
Can you help to to figure out what is wrong?
Here's the content from the .htaccess file:

RewriteEngine On
RewriteCond %{REQUEST_URI} (/[^.]*|\.(html?|php))$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .* /index.php

Any ideas? Thanks a lot for the help! ;)


OBS: it's Joomla 2.5.4 in a IIS server.

Re: Only shows homepage

Posted: Sat Jul 14, 2012 12:08 pm
by humvee
[Mod note: Moved from Installation Forum to IIS Installation Forum;]
.htaccess will have no effect on an IIS server, these changes need to be made in the web.config file instead.
As to how the settings are created/maintained - don't use it so can't help.
I can only suggest you read the first topic in this forum and use some of the links to find this out.

Alternatively, (for now) please run the Forum Post Assistant to provide the information to help us try and resolve the issue.
Please follow the instructions in the post and the program pack closely