Joomla 2.5.6 installation error

This forum is for issues with installing Joomla! 2.5 (All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.) on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
dimitrio
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jul 25, 2012 10:52 am

Joomla 2.5.6 installation error

Post by dimitrio » Wed Jul 25, 2012 10:57 am

Hi All

I am getting this on install when entering database information:

Some errors occurred while populating the database: Duplicate entry '1' for key 'PRIMARY' SQL=INSERT INTO `jos_viewlevels` (`id`, `title`, `ordering`, `rules`) VALUES (1, 'Public', 0, '[1]'), (2, 'Registered', 1, '[6,2,8]'), (3, 'Special', 2, '[6,3,8]')


My database server is separate from my webserver.
Webserver is running IIS 7.5 and PHP 5.4.5
Database server is MySQL 5.5

I am doing a manual install in a test environment.

Any ideas?

dimitrio
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jul 25, 2012 10:52 am

Re: Joomla 2.5.6 installation error

Post by dimitrio » Wed Jul 25, 2012 2:36 pm

Ended up having to go through the same step many times correcting each database error in turn.
Had to delete rows from viewlevels, template_styles and usergroups
And drop a whole load of others:
weblinks
users
update_categories
update_sites_extensions
update_sites
updates
sessions
and on and on.

Finally got through to the ftp page of the install.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Joomla 2.5.6 installation error

Post by humvee » Sun Jul 29, 2012 4:35 pm

[Mod note: Moved from Installation Forum to IIS Installation Forum;]
By Manual Installation I assume you mean adding the Web files, creating a configuration.php file and then editing the SQL file and importing it into MySQL with phpMyAdmin?
Any particular reason for doing this?
It might actually have been easier simply making sure that the database that was created had no tables at all and rerunning the installation.
I am not aware of having seen this particular requirement previously to resolve an issue with the database and it seems likely that there is some sort of configuration error between the web server/PHP and the database server preventing effective connection.
Or it could simply have been an issue with the first installation attempt and rerunning a fresh installation would have been sufficient.
Or an error in the configuration.php file
Or an error in the permissions of the database user

Please run the Forum Post Assistant to provide the information to help us try and resolve the issue.
Please follow the instructions in the post and the program pack closely


Locked

Return to “Joomla! 2.5 on IIS webserver”