All links only display home page

This forum is for issues with installing Joomla! 2.5 (All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.) on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
exclusive86
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Aug 14, 2012 11:20 pm

All links only display home page

Post by exclusive86 » Wed Aug 15, 2012 1:13 am

rawasiqatar.brinkster.net/arabdiar.com/

I am having trouble with my links . When i click any link it changes the address but the page is always showing content of the home page. home page is a feature article.

here are my specification

joomla 2.5.6 (downloaded from http://www.joomla.org/download.html)
IIS Version 6.0
MySQL 5.1 +
PHP 5.3
do not use apache as i am on IIS
web host brinkster.com

Any help will be appreciated.

Thanks
Last edited by humvee on Thu Aug 16, 2012 5:54 pm, edited 1 time in total.
Reason: Marked as resolved as per OP installed on different host

cifar24
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Tue Jun 23, 2009 12:10 pm

Re: All links only display home page

Post by cifar24 » Wed Aug 15, 2012 11:02 am

When this happened to me, the actual content was displayed at the very end of the front page. So it looked like I was looking at the front page only.
The reason for this was when you do not have a menu item assigned to display a content then Joomla displays the modules of the front page.
Make sure the links that are not working are connected to a menu item on your site.

ckilshaw
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Jul 18, 2012 11:46 am

Re: All links only display home page

Post by ckilshaw » Wed Aug 15, 2012 3:00 pm

Hey,

I had that problem, only fix I found was a full re install. After it re installed though they worked perfectly.

exclusive86
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Aug 14, 2012 11:20 pm

Re: All links only display home page

Post by exclusive86 » Wed Aug 15, 2012 5:15 pm

cifar24 wrote:When this happened to me, the actual content was displayed at the very end of the front page. So it looked like I was looking at the front page only.
The reason for this was when you do not have a menu item assigned to display a content then Joomla displays the modules of the front page.
Make sure the links that are not working are connected to a menu item on your site.
My menu are attached to module see images
You do not have the required permissions to view the files attached to this post.

exclusive86
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Aug 14, 2012 11:20 pm

Re: All links only display home page

Post by exclusive86 » Wed Aug 15, 2012 5:27 pm

ckilshaw wrote:Hey,

I had that problem, only fix I found was a full re install. After it re installed though they worked perfectly.
i designed the site locally and then uploaded it to remote server. the site is working fine on my local pc.
You do not have the required permissions to view the files attached to this post.

exclusive86
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Aug 14, 2012 11:20 pm

Re: All links only display home page

Post by exclusive86 » Thu Aug 16, 2012 1:43 am

Thanks, for ur views and replies guys. the problem is fixed after moving to linux server .

Regards.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: All links only display home page

Post by humvee » Thu Aug 16, 2012 5:50 pm

For future reference the issue is that the server is IIS 6 which does not meet the minimum technical requirements for Joomla as stated in those requirements.
This information is also provided in the first post in this forum!


Locked

Return to “Joomla! 2.5 on IIS webserver”