problem with joomla 2.5.7 installation

This forum is for issues with installing Joomla! 2.5 (All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.) on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
ovryu85
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Sep 17, 2012 11:21 pm

problem with joomla 2.5.7 installation

Post by ovryu85 » Mon Sep 17, 2012 11:27 pm

Hi I wanted to ask how I can solve this problem. I downloaded joomla 2.5.7 to my pc, installed files via FTP to the web hosting server. Went to the site to beging the installation. Went all the way to step 6 configuration. Fille out the info their but when I click next, it stays loading and doesn´t proceed to step 7 or finish. Have I done something wrong? I don´t get an error or nothing. It just stays loading.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: problem with joomla 2.5.7 installation

Post by humvee » Tue Sep 18, 2012 7:06 am

Hi
Welcome to Joomla and to these forums.
There may be an issue with creating the configuration.php file due to permissions or similar. Does this appear in the joomla_root/ directory?
Have you tried a completely fresh installation?
When you ftp files make sure FTP client is set to binary file transfer type.
Did you you change the FTP Layer settings at step 5? If so don't.
Please run the Forum Post Assistant to provide the information to help us resolve the issue.

ovryu85
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Sep 17, 2012 11:21 pm

Re: problem with joomla 2.5.7 installation

Post by ovryu85 » Tue Sep 18, 2012 3:30 pm

humvee wrote:There may be an issue with creating the configuration.php file due to permissions or similar. Does this appear in the joomla_root/ directory?
Have you tried a completely fresh installation?
When you ftp files make sure FTP client is set to binary file transfer type.
Did you you change the FTP Layer settings at step 5? If so don't.
Please run the Forum Post Assistant to provide the information to help us resolve the issue.
Where would I find the joomla_root? (FOUND joomla_root but no configuration.php is their.

When I log into my Control Panel on the web host, I go to the directory where I uploaded joomla which would be /cart

From their I see the directories Adminitrator; Cache ; Cli ; etc.

When you ask if I've tried a fresh installation do you mean reinstalling it? This is my first Joomla installation ever, and once I uploaded I tried to go through the installation steps so in a way it is a fresh installation no?? Or should I delete everything that is in the /cart directory and add once more via FTP to web host server?

When I added joomla to the hosting server the FTP Client was under AUTO not on BINARY so I don't know if it used ASCII or BINARY.

FTP Settings on Step 5 where left alone did not touch that.

I installed the fpa do I PM you the link? I PMed you the link never the less

[Mod Note:Link to FPA deleted from thread and do not just re-edit existing posts as no one knows you have made any changes (and please don't pm anyone unless they ask you to. ;) ]

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: problem with joomla 2.5.7 installation

Post by humvee » Tue Sep 18, 2012 3:43 pm

No please read the information in the FPA post message and the details of the instructions but do not post the FPA link to your site on the forum.
When you ask if I've tried a fresh installation do you mean reinstalling it? This is my first Joomla installation ever, and once I uploaded I tried to go through the installation steps so in a way it is a fresh installation no?? Or should I delete everything that is in the /cart directory and add once more via FTP to web host server?
Yes to deleting everything and starting again, but let us do that after the FPA details are presented please.

Auto FTP setting should be alright but binary is optimum.

ovryu85
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Sep 17, 2012 11:21 pm

Re: problem with joomla 2.5.7 installation

Post by ovryu85 » Tue Sep 18, 2012 4:14 pm

Sorry for this question, the answer might be self explanatory but I just want to make sure I do things correct. You want me to copy/paste the fpa info here? Correct?

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: problem with joomla 2.5.7 installation

Post by humvee » Tue Sep 18, 2012 6:09 pm

Please read the documentation and follow the stated steps to create the necessary (correct) output for the results under this heading in the FPA forum post Using the FPA to make a post to a forum topic:

ovryu85
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Sep 17, 2012 11:21 pm

Re: problem with joomla 2.5.7 installation

Post by ovryu85 » Tue Sep 18, 2012 6:24 pm

Forum Post Assistant (v1.2.2) : 18th September 2012 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 2.5.7-Stable (Ember) 13-September-2012
Joomla! Platform :: Joomla Platform 11.4.0-Stable (Brian Kernighan) 03-Jan-2012
Joomla! Configured :: Not Found

Host Configuration :: OS: Windows NT | OS Version: 6.1 | Technology: i586 | Web Server: Microsoft-IIS/7.5 | Encoding: gzip,deflate,sdch | Doc Root: | System TMP Writable: Yes

PHP Configuration :: Version: 5.2.17 | PHP API: isapi | Session Path Writable: Unknown | Display Errors: 1 | Error Reporting: 6135 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: 1 | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 10M | Max. POST Size: 8M | Max. Input Time: 60 | Max. Execution Time: 300 | Memory Limit: 128M

MySQL Configuration :: Database Credentials incomplete or not available Nothing to display.
Missing credentials detected: Connection Type missing | MySQL Host missing | Table Prefix missing | Database Username missing | Database Password missing |
Detailed Environment :: wrote:PHP Extensions :: bcmath () | calendar () | com_dotnet (0.1) | ctype () | date (5.2.17) | filter (0.11.0) | ftp () | hash (1.0) | iconv () | json (1.2.1) | odbc (1.0) | pcre () | Reflection (0.1) | session () | libxml () | standard (5.2.17) | tokenizer (0.1) | zlib (1.1) | SimpleXML (0.1) | dom (20031129) | SPL (0.2) | wddx () | xml () | xmlreader (0.1) | xmlwriter (0.1) | ISAPI () | curl () | gd () | gettext () | imap () | mbstring () | mssql () | mysql (1.0) | mysqli (0.1) | openssl () | PDO (1.0.4dev) | pdo_mysql (1.0.2) | pdo_sqlite (1.0.1) | sockets () | SQLite (2.0-dev) | xsl (0.1) | zip (1.8.11) | ionCube Loader () | Zend Engine (2.2.0) |
Potential Missing Extensions :: mcrypt | suhosin |

Switch User Environment (Experimental) :: PHP CGI: No | Server SU: No | PHP SU: No | Custom SU (LiteSpeed/Cloud/Grid): No
Potential Ownership Issues: Maybe
Folder Permissions :: wrote:Core Folders :: images/ (777) | components/ (777) | modules/ (777) | plugins/ (777) | language/ (777) | templates/ (777) | cache/ (777) | logs/ (777) | tmp/ (777) | administrator/components/ (777) | administrator/modules/ (777) | administrator/language/ (777) | administrator/templates/ (777) |

Elevated Permissions (First 10) :: None administrator/ (777) | administrator/cache/ (777) | administrator/components/ (777) | administrator/components/com_admin/ (777) | administrator/components/com_admin/controllers/ (777) | administrator/components/com_admin/helpers/ (777) | administrator/components/com_admin/helpers/html/ (777) | administrator/components/com_admin/models/ (777) | administrator/components/com_admin/models/forms/ (777) |
Extensions Discovered :: wrote:Components :: SITE :: com_mailto (2.5.0) | com_wrapper (2.5.0) |
Components :: ADMIN :: com_admin (2.5.0) | com_banners (2.5.0) | com_cache (2.5.0) | com_categories (2.5.0) | com_checkin (2.5.0) | com_config (2.5.0) | com_content (2.5.0) | com_cpanel (2.5.0) | com_finder (2.5.0) | com_installer (2.5.0) | com_joomlaupdate (2.5.0) | com_languages (2.5.0) | com_login (2.5.0) | com_media (2.5.0) | com_menus (2.5.0) | com_messages (2.5.0) | com_modules (2.5.0) | com_newsfeeds (2.5.0) | com_plugins (2.5.0) | com_redirect (2.5.0) | com_search (2.5.0) | com_templates (2.5.0) | com_users (2.5.0) | com_weblinks (2.5.0) |

Modules :: SITE :: mod_articles_archive (2.5.0) | mod_articles_categories (2.5.0) | mod_articles_category (2.5.0) | mod_articles_latest (2.5.0) | mod_articles_news (2.5.0) | mod_articles_popular (2.5.0) | mod_banners (2.5.0) | mod_breadcrumbs (2.5.0) | mod_custom (2.5.0) | mod_feed (2.5.0) | mod_finder (2.5.0) | mod_footer (2.5.0) | mod_languages (2.5.0) | mod_login (2.5.0) | mod_menu (2.5.0) | mod_random_image (2.5.0) | mod_related_items (2.5.0) | mod_search (2.5.0) | mod_stats (2.5.0) | mod_syndicate (2.5.0) | mod_users_latest (2.5.0) | mod_weblinks (2.5.0) | mod_whosonline (2.5.0) | mod_wrapper (2.5.0) |
Modules :: ADMIN :: mod_custom (2.5.0) | mod_feed (2.5.0) | mod_latest (2.5.0) | mod_logged (2.5.0) | mod_login (2.5.0) | mod_menu (2.5.0) | mod_multilangstatus (2.5.0) | mod_popular (2.5.0) | mod_quickicon (2.5.0) | mod_status (2.5.0) | mod_submenu (2.5.0) | mod_title (2.5.0) | mod_toolbar (2.5.0) | mod_version (2.5.0) |

Plugins :: SITE :: plg_authentication_gmail (2.5.0) | plg_authentication_joomla (2.5.0) | plg_authentication_ldap (2.5.0) | plg_captcha_recaptcha (2.5.0) | plg_content_emailcloak (2.5.0) | plg_content_finder (2.5.0) | plg_content_geshi (2.5.0) | plg_content_joomla (2.5.0) | plg_content_loadmodule (2.5.0) | plg_content_pagebreak (2.5.0) | plg_content_pagenavigation (2.5.0) | plg_content_vote (2.5.0) | plg_editors_codemirror (1.0) | plg_editors_tinymce (3.5.4.1) | plg_editors-xtd_article (2.5.0) | plg_editors-xtd_image (2.5.0) | plg_editors-xtd_pagebreak (2.5.0) | plg_editors-xtd_readmore (2.5.0) | plg_extension_joomla (2.5.0) | plg_finder_categories (2.5.0) | plg_finder_contacts (2.5.0) | plg_finder_content (2.5.0) | plg_finder_newsfeeds (2.5.0) | plg_finder_weblinks (2.5.0) | plg_quickicon_extensionupdate (2.5.0) | plg_quickicon_joomlaupdate (2.5.0) | plg_search_categories (2.5.0) | plg_search_contacts (2.5.0) | plg_search_content (2.5.0) | plg_search_newsfeeds (2.5.0) | plg_search_weblinks (2.5.0) | plg_system_cache (2.5.0) | plg_system_debug (2.5.0) | plg_system_highlight (2.5.0) | plg_system_languagecode (2.5.0) | plg_system_languagefilter (2.5.0) | plg_system_log (2.5.0) | plg_system_logout (2.5.0) | plg_system_p3p (2.5.0) | plg_system_redirect (2.5.0) | plg_system_remember (2.5.0) | plg_system_sef (2.5.0) | plg_user_contactcreator (2.5.0) | plg_user_joomla (2.5.0) | plg_user_profile (2.5.0) |
Templates Discovered :: wrote:Templates :: SITE :: atomic (2.5.0) | beez5 (2.5.0) | beez_20 (2.5.0) |
Templates :: ADMIN :: bluestork (2.5.0) | hathor (2.5.0) |

ovryu85
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Sep 17, 2012 11:21 pm

Re: problem with joomla 2.5.7 installation

Post by ovryu85 » Tue Sep 18, 2012 6:26 pm

Hopefully the above info is correct. Please note that I have not deleted joomla yet, to reupload the data back onto the hosting server. I thought of sending this prior so that you can see it and maybe their is a fix to it without needing to do a fresh install once more. What I noticed was that the configure.php I think it is, is not on the /cart folder, and when I looked at the zip file that configure.php is not their either.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: problem with joomla 2.5.7 installation

Post by humvee » Wed Sep 19, 2012 7:33 am

[Mod note: Moved from Installation Forum to IIS Installation Forum.]
Thankyou for getting this right it makes it so much easier for people to see what is going on.
Clearly you are using IIS7.5 server which immediately makes a difference to the amount of available support that there is and the answers that could be given.

You should read the first post in this forum http://forum.joomla.org/viewtopic.php?f=623&t=715473 for links to help resolve the issue and for details on configuring the server for Joomla.
You should also check out the other threads in this forum from other users.
There may be more specific assistance forthcoming from other users.


Locked

Return to “Joomla! 2.5 on IIS webserver”