Errors during changing admin and now with install/reinstall

This forum is for issues with installing Joomla! 2.5 (All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.) on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
craig496
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Sep 24, 2012 5:19 pm

Errors during changing admin and now with install/reinstall

Post by craig496 » Mon Sep 24, 2012 5:27 pm

Hi fellow joomla user.

I am in desperate need of help. I have had a nightmare with my partners website today i have literally been pulling my hair out and now i am at the stage where i need to get this resolved.

After loosing the login for the admin section - i made a rash decision and took info from another forum. After i made the change in phpmyadmin the site went down and was unable to connect to sql server. Now the database has been deleted and I am really desperate to get the site back up. i deleted everything re uploaded to ftp but its not working. i have even tried to install a new version of joomla but when i go to the page i just get this error.

Code: Select all

Fatal error: Uncaught exception 'RuntimeException' with message 'DirectoryIterator::__construct(E:\Domains\h\honeybearsnursery.co.uk\user\htdocs\joomla\libraries\joomla\application/input) [<a href='directoryiterator.--construct'>directoryiterator.--construct</a>]: failed to open dir: No error' in E:\Domains\h\honeybearsnursery.co.uk\user\htdocs\joomla\libraries\loader.php:68 Stack trace: #0 E:\Domains\h\honeybearsnursery.co.uk\user\htdocs\joomla\libraries\loader.php(68): DirectoryIterator->__construct('E:\Domains\h\ho...') #1 E:\Domains\h\honeybearsnursery.co.uk\user\htdocs\joomla\libraries\joomla\application\input.php(12): JLoader::discover('JInput', 'E:\Domains\h\ho...') #2 E:\Domains\h\honeybearsnursery.co.uk\user\htdocs\joomla\libraries\loader.php(197): include_once('E:\Domains\h\ho...') #3 [internal function]: JLoader::load('JInput') #4 [internal function]: spl_autoload_call('JInput') #5 E:\Domains\h\honeybearsnursery.co.uk\user\htdocs\joomla\libraries\joomla\application\application.php(119): class_exists('JInput') # in E:\Domains\h\honeybearsnursery.co.uk\user\htdocs\joomla\libraries\loader.php on line 68
if someone has 10 mins to help me on this it would be greatly appreciated. I either want to install the new joomla with the old theme or restore the old one

much appreciateed, :'( :'( :'(
[Mod Note: I have removed your commercial support request.
If you want to advertise for Professional Support please make sure that before posting you read the: Guide for Posting Professional Requests. You can post your request for paid help in the Professional Services Forum.
Don't forget to include some contact info, as it is not possible to reply to threads in that forum.]
Last edited by humvee on Tue Sep 25, 2012 10:01 am, edited 2 times in total.
Reason: Changed title | removed financial offering | added [code] tabs

craig496
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Sep 24, 2012 5:19 pm

Re: Urgent Help Required

Post by craig496 » Mon Sep 24, 2012 5:45 pm

Quick update. got up to the bit of the new joomla instalation and now im stuck on the sql bit.

it says :Some errors occurred while populating the database: INSERT command denied to user [Mod Note: user and DB details removed for security ]for table 'n3kvj_viewlevels' SQL=INSERT INTO `n3kvj_viewlevels` (`id`, `title`, `ordering`, `rules`) VALUES (1, 'Public', 0, '[1]'), (2, 'Registered', 1, '[6,2,8]'), (3, 'Special', 2, '[6,3,8]')

any one knows what this means so i can get the old site back up

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Urgent Help Required

Post by humvee » Tue Sep 25, 2012 9:48 am

Hi
Welcome to Joomla and to these forums, wish it was under better circumstances.
Before you start reinstalling anything and possibly losing any chance to recover the original site:
  1. Are you sure the original database has been deleted?
  2. What precisely were the changes the other site told you to make?
  3. How did you do these?
  4. In phpMyAdmin for the MySQL Database are there any tables displayed at all from the original site?
  5. Do you have a complete backup of the site and database from before your attempted changes?
Please run the Forum Post Assistant to provide the information to help us try and resolve the issue.
Please follow the instructions in the post and the program pack closely.

[Mod note: Moved from Installation Forum to IIS Installation Forum; ]
To help you, in the future, find the correct forum for your topic please read the Which forum to post your question that I have put together.


Locked

Return to “Joomla! 2.5 on IIS webserver”