index.php cannot be recognized since updating to 2.5.7

This forum is for issues with installing Joomla! 2.5 (All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.) on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
knak55
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Oct 09, 2012 4:36 am

index.php cannot be recognized since updating to 2.5.7

Post by knak55 » Tue Oct 09, 2012 5:09 am

When I set up Joomla 2.5.6, I was able to see the Joomla home page and the administrator page by accessing to the URL of "http://<domain name>/joomla/" and "http://<domain name>/joomla/administrator/" respectively.
However, since I updated the site to Joomla 2.5.7, I cannot see the Joomla home page by just the same URL. Instead, I need to access to "http://<domain name>/joomla/index.php". But I CAN see the Joomla administrator page with the same URL as before, that is, I don't need to specify index.php after the URL.

Is there any way to see the Joomla home page without specifying index.php like the administrator page?
Last edited by humvee on Sat Nov 03, 2012 3:00 pm, edited 1 time in total.
Reason: Marked as resolved

User avatar
Shmata
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Wed Apr 04, 2012 5:35 am
Location: THR
Contact:

Re: index.php cannot be recognized since updating to 2.5.7

Post by Shmata » Tue Oct 09, 2012 6:35 am

Yes there is a way to brows the joomla front-end pages without index.php suffix.
1st: login to administrator
2st: Site menu -> Global Configuration -> in site tab SEO Settings there are 5 options , you should choose No for all options except first option .
for Search Engine Friendly URLs choos yes and for others choose NO

knak55
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Oct 09, 2012 4:36 am

Re: index.php cannot be recognized since updating to 2.5.7

Post by knak55 » Tue Oct 09, 2012 10:16 pm

Hi Shmata,

Thank you for your suggestion.
Though I checked the current SEO settings, they have been already set as you mentioned. However, if I chose "No" for all settings including "Search Engine Friendly URLs", I can access to the Joomla Home page without "index.php". I think this is the only way to do this so far.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: index.php cannot be recognized since updating to 2.5.7

Post by humvee » Fri Oct 12, 2012 5:33 pm

[Mod note: Moved from Admin Forum to Upgrade Forum;]
To help you, in the future, find the correct forum for your topic please read the Which forum to post your question that I have put together.
  1. Make sure the database has been updated to reflect the changes from the update(s)
    1. Go to the Extensions=>Extension Manager->Database tab
    2. CLICK the Fix button (top right toolbar).
  2. Also , make sure that you clear the Joomla cache files.
    1. Go to Extensions=>Extension Manager->Updates tab
    2. CLICK Purge Cache
  3. Report back with the outcome.

knak55
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Oct 09, 2012 4:36 am

Re: index.php cannot be recognized since updating to 2.5.7

Post by knak55 » Mon Oct 15, 2012 12:17 am

I am really sorry that I did not post my question to the appropriate forum.
Though I have done all the operation you mentioned, the situation does not change.
When I used Joomla 2.5.6, there was no problem even if I set "Search Engine Friendly URLs" to "Yes".
Is there anything I can do for this problem?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37264
Joined: Sat Apr 05, 2008 9:58 pm

Re: index.php cannot be recognized since updating to 2.5.7

Post by Webdongle » Mon Oct 15, 2012 12:59 am

Try placing the following at the bottom of the .htaccess file
DirectoryIndex index.php index.html
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

knak55
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Oct 09, 2012 4:36 am

Re: index.php cannot be recognized since updating to 2.5.7

Post by knak55 » Mon Oct 15, 2012 2:14 am

I am sorry that I did not mention about the web server.
I make use of IIS as the web server right now, as the web hosting site uses it. So I cannot use .htaccess file.
Incidentally the administrator site (http://<domain name>/joomla/administrator/) can be accessed without index.php even if I set "Search Engine Friendly URLs" to "Yes". Does this mean this "Search Engine Friendly URLs" setting is always "No" for the administrator site?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 25879
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: index.php cannot be recognized since updating to 2.5.7

Post by Per Yngve Berg » Mon Oct 15, 2012 9:44 am

Mod. Note: Relocated the topic to the Installation on IIS server forum.

On an IIS server, you have to use a web.config file. Rename webconfig.txt to web.config.

knak55
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Oct 09, 2012 4:36 am

Re: index.php cannot be recognized since updating to 2.5.7

Post by knak55 » Tue Oct 16, 2012 12:18 am

I am sorry that I posted this question to the wrong forum.
Thanks to your suggestion, the problem is sorted out with the following procedure.
1. Rename web.config.txt to web.config.
2. Add the following statement inside the <system.webServer> tag in the web.config file.
<defaultDocument>
<files>
<clear/>
<add value="index.php" />
</files>
</defaultDocument>
Note: The situation did not change with just renaming the configuration file. And when I removed <clear/> from the above statement, the Joomla caused "Internal Server Error".

I am not sure why Joomla 2.5.6 worked well even when I set "Search Engine Friendly URLs" to "On". I wonder if the upgrade of Joomla from 2.5.6 to 2.5.7 removed this configuration file.
Anyway my problem is resolved. Many Thanks!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37264
Joined: Sat Apr 05, 2008 9:58 pm

Re: index.php cannot be recognized since updating to 2.5.7

Post by Webdongle » Tue Oct 16, 2012 12:23 am

Please run the http://forum.joomla.org/viewtopic.php?f=621&t=582860 and post the results here.

Do you use a custom Template If yes then try setting the default Template to a standard unmodified Template.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

knak55
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Oct 09, 2012 4:36 am

Re: index.php cannot be recognized since updating to 2.5.7

Post by knak55 » Tue Oct 16, 2012 1:18 am

The attached is the output of the Forum Post Assistant(Only the doc root information is changed).
Even if I changed the template to the "Atomic - Default", the situation does not change.
That is, when I rename web.config.txt to web.config and add the defaultDocument setting in the configuration file, the problem is sorted out. Otherwise the problem remains.

------------- the output of the Forum Post Assistant ----------------------------------
Problem Description :: Forum Post Assistant (v1.2.3) : 16th October 2012 wrote:index.php cannot be recognized after updating 2.5.7
Log/Error Message :: Forum Post Assistant (v1.2.3) : 16th October 2012 wrote:Not Found
Actions Taken To Resolve by Forum Post Assistant (v1.2.3) 16th October 2012 wrote:Rename web.config.txt to web.config and add the follwoing description to the file.
<defaultDocument>
<files>
<clear/>
<add value=\"index.php\" />
</files>
</defaultDocument>
Forum Post Assistant (v1.2.3) : 16th October 2012 wrote:
Basic Environment :: wrote:Joomla! Instance :: Not Found
Joomla! Configured :: Not Found

Host Configuration :: OS: Windows NT | OS Version: 6.0 | Technology: i586 | Web Server: Microsoft-IIS/7.0 | Encoding: | Doc Root: D:/inetpub/vhosts/<modified>/httpdocs | System TMP Writable: Yes

PHP Configuration :: Version: 5.2.13 | PHP API: cgi-fcgi | Session Path Writable: Unknown | Display Errors: 1 | Error Reporting: 6135 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: 1 | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 2M | Max. POST Size: 8M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 128M

MySQL Configuration :: Database Credentials incomplete or not available Nothing to display.
Detailed Environment :: wrote:PHP Extensions :: bcmath () | calendar () | com_dotnet (0.1) | ctype () | date (5.2.13) | filter (0.11.0) | ftp () | hash (1.0) | iconv () | json (1.2.1) | odbc (1.0) | pcre () | Reflection (0.1) | session () | libxml () | standard (5.2.13) | tokenizer (0.1) | zlib (1.1) | SimpleXML (0.1) | dom (20031129) | SPL (0.2) | wddx () | xml () | xmlreader (0.1) | xmlwriter (0.1) | cgi-fcgi () | curl () | gd () | gettext () | imap () | mbstring () | mssql () | mysql (1.0) | PDO (1.0.4dev) | pdo_sqlite (1.0.1) | sockets () | SQLite (2.0-dev) | xsl (0.1) | Zend Engine (2.2.0) |
Potential Missing Extensions :: zip | openssl | mysqli | mcrypt | suhosin |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: No | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): No
Potential Ownership Issues: Maybe
-----------------------------------------------------------------------------------------------------------

User avatar
euoceo
Joomla! Guru
Joomla! Guru
Posts: 955
Joined: Fri Sep 12, 2008 2:48 pm
Location: Sacramento
Contact:

Re: index.php cannot be recognized since updating to 2.5.7

Post by euoceo » Tue Oct 16, 2012 3:24 am

Is this your own server that you have access to ISS manager? If so, check the properties for that domain and that your Joomla is in the correct directory, and that index.php is define in the html/index tab. Did this happen immediately after the 2.5.7 update? One my servers run IIS and I can see about testing this out depending on your answers, I'd suspect something corrupt with the php install/library or a configuration issue with the domain's entry.
Joomla! Web Hosting, Design, and Consulting.
Portfolio: http://www.calweb.com/joomla
Please do not PM me for help, use the forums first.

knak55
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Oct 09, 2012 4:36 am

Re: index.php cannot be recognized since updating to 2.5.7

Post by knak55 » Tue Oct 16, 2012 4:15 am

Unfortunately as I make use of a web hosting service, I cannot access to the IIS manager. The service provides the Joomla 2.5.6 as a CMS product. So I set up the Joomla 2.5.6 and then I upgraded it to 2.5.7. Before upgrading to 2.5.7, I was able to access to the Joomla site without specifying "index.php" and the setting of "Search Engine Friendly URLs" was "On" at that time. Just after upgrading to 2.5.7, I failed to access to the site without specifying "index.php". But now I can access without "index.php" by setting the web.config file.

User avatar
euoceo
Joomla! Guru
Joomla! Guru
Posts: 955
Joined: Fri Sep 12, 2008 2:48 pm
Location: Sacramento
Contact:

Re: index.php cannot be recognized since updating to 2.5.7

Post by euoceo » Tue Oct 16, 2012 5:00 am

So is everything fixed now? Sounds like the web.config file was the answer?
Joomla! Web Hosting, Design, and Consulting.
Portfolio: http://www.calweb.com/joomla
Please do not PM me for help, use the forums first.

knak55
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Oct 09, 2012 4:36 am

Re: index.php cannot be recognized since updating to 2.5.7

Post by knak55 » Tue Oct 16, 2012 5:12 am

Yes. The web.confing file resolved my problem, though I do not know why upgrading to 2.5.7 caused this problem.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37264
Joined: Sat Apr 05, 2008 9:58 pm

Re: index.php cannot be recognized since updating to 2.5.7

Post by Webdongle » Fri Nov 02, 2012 10:23 pm

knak55 wrote:...
I am not sure why Joomla 2.5.6 worked well even when I set "Search Engine Friendly URLs" to "On". I wonder if the upgrade of Joomla from 2.5.6 to 2.5.7 removed this configuration file.
...
The web.config.txt in 2.5.6 and 2.5.7 are exactly the same.

Could you install 2.5.6 in a sub directory(and to a different database) then rename web.config.txt to web.config and update that site. See if the web.config is removed ?

If you could do it via the Joomla update component and via the extension manager install .. the results would be very useful.

How did you update before ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein


Locked

Return to “Joomla! 2.5 on IIS webserver”