Administration Login problem

This forum is for issues with installing Joomla! 2.5 (All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.) on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
eiland88
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue May 13, 2014 8:18 pm

Administration Login problem

Post by eiland88 » Tue May 13, 2014 8:46 pm

when i try to log in to my Administration Login, i get the below page:
Deprecated: Assigning the return value of new by reference is deprecated in /home/xxx/libraries/openid/Auth/OpenID/Consumer.php on line 268

Deprecated: Assigning the return value of new by reference is deprecated in /home/xxx/libraries/openid/Auth/OpenID/Consumer.php on line 274

Deprecated: Assigning the return value of new by reference is deprecated in /home/xxx/libraries/openid/Auth/OpenID/Consumer.php on line 276


then i search to solved.
then below page appears:

Warning: require_once(Auth/OpenID/Consumer.php) [function.require-once]: failed to open stream: No such file or directory in /home/xxx/libraries/openid/consumer.php on line 15

Fatal error: require_once() [function.require]: Failed opening required 'Auth/OpenID/Consumer.php' (include_path='/home/xxx/libraries/openid/.:/usr/local/lib/php') in /home/xxx/libraries/openid/consumer.php on line 15


Can someone help me? or know how to solve this problem? I cannot upload anything.

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19646
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: Administration Login problem

Post by dhuelsmann » Tue May 13, 2014 8:55 pm

What version of PHP are you on?
Regards, Dave
Past Treasurer Open Source Matters, Inc.
Past Global Moderator
http://www.kiwaniswest.org

eiland88
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue May 13, 2014 8:18 pm

Re: Administration Login problem

Post by eiland88 » Tue May 13, 2014 8:59 pm

i think PHP5.4

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19646
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: Administration Login problem

Post by dhuelsmann » Tue May 13, 2014 9:43 pm

eiland88 wrote:i think PHP5.4
OpenID originally broke in PHP 5.3 back in 2009 for Joomla 1.5.x. It should have been fixed in for Joomla 1.6. You might try downloading a full 2.5.x package and extracting consumer.php to your current install. Or, if you are not on 2.5.20, upgrading to that version.
Regards, Dave
Past Treasurer Open Source Matters, Inc.
Past Global Moderator
http://www.kiwaniswest.org

eiland88
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue May 13, 2014 8:18 pm

Re: Administration Login problem

Post by eiland88 » Mon May 26, 2014 8:50 pm

Dear Dave,
Someone from China told me he can solve it for me, but now he respond to me he cannot solve it.
Could you perhaps help me to solve it?
Regards Ken

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19646
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: Administration Login problem

Post by dhuelsmann » Mon May 26, 2014 8:57 pm

You didn't say what version of Joomla you are on.
Regards, Dave
Past Treasurer Open Source Matters, Inc.
Past Global Moderator
http://www.kiwaniswest.org

eiland88
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue May 13, 2014 8:18 pm

Re: Administration Login problem

Post by eiland88 » Tue May 27, 2014 10:08 pm

I forget which version, but remember it was installed in 2009

eiland88
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue May 13, 2014 8:18 pm

Re: Administration Login problem

Post by eiland88 » Thu May 29, 2014 2:42 pm

i have checked Joomla! 1.5

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19646
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: Administration Login problem

Post by dhuelsmann » Thu May 29, 2014 2:58 pm

dhuelsmann wrote:OpenID originally broke in PHP 5.3 back in 2009 for Joomla 1.5.x. It should have been fixed in for Joomla 1.6. You might try downloading a full 2.5.x package and extracting consumer.php to your current install. Or, if you are not on 2.5.20, upgrading to that version.
Regards, Dave
Past Treasurer Open Source Matters, Inc.
Past Global Moderator
http://www.kiwaniswest.org

eiland88
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue May 13, 2014 8:18 pm

Re: Administration Login problem

Post by eiland88 » Sun Jun 01, 2014 11:31 am

I have downloaded the Joomla_2.5.20-Stable-Full_Package, but i am not able to find consumer.php. Are you able to tell me where i can find consumer.php?
After i installed joomla 3.3.0, I also had this problem showing up when logging into my website as an administrator: "Your host needs to disable magic_quotes_gpc to run this version of Joomla!"
Regards, Ken

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19646
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: Administration Login problem

Post by dhuelsmann » Sun Jun 01, 2014 11:59 am

You have me completely confused now. After I suggest you upgrade to 2.5.20, you then tell me you are actually on 1.5.x then just now you describe installing 3.3.0 and have issues with magic quotes. What exactly is your problem and with what version of Joomla?

If it is 1.5.x and as described initially then,
if you are seeing an error (when logging in to Joomla’s backend) that is related to OpenID or LDAP and you know that you’re not using either of them and you are using Joomla 1.5, then here’s what you need to do:

Go to phpMyAdmin and select the database that contains the data of your Joomla website.
Run the following query:

UPDATE jos_plugins SET `access` = 1, `ordering`=1, `published`=1 WHERE `id` = 1;

The above query will enable the default authentication for Joomla (which is usually what the Joomla administrator wants). Now we need to disable the rest of the authentication plugins by running the following query:

UPDATE jos_plugins SET `published`=0 WHERE `name` LIKE 'Authentication%' AND `id` != 1;

Running the above query will ensure 2 things:

There won’t be other authentication plugins that will take priority over Joomla’s default authentication.
Joomla will not wait for other authentication plugins (that may connect to 3rd party servers) to run if the provided credentials are incorrect.
Regards, Dave
Past Treasurer Open Source Matters, Inc.
Past Global Moderator
http://www.kiwaniswest.org

eiland88
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue May 13, 2014 8:18 pm

Re: Administration Login problem

Post by eiland88 » Sun Jun 01, 2014 12:54 pm

I am sorry to confuse you, i didn't formulated it correctly. I have downloaded 2.5.x but i couldn't find the consumer.php inside the file. I would like to solve the consumer.php problem so can you tell me where to find it?
After i couldn't find it i installed joomla 3.3.0 on the server on another location and i got the "Your host needs to disable magic_quotes_gpc to run this version of Joomla!" error code.
The first problem is my priority, but if i am not able to solve that problem i want to solve the second one.
Regards, Ken

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19646
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: Administration Login problem

Post by dhuelsmann » Sun Jun 01, 2014 1:01 pm

The only reason I mentioned 2.5.20 was because you posted in a 2.5 forum. The solution to your 1.5 issue is in the last post I made above.
Regards, Dave
Past Treasurer Open Source Matters, Inc.
Past Global Moderator
http://www.kiwaniswest.org

eiland88
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue May 13, 2014 8:18 pm

Re: Administration Login problem

Post by eiland88 » Sun Jun 01, 2014 6:38 pm

Thank you very much, i was able to solve the problem with phpmyadmin.
Regards, Ken

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19646
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: Administration Login problem

Post by dhuelsmann » Sun Jun 01, 2014 6:46 pm

Glad you got it sorted
Regards, Dave
Past Treasurer Open Source Matters, Inc.
Past Global Moderator
http://www.kiwaniswest.org


Locked

Return to “Joomla! 2.5 on IIS webserver”