How to correct mysql/mysqli connections

Need help with the Administration of your Joomla! 2.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
bulgin
Joomla! Explorer
Joomla! Explorer
Posts: 273
Joined: Sun Sep 30, 2007 10:18 pm

How to correct mysql/mysqli connections

Post by bulgin » Sat Feb 06, 2021 10:08 pm

Hello.

I have an older joomla install that I need to incrementally update to get current. Below are the production server joomla data and FPA data.

I migrated this older install to my test server which is running php 5.1 because the version of joomla is 2.5.4 and I'd rather upgrade incrementally on the test server first.

Yet I still can't connect to the database on the test server and maybe some clues are in the below FPA data. and joomla information.

==========================================
Here is the information from the production server where I can connect:

Database Version 5.6.41-84.1
Database Collation utf8_general_ci
PHP Version 5.4.45
Web Server Apache
WebServer to PHP Interface cgi-fcgi
Joomla! Version Joomla! 2.5.4 Stable [ Ember ] 2-April-2012 14:00 GMT
Joomla! Platform Version Joomla Platform 11.4.0 Stable [ Brian Kernighan ] 03-Jan-2012 00:00 GMT
User Agent Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:85.0) Gecko/20100101 Firefox/85.0
==========================================
Here is the FPA data from the test server for the same install for which I cannot connect:
Forum Post Assistant (v1.6.2) : 6-Feb-2021 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 2.5.4-Stable (Ember) 2-April-2012
Joomla! Platform :: Joomla Platform 11.4.0-Stable (Brian Kernighan) 03-Jan-2012
Joomla! Configured :: Yes | Read-Only (444) |
Configuration Options :: Offline: false | SEF: true | SEF Suffix: true | SEF ReWrite: true | .htaccess/web.config: Yes | GZip: true | Cache: true | CacheTime: 15 | CacheHandler: file | CachePlatformPrefix: N/A | FTP Layer: false | Proxy: N/A | LiveSite: | Session lifetime: 15 | Session handler: database | Shared sessions: N/A | SSL: 0 | Error Reporting: default | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 2.5.4: Yes | Database Supports J! 2.5.4: Unknown | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 5.8.0-41-generic | Technology: x86_64 | Web Server: Apache/2.4.46 (Ubuntu) | Encoding: gzip, deflate | System TMP Writable: Yes | Free Disk Space : 101.49 GiB |

PHP Configuration :: Version: 5.6.40-39+ubuntu20.04.1+deb.sury.org+1 | PHP API: apache2handler | Session Path Writable: Yes | Display Errors: | Error Reporting: 22527 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: 1 | Open Base: | Uploads: 1 | Max. Upload Size: 2M | Max. POST Size: 8M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 128M

Database Configuration :: Connection Error: 2054:Server sent charset unknown to the client. Please, report to the developersUser Privileges : Unknown
Detailed Environment :: wrote:PHP Extensions :: Core (5.6.40-39+ubuntu20.04.1+deb.sury.org+1) | date (5.6.40-39+ubuntu20.04.1+deb.sury.org+1) | ereg () | libxml () | openssl () | pcre () | zlib (2.0) | filter (0.11.0) | hash (1.0) | Reflection ($Id: 5f15287237d5f78d75b19c26915aa7bd83dee8b8 $) | SPL (0.2) | session () | standard (5.6.40-39+ubuntu20.04.1+deb.sury.org+1) | apache2handler () | mysqlnd (mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $) | PDO (1.0.4dev) | xml () | calendar () | ctype () | dom (20031129) | exif (1.4 $Id: cad29b729548e4206f0697710cc9e177f26fdff3 $) | fileinfo (1.0.5) | ftp () | gettext () | iconv () | json (1.2.1) | mysql (1.0) | mysqli (0.1) | pdo_mysql (1.0.2) | Phar (2.0.2) | posix () | readline (5.6.40-39+ubuntu20.04.1+deb.sury.org+1) | shmop () | SimpleXML (0.1) | sockets () | sysvmsg () | sysvsem () | sysvshm () | tokenizer (0.1) | wddx () | xmlreader (0.1) | xmlwriter (0.1) | xsl (0.1) | mhash () | Zend OPcache (7.0.6-devFE) | Zend Engine (2.6.0) |
Potential Missing Extensions :: zip | curl | mbstring | mcrypt |
Disabled Functions :: pcntl_alarm | pcntl_fork | pcntl_waitpid | pcntl_wait | pcntl_wifexited | pcntl_wifstopped | pcntl_wifsignaled | pcntl_wexitstatus | pcntl_wtermsig | pcntl_wstopsig | pcntl_signal | pcntl_signal_dispatch | pcntl_get_last_error | pcntl_strerror | pcntl_sigprocmask | pcntl_sigwaitinfo | pcntl_sigtimedwait | pcntl_exec | pcntl_getpriority | pcntl_setpriority | |

Switch User Environment :: PHP CGI: No | Server SU: No | PHP SU: No | Potential Ownership Issues: No

Apache Modules :: core | mod_so | mod_watchdog | http_core | mod_log_config | mod_logio | mod_version | mod_unixd | mod_access_compat | mod_alias | mod_auth_basic | mod_authn_core | mod_authn_file | mod_authz_core | mod_authz_host | mod_authz_user | mod_autoindex | mod_deflate | mod_dir | mod_env | mod_filter | mod_mime | prefork | mod_negotiation | mod_php5 | mod_reqtimeout | mod_rewrite | mod_setenvif | mod_status | Apache/2.4.46 (Ubuntu) |
Potential Missing Modules :: mod_expires | mod_security | mod_evasive | mod_dosevasive | mod_ssl | mod_qos | mod_userdir |
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (755) |

Elevated Permissions (First 10) ::
Extensions Discovered :: wrote:Components :: Site ::
Core :: com_mailto (2.5.0) ? | com_wrapper (2.5.0) ? |
3rd Party:: WF_LAYER_TITLE (2.5.18) ? | WF_CONTEXTMENU_TITLE (2.5.18) ? | WF_TEXTCASE_TITLE (2.5.18) ? | WF_FULLSCREEN_TITLE (2.5.18) ? | WF_VISUALCHARS_TITLE (2.5.18) ? | WF_HR_TITLE (2.5.18) ? | WF_PRINT_TITLE (2.5.18) ? | WF_ANCHOR_TITLE (2.5.18) ? | WF_LINK_TITLE (2.5.18) ? | WF_DIRECTIONALITY_TITLE (2.5.18) ? | WF_CHARMAP_TITLE (2.5.18) ? | WF_BROWSER_TITLE (2.5.18) ? | WF_TABLE_TITLE (2.5.18) ? | WF_XHTMLXTRAS_TITLE (2.5.18) ? | WF_CLEANUP_TITLE (2.5.18) ? | WF_INLINEPOPUPS_TITLE (2.5.18) ? | WF_SOURCE_TITLE (2.5.18) ? | WF_FONTCOLOR_TITLE (2.5.18) ? | WF_CLIPBOARD_TITLE (2.5.18) ? | WF_ARTICLE_TITLE (2.5.18) ? | WF_KITCHENSINK_TITLE (2.5.18) ? | WF_NONBREAKING_TITLE (2.5.18) ? | WF_SEARCHREPLACE_TITLE (2.5.18) ? | WF_VISUALBLOCKS_TITLE (2.5.18) ? | WF_IMGMANAGER_TITLE (2.5.18) ? | WF_SPELLCHECKER_TITLE (2.5.18) ? | WF_MEDIA_TITLE (2.5.18) ? | WF_FONTSELECT_TITLE (2.5.18) ? | WF_AUTOSAVE_TITLE (2.5.18) ? | WF_FORMATSELECT_TITLE (2.5.18) ? | WF_STYLESELECT_TITLE (2.5.18) ? | WF_PREVIEW_TITLE (2.5.18) ? | WF_FONTSIZESELECT_TITLE (2.5.18) ? | WF_STYLE_TITLE (2.5.18) ? | WF_LISTS_TITLE (2.5.18) ? | WF_FILESYSTEM_JOOMLA_TITLE (2.5.18) ? | WF_LINKS_JOOMLALINKS_TITLE (2.5.18) ? | WF_AGGREGATOR_VINE_TITLE (2.5.18) ? | WF_AGGREGATOR_VIMEO_TITLE (2.5.18) ? | WF_AGGREGATOR_DAILYMOTION_TITLE (2.5.18) ? | WF_AGGREGATOR_[youtube]_TITLE (2.5.18) ? | WF_MEDIAPLAYER_JCEPLAYER_TITLE (2.5.18) ? | WF_POPUPS_JCEMEDIABOX_TITLE (2.5.18) ? | WF_POPUPS_WINDOW_TITLE (2.5.18) ? | WF_LINK_SEARCH_TITLE (2.5.18) ? |

Components :: Admin ::
Core :: com_cpanel (2.5.0) ? | com_redirect (2.5.0) ? | com_search (2.5.0) ? | com_languages (2.5.0) ? | com_finder (2.5.0) ? | com_checkin (2.5.0) ? | com_admin (2.5.0) ? | com_weblinks (2.5.0) ? | com_cache (2.5.0) ? | com_newsfeeds (2.5.0) ? | com_users (2.5.0) ? | com_messages (2.5.0) ? | com_media (2.5.0) ? | com_content (2.5.0) ? | com_categories (2.5.0) ? | com_joomlaupdate (2.5.0) ? | com_templates (2.5.0) ? | com_menus (2.5.0) ? | com_installer (2.5.0) ? | com_banners (2.5.0) ? | com_plugins (2.5.0) ? | com_modules (2.5.0) ? | com_login (2.5.0) ? | com_config (2.5.0) ? |
3rd Party:: Gantry (3.2.19) ? | JCE (2.5.18) ? |

Modules :: Site ::
Core :: mod_stats (2.5.0) ? | mod_articles_categories (2.5.0) ? | mod_custom (2.5.0) ? | mod_syndicate (2.5.0) ? | mod_banners (2.5.0) ? | mod_search (2.5.0) ? | mod_articles_latest (2.5.0) ? | mod_articles_archive (2.5.0) ? | mod_languages (2.5.0) ? | mod_footer (2.5.0) ? | mod_articles_category (2.5.0) ? | mod_whosonline (2.5.0) ? | mod_feed (2.5.0) ? | mod_random_image (2.5.0) ? | mod_breadcrumbs (2.5.0) ? | mod_articles_popular (2.5.0) ? | mod_wrapper (2.5.0) ? | mod_articles_news (2.5.0) ? | mod_menu (2.5.0) ? | mod_users_latest (2.5.0) ? | mod_weblinks (2.5.0) ? | mod_related_items (2.5.0) ? | mod_login (2.5.0) ? | mod_finder (2.5.0) ? |
3rd Party:: Simple Email Form (1.8.6) ? | RokNavMenu (1.10) ? |

Modules :: Admin ::
Core :: mod_version (2.5.0) ? | mod_popular (2.5.0) ? | mod_custom (2.5.0) ? | mod_toolbar (2.5.0) ? | mod_quickicon (2.5.0) ? | mod_feed (2.5.0) ? | mod_latest (2.5.0) ? | mod_menu (2.5.0) ? | mod_status (2.5.0) ? | mod_title (2.5.0) ? | mod_multilangstatus (2.5.0) ? | mod_logged (2.5.0) ? | mod_submenu (2.5.0) ? | mod_login (2.5.0) ? |
3rd Party::

Libraries ::
Core ::
3rd Party::

Plugins ::
Core :: plg_extension_joomla (2.5.0) ? | plg_editors-xtd_image (2.5.0) ? | plg_editors-xtd_article (2.5.0) ? | plg_editors-xtd_pagebreak (2.5.0) ? | plg_editors-xtd_readmore (2.5.0) ? | plg_quickicon_extensionupdate (2.5.0) ? | plg_quickicon_joomlaupdate (2.5.0) ? | plg_system_cache (2.5.0) ? | plg_system_logout (2.5.0) ? | plg_system_highlight (2.5.0) ? | plg_system_redirect (2.5.0) ? | plg_system_debug (2.5.0) ? | plg_system_languagefilter (2.5.0) ? | plg_system_p3p (2.5.0) ? | plg_system_sef (2.5.0) ? | plg_system_log (2.5.0) ? | plg_system_remember (2.5.0) ? | plg_system_languagecode (2.5.0) ? | plg_user_contactcreator (2.5.0) ? | plg_user_joomla (2.5.0) ? | plg_user_profile (2.5.0) ? | plg_authentication_gmail (2.5.0) ? | plg_authentication_ldap (2.5.0) ? | plg_authentication_joomla (2.5.0) ? | plg_captcha_recaptcha (2.5.0) ? | plg_finder_newsfeeds (2.5.0) ? | plg_finder_contacts (2.5.0) ? | plg_finder_weblinks (2.5.0) ? | plg_finder_categories (2.5.0) ? | plg_finder_content (2.5.0) ? | plg_content_geshi (2.5.0) ? | plg_content_emailcloak (2.5.0) ? | plg_content_pagenavigation (2.5.0) ? | plg_content_loadmodule (2.5.0) ? | plg_content_pagebreak (2.5.0) ? | plg_content_joomla (2.5.0) ? | plg_content_vote (2.5.0) ? | plg_content_finder (2.5.0) ? | plg_search_newsfeeds (2.5.0) ? | plg_search_contacts (2.5.0) ? | plg_search_weblinks (2.5.0) ? | plg_search_categories (2.5.0) ? | plg_search_content (2.5.0) ? |
3rd Party:: plg_quickicon_jcefilebrowser (2.5.18) ? | plg_system_jce (2.5.18) ? | System - HD Gfont (3.25.1) ? | System - Gantry (3.2.19) ? | System - RokExtender (1.0) ? | plg_editors_codemirror (1.0) ? | plg_editors_tinymce (3.4.9) ? | plg_editors_jce (2.5.18) ? |
Templates Discovered :: wrote:Templates :: Site :: rt_gantry (3.2.19) ? | beez5 (2.5.0) ? | atomic (2.5.0) ? | beez_20 (2.5.0) ? |
Templates :: Admin :: bluestork (2.5.0) ? | hathor (2.5.0) ? |
Last edited by toivo on Sat Feb 06, 2021 11:03 pm, edited 1 time in total.
Reason: mod note: moved from 3.x Administration

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6614
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: How to correct mysql/mysqli connections

Post by AMurray » Sat Feb 06, 2021 11:08 pm

Is this related to your earlier question: viewtopic.php?f=710&t=984521 ???
PHP Configuration :: Version: 5.6.40-39+ubuntu20.04.1+deb.sury.org+1
FPA reports you're running PHP 5.6.40, not 5.1 (For Joomla 2.5, the PHP minimum requirement is 5.2.4 and you meet that requirement) Refer to https://downloads.joomla.org/technical-requirements

Refer here for comprehensive migration to 3.x guide: viewtopic.php?f=710&t=793171.

Refer to https://downloads.joomla.org/cms/joomla25/ for the downloads of the various 2.5.x releases and installation instructions.

I would suggest to start over with migration of the site to the test server and this time try the methods described in this documentation: https://docs.joomla.org/Copying_a_Joomla_website. Try the Akeeba (Common) method.

Download for Akeeba to suit your Joomla 2.5.x site: https://www.akeeba.com/download/akeeba- ... 4-7-4.html. Also you need to download Kickstart to restore your site - https://www.akeeba.com/download/akeeba- ... 4-1-1.html.

Before anything else this setting needs attention:
Max. Upload Size: 2M | Max. POST Size: 8M
Increase both values to at least 30M. You should be able to do this through your hosting account - either your provider has a utility to do it or you can edit the relevant php.ini file.
Regards,
--------------------------------------------------------------
A Murray
Help you I can, yes!. Post your question, you should. Keep it on topic you must!
Use the Forc....Forum Post Assistant my young Padawan!

bulgin
Joomla! Explorer
Joomla! Explorer
Posts: 273
Joined: Sun Sep 30, 2007 10:18 pm

Re: How to correct mysql/mysqli connections

Post by bulgin » Sat Feb 06, 2021 11:32 pm

Thanks @AMurry as usual, you are a life saver.

Just to be clear I will:

1)Download a joomla 2.5x onto the test server and install.
2) Download Akeeba Backup for Joomla! version 4.7.4 which is here: https://downloads.joomla.org/cms/joomla25/ (note: it's difficult to tell on that download page if 4.7.4 is for 2.5x joomla. I'm guessing the green colored cubes means it works with those versions as well as the grey-colored cubes for those versions of php)??
3) using akeeba backup, backup the production server.
4) Install the kickstarter akeepa file on the test server and let akeeba install the kickstarter file generated from the production server.

Do I have sequence right?

bulgin
Joomla! Explorer
Joomla! Explorer
Posts: 273
Joined: Sun Sep 30, 2007 10:18 pm

Re: How to correct mysql/mysqli connections

Post by bulgin » Sat Feb 06, 2021 11:36 pm

Yes @AMurry it is related to the first question and you may delete that post if it conflicts. Or should I?

bulgin
Joomla! Explorer
Joomla! Explorer
Posts: 273
Joined: Sun Sep 30, 2007 10:18 pm

Re: How to correct mysql/mysqli connections

Post by bulgin » Sun Feb 07, 2021 2:00 am

did as suggested and I'm at the part where joomla 2.5 on the local test machine is asking for database credentials.

I'm familiar with this screen and I know I'm entering the correct database, username, etc. but it will not proceed.

Message in Joomla 2.5 says cannot connect. When I activated php 5.6 on localhost machine I see these messages:

sudo a2enmod php5.6
Considering dependency mpm_prefork for php5.6:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php5.6:

I have a feeling the currently installed version of mysql is light years ahead of what joomla 2.5 is expecting?

mysqld --version
/usr/sbin/mysqld Ver 8.0.23-0ubuntu0.20.04.1 for Linux on x86_64 ((Ubuntu))

What version/flavor of mysql does joomla 2.5 require?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 27680
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: How to correct mysql/mysqli connections

Post by Per Yngve Berg » Sun Feb 07, 2021 2:59 pm

The last version of 2.5 series is 2.5.28

You should have updated many years ago.

Your server have both mysql and mysqli available.

Potential Missing Extensions :: zip | curl | mbstring | mcrypt (missing mbstring which handles multi byte character sets.)

bulgin
Joomla! Explorer
Joomla! Explorer
Posts: 273
Joined: Sun Sep 30, 2007 10:18 pm

Re: How to correct mysql/mysqli connections

Post by bulgin » Sun Feb 07, 2021 3:53 pm

Thank you Per Yngve Berg. I'm taking over the corrections the previous tech did not attend to. I must first get the current version of joomla up to some revision that is compatible with current-day versions. To do so I must first install the older versions of both php and joomla on my test server. So far I've done that but can't get past the install screen when it asks for the database credentials - which I'm entering correctly. I assume that issue is what leads you to believe I'm missing those extensions. I'll see if I can install them. Thank you.

frostmakk
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 198
Joined: Sun Dec 28, 2014 9:30 am
Location: Stavanger, Norway

Re: How to correct mysql/mysqli connections

Post by frostmakk » Sun Feb 07, 2021 5:37 pm

bulgin wrote:
Sun Feb 07, 2021 2:00 am
I have a feeling the currently installed version of mysql is light years ahead of what joomla 2.5 is expecting?
mysqld --version
/usr/sbin/mysqld Ver 8.0.23-0ubuntu0.20.04.1 for Linux on x86_64 ((Ubuntu))
What version/flavor of mysql does joomla 2.5 require?
You are correct. It will not work with a mysql 8 db. Should be one of the 5.x
As a starting point, use the same as the one you are copying from. Later on you could export the db, and then import again to a newer version of mysql.

bulgin
Joomla! Explorer
Joomla! Explorer
Posts: 273
Joined: Sun Sep 30, 2007 10:18 pm

Re: How to correct mysql/mysqli connections

Post by bulgin » Sun Feb 07, 2021 6:12 pm

Hi @frostmakk - you are correct. It's the wrong version and that's why it keeps stalling at the connect to database screen.

I don't even know if it's possible to have two versions of mysql running on one ubuntu test server. . .

frostmakk
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 198
Joined: Sun Dec 28, 2014 9:30 am
Location: Stavanger, Norway

Re: How to correct mysql/mysqli connections

Post by frostmakk » Sun Feb 07, 2021 6:24 pm

Use the 5.x MySQL version and PHP 5.6 until you have managed to get Joomla up to the current 3.9.24.
Then export the database using phpMyAdmin or similar.
Change the PHP and MySQL versions on your server. Import the database.

bulgin
Joomla! Explorer
Joomla! Explorer
Posts: 273
Joined: Sun Sep 30, 2007 10:18 pm

Re: How to correct mysql/mysqli connections

Post by bulgin » Sun Feb 07, 2021 7:37 pm

thank you @frostmakk

I think this is the missing key:

https://www.dbdeployer.com/

allows me to run multiple versions of mysql on one sandbox.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 20268
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: How to correct mysql/mysqli connections

Post by leolam » Tue Mar 23, 2021 5:22 pm

It is rather simple actually (but some work). Update your Joomla version to 2.5.28 with installing (extract and upload with ftp) https://downloads.joomla.org/cms/joomla ... format=zip

Than follow my instructions as posted here viewtopic.php?f=710&t=793171

Leo 8)
Joomla's #1 Professional Services Provider:
#Joomla Professional Support: https://gws-desk.com -
#Joomla Specialized Hosting Solutions: https://gws-host.com -
#Joomla Webmaster Services: gws-webmaster.services


Post Reply

Return to “Administration Joomla! 2.5”