You are not permitted to use that link

Need help with the Administration of your Joomla! 2.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
IPN
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Tue May 12, 2009 12:20 am

Re: You are not permitted to use that link

Postby IPN » Wed Dec 23, 2015 4:22 pm

I'm not sure what to make of this, but when I logged out and logged back in, everything worked fine. Very weird.

User avatar
candidosa2
Joomla! Explorer
Joomla! Explorer
Posts: 346
Joined: Sun Nov 05, 2006 10:20 pm
Location: Joomla Moçambique
Contact:

Re: You are not permitted to use that link

Postby candidosa2 » Thu Dec 24, 2015 12:45 am

iam Upgrade my Joomla Now to 3.4.7
when try edit my template i see that error
Error
You are not permitted to use that link to directly access that page (#17).
but when used 3.4.6 work
how can resolve it thank you

User avatar
candidosa2
Joomla! Explorer
Joomla! Explorer
Posts: 346
Joined: Sun Nov 05, 2006 10:20 pm
Location: Joomla Moçambique
Contact:

Re: You are not permitted to use that link

Postby candidosa2 » Thu Dec 24, 2015 6:10 am

Done
Now is work
try F5 And restart Localhost

pretobrazza
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Dec 03, 2011 10:59 am

Re: You are not permitted to use that link

Postby pretobrazza » Thu Dec 24, 2015 3:00 pm

Hi,

I had it on 2 backends with the latest updates to Joomla! 3.4.7 - Logging in and out of admin solved the issue!

Kind regards,
Bernard

HiTechCoach
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sun Apr 09, 2006 7:23 am
Location: Oklahoma City, OK USA
Contact:

Re: Creal the Broser's Cashe/tempoery files

Postby HiTechCoach » Fri Dec 25, 2015 1:35 am

I have found that whenever you install any updates you need to immediately clear your browser's cache (delete temporary files). If you don't you will often have many issues.

Since Joomla 2.5 I have been clearing the browser's cache after installing anything. New or updates. I now rarely have any issues.


On your Development Computer:

I also recommend setting the browser to clear the cache on exit/close. Now after you install any updates and before yu do anything else you can simple log out of Joomla and close the browser.
Boyd Trimmell, Microsoft MVP 2010-2015
aka HiTechCoach
Desktop and Web Application Developer

User avatar
Luciano
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 137
Joined: Thu Sep 08, 2005 2:04 pm
Location: Porto Alegre - Brasil
Contact:

Re: You are not permitted to use that link

Postby Luciano » Fri Mar 04, 2016 9:56 pm

slavne wrote:To add to discussion: I got the same message.

Circumstances: previous day I made and edited a new article. Today first thing when logging I updated Joomla to the lates (minor) update. After that the check in icon (lock) appeared by side of title of the newly added article that I finished the previous day. When trying to edit the article I got the message. Clicking the edit button does not help.

Solution: I logged out, then logged in again, the problem was solved.

Possible explanation: Joomla update produced some sort of inconsistency in Joomla session. The session should be killed and recreated by logging in.


Thank you sir, with your tip the issue was solved for me too!

aLvEe
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Jul 13, 2016 6:55 am

Re: You are not permitted to use that link

Postby aLvEe » Wed Jul 13, 2016 6:57 am

Thanks it's work for me too

webjo
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Tue Aug 19, 2008 2:48 pm

Re: You are not permitted to use that link

Postby webjo » Wed Sep 07, 2016 4:51 pm

I found this post while investigating this cache issue for one of my client sites also. I found the answer to this issue here:

http://www.itoctopus.com/you-are-not-pe ... la-article.

In short, if your .htaccess file contains this line:

ExpiresDefault "now plus 1 hour"

Add this line right after it:

ExpiresByType text/html "now"

This new line "instructs the browser to expire any PHP/HTML content immediately" so that the session cache information is not saved for 1 hour.

Adding this line fixed the issue in Chrome, IE 11 and Edge. The original problem did not seem to occur in Firefox.

This also fixed the issue in the back-end admin where if I tried to re-edit an article or module I got the "You are not permitted to use that link to directly access that page (#xxx)." error.

This is a "hotly" debated issue on the Joomla boards as to whether this is really a bug or not. In any case, this is the resolution I found that works so far.

User avatar
jjonker
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Sat May 27, 2006 10:18 pm
Contact:

Re: You are not permitted to use that link

Postby jjonker » Tue Oct 25, 2016 9:34 am

Thanks webjo! We have the Expire rules in our .htaccess fo all our sites. We add this using the .htaccess Maker from Admin Tools Pro. After adding the Expire rule for text/html the problem was solved.

We did not have this problem before updating to Joomla 3.6.3 as far as I can tell. So I'm not sure why this started to be an issue here. Also we only experienced this in Chrome. Not Firefox. Haven't tested it in IE or other browsers.

Anyway thanks for sharing the solution.

noxidsoft
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sun Aug 16, 2009 2:39 pm
Location: Toowoomba Qld Australia
Contact:

Re: You are not permitted to use that link

Postby noxidsoft » Wed Nov 23, 2016 6:57 am

webjo nailed it.
Kind Regards,
Noel Dixon
http://www.noxidsoft.com

divyafixx
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Dec 16, 2016 8:49 am

Re: You are not permitted to use that link

Postby divyafixx » Fri Dec 16, 2016 9:41 am

Please note that selecting the article via the left side check box and then clicking on the edit button top of the page does work, even repeatedly.

promo214
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Mon Jul 29, 2013 12:28 am

Re: You are not permitted to use that link

Postby promo214 » Sun Apr 09, 2017 11:08 pm

Commenting out all of the <IfModule mod_expires.c> block as suggested above also worked for me, but Google Page Speed wasn't happy with that. So I looked for another solution and found this one, which is working so far.

I left all the <IfModule mod_expires.c> lines enabled except one, the text/html command. I supposed since I'm editing html on the front end, this makes sense. Here's my new htaccess expires code:

Code: Select all

<IfModule mod_expires.c>
ExpiresActive On
## Commented out html line below which fixed the 404 error when editing article on front end
#ExpiresByType text/html "access plus 1 days"
ExpiresByType image/gif "access plus 1 month"
ExpiresByType image/jpeg "access plus 1 month"
ExpiresByType image/jpg "access plus 1 month"
ExpiresByType image/png "access plus 1 month"
ExpiresByType image/x-icon "access plus 1 year"
ExpiresByType text/css "access plus 1 week"
ExpiresByType text/javascript "access plus 1 week"
ExpiresByType application/x-javascript "access plus 1 month"
ExpiresByType application/javascript "access plus 1 week"
ExpiresByType application/x-shockwave-flash "access plus 1 month"
ExpiresByType application/x-font-woff   "access plus 1 year"
</IfModule>


Return to “Administration Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 3 guests