[Solved] "Failed binding to LDAP server"

Need help with the Administration of your Joomla! 2.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
jsgdmbnhl
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 156
Joined: Thu Jul 05, 2012 4:32 pm

[Solved] "Failed binding to LDAP server"

Post by jsgdmbnhl » Thu Jul 12, 2012 4:24 pm

I am trying to use Active Directory to create and authenticate new users to Joomla. I get the error: "Failed binding to LDAP server".

I did read http://ourlife01.[URL banned].com/2012/03/c ... la-25.html.
The plug-ins Authentication - Joomla and Authentication - LDAP are both enabled. The extension manager shows Authentication - LDAP as enabled. I used the values provided by my system admin for the Authentication - LDAP plug in manager. I verified that Auto-Create Users is enabled.

Any advice is appreciated.

ShMaunder
Joomla! Explorer
Joomla! Explorer
Posts: 486
Joined: Mon Jul 05, 2010 7:22 pm
Location: UK
Contact:

Re: "Failed binding to LDAP server"

Post by ShMaunder » Thu Jul 12, 2012 9:28 pm

I would use "Bind and Search" if I were you.

Then use something like:
LDAP V3: Yes
Negotiate TLS: No
Follow Referrals: No
Base DN: DC=DOMAIN,DC=LOCAL
Search String: sAMAccountName=[search]
Connect Username: ldapuser@DOMAIN.LOCAL
Connect Password: [ldap user password]
Map: Full Name: name
Map: email: mail
Map: User ID: sAMAccountName

If you still have troubles then post your config. Also, try port 3268 (global catalog). Post the contents of /logs/error.php.
Shaun Maunder
JMapMyLDAP extensions - Joomla! 2.5/3.1/3.2 LDAP Integration & SSO
http://shmanic.com/tools/jmapmyldap/

jsgdmbnhl
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 156
Joined: Thu Jul 05, 2012 4:32 pm

Re: [SOLVED]"Failed binding to LDAP server"

Post by jsgdmbnhl » Fri Jul 13, 2012 8:27 pm

ShMaunder: Thanks for your help. Joomla is now authenticating first to Active Directory.

I do not believe that the Auto-Create User function is working properly, but that will be a different post since LDAP is authenticating.

waywardnl
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Feb 15, 2015 11:52 am

Re: [Solved] "Failed binding to LDAP server"

Post by waywardnl » Thu Apr 02, 2015 2:43 pm

Thanks for the tips, this redirected my to succesfully login all users on the local intranet! Thankyou!

piloss
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Sat Apr 11, 2015 11:26 am

Re: [Solved] "Failed binding to LDAP server"

Post by piloss » Sat Apr 11, 2015 12:00 pm

Maybe it was a conflict arises between the plugin


Locked

Return to “Administration Joomla! 2.5”