Just taken over website but need help

Joomla versions 2.5, 1.7 and 1.6 are all end-of-life since December 31st 2014 and are no longer supported. Please use Joomla 3.x instead.
Locked
Taekwondo2012
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Sep 18, 2020 6:48 pm

Just taken over website but need help

Post by Taekwondo2012 » Fri Sep 18, 2020 7:08 pm

Hi,

I have just taken over an old website which uses Joomla. Its so old its on version 1.7.3 which i believe is EOL.
Is there a way i can update this to a newer version easily?

All im trying to do is update the website with wording and pictures, but i am struggling to load any pictures. just keep getting the error 'timeout' or 'httpStatus'

Any suggestions is much appreciated

thanks
mike
Last edited by imanickam on Sat Sep 19, 2020 3:12 am, edited 1 time in total.
Reason: Moved topic » from General Questions/New to Joomla! 1.5 to Migrating and Upgrading to Joomla! 2.5

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9999
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Just taken over website but need help

Post by sozzled » Fri Sep 18, 2020 8:06 pm

J! 1.7.3 is a older version in the J! 2.5 series (released in November 2011); J! 1.7.3 became EOL nine years ago. The first thing to do is to update this to J!2.5 by following the instructions at viewtopic.php?f=625&t=691030.

The next thing is to make sure that you are updated to J! 2.5.28 which was the last release in the J! 2.5 series. J! 2.5.28 provides a platform from which you can migrate to J! 3.x.

J! 2.5.28 became EOL six years ago and you should be planning to migrate your website to J! 3.x as soon as you are able to do so. Migrating from J! 2.5.28 to J! 3.x may take you a few days to complete; you will need to consider replacing your old J! 2.5 extensions (e.g components, plugins, modules, templates) because those extensions will not work with J! 3.x. Migrating to J! 3.x is not too difficult and there's a quick guide here: viewtopic.php?f=710&t=793171

Keep in mind that the technical requirements for operating old versions of J! are a little different to the technical requirements for operating the versions of J! that people use today. See https://downloads.joomla.org/technical-requirements. As a minimum, you will need a webhosting environment that supports PHP 5.6. You cannot use PHP 7.x to run J! 1.7 or even some of the older versions of J! 3.x. If your webhosting provider does not offer PHP 5 then you will not be able to update/migrate your existing website.

As I say, the first step is to get to J! 2.5.28 and then you can consider migrating your website to J! 3.x.

At this time, do not think about the "next" major release of Joomla! (J! 4) because it is still in development and no-one knows when it will be stable enough to use for production purposes.

We recommend that people should use the latest stable version of J!—currently J! 3.9.21—so that you will be able to get help when you need it. 8)

Good luck. :)
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)


Locked

Return to “Migrating and Upgrading to Joomla! 2.5”