Joomla 1.6 Article Edit User Logout Problem

Joomla versions 2.5, 1.7 and 1.6 are all end-of-life since December 31st 2014 and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
mockefj
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Tue Jul 21, 2009 4:34 pm

Joomla 1.6 Article Edit User Logout Problem

Post by mockefj » Tue Jan 11, 2011 7:54 am

Hello everyone,

I installed the new Joomla 1.6 installation on a fresh database... The only thing I did was export the previous Joomla 1.6 RC1 content table from the old database and imported it to the new database. The fields fitted perfectly so I'm almost 100% sure that this cannot be the problem.

What is happening is when I edit an existing article and click save, I'm logged out of Joomla, and when I try to log in again I get an error that says I don't have the permission to view the page.

Then I have to logout again and login again.

I cannot go through this procedure each time I want to edit an article! Any idea what may cause this? Can this be the database?

mockefj
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Tue Jul 21, 2009 4:34 pm

Re: Joomla 1.6 Article Edit User Logout Problem

Post by mockefj » Tue Jan 11, 2011 8:11 am

I found the solution I forgot to also update the assets table which is connected to the content table...

But now for the bad news I have a new problem... When I create a new article the article ID is 0, for some reason the existing articles are not counted... Any idea where I can recount the articles or update it in the database?

mbabker
Joomla! Hero
Joomla! Hero
Posts: 2236
Joined: Sun Feb 28, 2010 8:26 pm

Re: Joomla 1.6 Article Edit User Logout Problem

Post by mbabker » Tue Jan 11, 2011 3:14 pm

When the article is saved, the ID is 0? It shouldn't do this...

mockefj
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Tue Jul 21, 2009 4:34 pm

Re: Joomla 1.6 Article Edit User Logout Problem

Post by mockefj » Tue Jan 11, 2011 3:39 pm

mbabker wrote:When the article is saved, the ID is 0? It shouldn't do this...
Not when it is saved, when creating the article the initial ID is 0, after saving the error appears and then it is saved with the right ID.

Kinda strange

mbabker
Joomla! Hero
Joomla! Hero
Posts: 2236
Joined: Sun Feb 28, 2010 8:26 pm

Re: Joomla 1.6 Article Edit User Logout Problem

Post by mbabker » Tue Jan 11, 2011 3:52 pm

Until it is created in the database, an ID isn't generated. On save, an asset record should also be created for articles.

mockefj
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Tue Jul 21, 2009 4:34 pm

Re: Joomla 1.6 Article Edit User Logout Problem

Post by mockefj » Tue Jan 11, 2011 4:24 pm

mbabker wrote:Until it is created in the database, an ID isn't generated. On save, an asset record should also be created for articles.
I fiddled around in the database and deleted a suspicious article that did not show in the article manager. That fixed the problem.

Weird weird weird.

Anyways I'm all fixed up now thanks for the concern! :D


Locked

Return to “Migrating and Upgrading to Joomla! 2.5”