Updating an extension to J1.6 advice/assistance please

Joomla versions 2.5, 1.7 and 1.6 are all end-of-life since December 31st 2014 and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
gwmbox
Joomla! Explorer
Joomla! Explorer
Posts: 429
Joined: Thu Nov 10, 2005 8:05 am
Location: Western Australia
Contact:

Updating an extension to J1.6 advice/assistance please

Post by gwmbox » Mon Jan 31, 2011 11:49 am

Hi guys

I have an extension that I use in my Joomla 1.5 site (simplylinks) that does what I need but I wish to update to Joomla 1.6 but the past developer of the extension has passed it onto another group that is really non existent and I don;t expect that a J1.6 version will be available any time soon.

Anyway, I am no php developer per sae but I do understand the basics so I am sure with a few trial and errors, some wins and losses and of course some advice from those that can help, I would like to attempt to update it to J1.6 native myself, and if successful give it to everyone to use :). Of course all previous work will be credited and recognised with full details retained in the relevant files.

So I went to the Wiki to find out about how to go about this task and came across the page here http://docs.joomla.org/Upgrading_a_Joom ... Joomla_1.6 but at the top of the page it says 'Please note that the content on this page is currently incomplete. Please treat it as a work in progress'. Which for myself is like saying here is half of the stuff to update it the rest you can figure out yourself, which is fine I will have a play and see what I can come up with, but if anyone knows what is missing then it would be great to see or know what that is. :)

Likewise if there is a 'developers' cookbook for joomla 1.6 that is available to read and learn how to upgrade a J1.5 extension then please point me to it so I can buy it :)

Thanks

GW
If you don't ask....
Help yourself, use Firebug with Firefox

Locked

Return to “Migrating and Upgrading to Joomla! 2.5”