Page 1 of 1

404 - Component not found [SOLVED] - sharing knowledge

Posted: Tue Dec 20, 2011 2:26 am
by kiwiblue01
Hello
Following was an issue I faced when migrating from Joomla 1.7 to 1.7.3, and then restoring my website. Thought of sharing the solution for everyone's benefit.

Issue - 404 - Component not found)
1. an out-of-date bookmark/favourite
2. a search engine that has an out-of-date listing for this site
3. a mistyped address
4. you have no access to this page
5. The requested resource was not found.
6. An error has occurred while processing your request.
Please try one of the following pages:
* Home Page
If difficulties persist, please contact the System Administrator of this site.
Component not found

Resolution
I tried many ways but could resolve easily with the simple solution below.

Resolution 1
1. Open the configuration.php file lying in directory \xampp\htdocs\JoomlaXX (XX is your the number you gave while installing Joomla)
2. Search for string var $sef
3. Change its value from previous var $sef = '1'; to var $sef = '0';
4. Try now and it should work.
5. If it doesn't work try Resolution 2 below

Resolution 2
1. If you have multiple websites hosted already then copy configuration.php from another website, lying under that website's directory on your computer \xampp\htdocs\JoomlaXX1 (XX is your the number you gave while installing Joomla). Alternatively, copy a configuration.php from your previous Joomla installation or default Joomla installation.

2. Dump (paste) the above configuration.php file in the directory of the website wherein you are getting this issue (say \xampp\htdocs\JoomlaXX2)

3. Login as Administrator

4. Go to Site -> Global Configuration -> Server

5. Update Database Name to current website's database name (that is the db name of website which is having issue)

6. Save your changes and retry

Voila! That's all and you could manage to fix the issue!

Regards
Kiwiblue

Note - there may be other solutions and please feel free to add to the list :-)

Re: 404 - Component not found [SOLVED] - sharing knowledge

Posted: Thu Apr 04, 2013 6:55 am
by kinnarrk
Thanks a lot. First solution worked :)

Re: 404 - Component not found [SOLVED] - sharing knowledge

Posted: Sun Nov 24, 2013 10:47 pm
by gothicreader
Thanks - solution #2 worked for me.
:D

Re: 404 - Component not found [SOLVED] - sharing knowledge

Posted: Tue Oct 18, 2016 10:06 am
by sachinsehdev
FIRST SOLUTION WORKED FOR ME. THANKS