Page 2 of 3

Re: i can't login to my admin panel

Posted: Fri Jun 14, 2013 5:01 pm
by JoyP
Possible solution.......

This message is for newbies who like me may be stumbling along with huge gaps in their knowledge - learning by doing but not necessarily understanding what they are doing ...... :D

I had this problem and still don't know what caused it, but after changing my username and password in my database (via cpanel & phpmyadmin > ..._users), I still couldn't login. I tore my hair out in frustration, combing this thread and the web for suggestions, trying everything I could find, then discovered that if you change your username in the database, DON't use MD5 to encrypt it - only do this for the password.

This worked for me. I hope it helps someone else.

Re: i can't login to my admin panel

Posted: Wed Jul 17, 2013 10:30 am
by jocelp
Thanks guys! the first suggestion was the one that's solved my freaking problems. Thanks alot! Two Thumbs-up! (^_^) :D

Re: i can't login to my admin panel

Posted: Tue Jul 23, 2013 1:09 am
by senton1
I cannot access my admin login...in myphpadmin the super user is deprecated. None of my user accounts are accessable. I could everything above and none of them often work.

When I tried login one and only thing happen is usually a page refresh. Basically try creating a new account nothing happens. Im a new comer to Joomla and I cannot figure out what could possibly be wrong... please help me.

Im using joomla 2.5

Re: i can't login to my admin panel

Posted: Wed Jul 24, 2013 5:01 am
by triveni1231
jos_profile is not present with my database

Re: i can't login to my admin panel

Posted: Wed Jul 24, 2013 5:48 am
by dpradhan
Thankx everyone for showing your support.

Re: i can't login to my admin panel

Posted: Fri Aug 16, 2013 12:48 pm
by Rookie81
activ2012 wrote:I believe I found a solution.

1. I accessed phpMyAdmin
2. Accessed jos_extensions table
3. Navigated to the page of elements where the plugins are
4. I found plg_authentication_joomla was enabled as it was set to '1'
5. I found plg_user_joomla was disabled. I enabled it and was able to login

It seems I disabled this in the Admin area of Joomla and had to enable it again in phpMyAdmin
That was very helpful! Thanks.
I had a slightly different issue. I couldnt see the Joomla panel altogether nevertheless log in but I followed your steps and was able to turn off a module that was giving me a headache and voila joomla was back.
So thanks again!

Re: i can't login to my admin panel

Posted: Fri Aug 30, 2013 4:32 pm
by nicoljcraig
I have tried everything on this forum and no use so far. I have been logging into my site for ages and haven't had any issues. Suddenly I cannot login to both my sites, one running Joomla 2.5, the other 3.1. No change in password or usernames. Nothing wrong server side.

Tried changing config file, but it was already correct.

public $cookie_domain = '';
public $cookie_path = '';

Tried changing plg_authentication_joomla and plg_user_joomla on myPHPadmin but both are enabled. Anyone got any thoughts? Pretty please.

Re: i can't login to my admin panel

Posted: Mon Oct 21, 2013 7:45 am
by alexzien
I have the same problem. But mine was caused when the site was hacked. I removed the hacked files coockies.php, mod_joomla.php and the folder coockies from the ftp, but I still can't login. I have tried everything that is mentioned in this thread too. Got latest version of Joomla. Any more ideas?

Re: i can't login to my admin panel

Posted: Mon Nov 25, 2013 10:24 am
by hourioux
Hello,
Sorry for my poor english... but my experience could help someone, then i post

my problem : after modifying the cache settings in the joomla console, it was impossible to login to backend, as related by some precedent posts, the login page don't return an error message ...

my solution : after reading many posts, one of them recommand to edit and modify the configuration.php file, as follow :

public $cache_handler = 'file';
public $caching = '0';
public $session_handler = 'database';

After saving the modified file, login problems were resolved ...
If ... it can help someone ...

Best regards

Re: i can't login to my admin panel

Posted: Mon Jan 13, 2014 9:27 pm
by punktoy
Hey i just clean caché with shift+command(mac)+R ;D

Re: i can't login to my admin panel

Posted: Tue Jan 21, 2014 11:10 am
by ideleuwa
my loging page www.mydomain.com/Administrator keeps redirecting to my home page www.mydomain.com so I don't even have access to the admin panel user name and password page....

Any ideas

Re: i can't login to my admin panel

Posted: Tue Jan 21, 2014 5:45 pm
by pe7er
Did you install any 3rd party Login Protection plugin? e.g. JSecure or Admin Tools
http://extensions.joomla.org/extensions ... protection

If so don't forget to put the ?secret-security-token behind the URL,
otherwise you will be redirected to the homepage...

Re: i can't login to my admin panel

Posted: Tue Jan 21, 2014 8:31 pm
by ideleuwa
how do I get the ?secret-security-token?

Am not sure what was installed. Is there any other way I can access the admin panel?

Re: i can't login to my admin panel

Posted: Mon Jan 27, 2014 10:38 am
by ibextrex
Hi I had the same problem, your username is there and your password is filled out but will not log in, check the address has www. in front of it as it will not work unless it is in the same form the password was saved in.
Hope it helps.

Re: i can't login to my admin panel

Posted: Sat Mar 08, 2014 3:25 pm
by Bloomdido
I have just installed Joomla using the Fasthosts 'One Click' option over an old site I thought I had forgotten the password to. I couldn't log in to the new install until I rolled the install back to version 2.8. Then it let me log in. Crazy!

Re: i can't login to my admin panel

Posted: Mon Mar 10, 2014 6:48 pm
by pdxvector
Problem Description :: Forum Post Assistant (v1.2.4) : 10th March 2014 wrote:I can not log in, and get no feedback as to why
Log/Error Message :: Forum Post Assistant (v1.2.4) : 10th March 2014 wrote:None
Actions Taken To Resolve by Forum Post Assistant (v1.2.4) 10th March 2014 wrote:I run two sites with the same cookie name and changed the cookie name in the admin area hoping to solve always having to retype the password.

After I did this I could not log in as a user or as admin. When a user (or admin) tries to login, and presses submit, nothing happens other than it clears the form, and asks me to log in. No error.

I have tried:
1. Changing cfg file:
public $cookie_domain = '';
public $cookie_path = '';

2. Making sure my admin user is set to 8

3. Making sure authentication is enabled

4. Checked with other admins, they are having same things, so it is not a ban issue by IP or user issue.

5. Purged my browser cache repeatedly each change.
Forum Post Assistant (v1.2.4) : 10th March 2014 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.1.5-Stable (Ember) 01-August-2013
Joomla! Platform :: Joomla Platform 12.2.0-Stable (Neil Armstrong) 21-September-2012
Joomla! Configured :: Yes | Read-Only (444) | Owner: pdxlan (uid: 1/gid: 1) | Group: pdxlan (gid: 1) | Valid For: 3.1
Configuration Options :: Offline: 0 | SEF: 1 | SEF Suffix: 0 | SEF ReWrite: 0 | .htaccess/web.config: Yes | GZip: 0 | Cache: 0 | FTP Layer: 0 | SSL: 0 | Error Reporting: default | Site Debug: 0 | Language Debug: 0 | Default Access: 1 | Unicode Slugs: 0 | Database Credentials Present: Yes

Host Configuration :: OS: Linux | OS Version: 2.6.32-358.11.1.el6.x86_64 | Technology: x86_64 | Web Server: Apache/2 | Encoding: gzip, deflate | Doc Root: /home/pdxlan/domains/pdxlan.net/public_html | System TMP Writable: Yes

PHP Configuration :: Version: 5.3.26 | PHP API: cgi-fcgi | Session Path Writable: No | Display Errors: 1 | Error Reporting: 30711 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 32M | Max. POST Size: 8M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 128M

MySQL Configuration :: Version: 5.6.12 (Client:5.6.12) | Host: --protected-- (--protected--) | Collation: latin1_swedish_ci (Character Set: latin1) | Database Size: 4.69 MiB | #of Tables: 76
Detailed Environment :: wrote:PHP Extensions :: Core (5.3.26) | date (5.3.26) | ereg () | libxml () | openssl () | pcre () | sqlite3 (0.7-dev) | zlib (1.1) | bcmath () | calendar () | ctype () | curl () | dom (20031129) | hash (1.0) | fileinfo (1.0.5-dev) | filter (0.11.0) | ftp () | gd () | gettext () | SPL (0.2) | iconv () | json (1.2.1) | mbstring () | mcrypt () | mysql (1.0) | mysqli (0.1) | session () | PDO (1.0.4dev) | pdo_mysql (1.0.2) | pdo_sqlite (1.0.1) | standard (5.3.26) | posix () | Reflection ($Id: 4af6c4c676864b1c0bfa693845af0688645c37cf $) | Phar (2.0.1) | SimpleXML (0.1) | soap () | sockets () | SQLite (2.0-dev) | exif (1.4 $Id$) | tokenizer (0.1) | wddx () | xml () | xmlreader (0.1) | xmlwriter (0.1) | xsl (0.1) | zip (1.11.0) | cgi-fcgi () | mhash () | Zend Engine (2.3.0) |
Potential Missing Extensions :: suhosin |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) |

Elevated Permissions (First 10) ::
Extensions Discovered :: wrote:Components :: SITE :: com_wrapper (3.0.0) | com_mailto (3.0.0) |
Components :: ADMIN :: Qlue 404 (3.0) | com_installer (3.0.0) | com_media (3.0.0) | com_content (3.0.0) | com_users (3.0.0) | com_modules (3.0.0) | com_finder (3.0.0) | com_newsfeeds (3.0.0) | COM_FSF (1.11.7.1700) | com_weblinks (3.0.0) | com_joomlaupdate (3.0.0) | com_messages (3.0.0) | com_languages (3.0.0) | com_plugins (3.0.0) | com_login (3.0.0) | com_config (3.0.0) | com_redirect (3.0.0) | com_checkin (3.0.0) | com_cache (3.0.0) | com_categories (3.0.0) | com_search (3.0.0) | com_cpanel (3.0.0) | com_templates (3.0.0) | com_menus (3.0.0) | com_banners (3.0.0) | com_admin (3.0.0) | com_tags (3.1.0) |

Modules :: SITE :: mod_footer (3.0.0) | mod_menu (3.0.0) | mod_custom (3.0.0) | mod_weblinks (3.0.0) | mod_finder (3.0.0) | IFacebook Widget (1.0) | mod_syndicate (3.0.0) | S5 Tab Show (2.0.0) | mod_whosonline (3.0.0) | S5 Image and Content Fader v3 (3.2.0) | mod_wrapper (3.0.0) | mod_random_image (3.0.0) | mod_feed (3.0.0) | S5 Accordion Menu (2.0.0) | mod_tags_similar (3.1.0) | mod_breadcrumbs (3.0.0) | S5 Register (3.0.0) | mod_articles_archive (3.0.0) | mod_users_latest (3.0.0) | mod_articles_categories (3.0.0) | mod_languages (3.0.0) | Freestyle FAQs: FAQ/KB categor (1.11.7.1700) | Vinaora Nivo Slider (3.1.0) | PDX102 (1.0) | mod_search (3.0.0) | mod_login (3.0.0) | mod_banners (3.0.0) | mod_related_items (3.0.0) | mod_articles_news (3.0.0) | SP Countdown (1.0.0) | mod_articles_popular (3.0.0) | S5 Box (4.0.0) | mod_tags_popular (3.1.0) | mod_stats (3.0.0) | mod_articles_latest (3.0.0) | Freestyle FAQs: FAQs (1.10.0.1668) | mod_articles_category (3.0.0) |
Modules :: ADMIN :: mod_menu (3.0.0) | mod_custom (3.0.0) | mod_latest (3.0.0) | mod_feed (3.0.0) | mod_status (3.0.0) | mod_submenu (3.0.0) | mod_stats_admin (3.0.0) | mod_popular (3.0.0) | mod_title (3.0.0) | mod_multilangstatus (3.0.0) | mod_quickicon (3.0.0) | mod_version (3.0.0) | mod_login (3.0.0) | mod_toolbar (3.0.0) | mod_logged (3.0.0) |

Plugins :: SITE :: plg_captcha_recaptcha (3.0.0) | plg_authentication_ldap (3.0.0) | plg_authentication_gmail (3.0.0) | plg_authentication_joomla (3.0.0) | plg_editors-xtd_readmore (3.0.0) | plg_editors-xtd_article (3.0.0) | plg_editors-xtd_image (3.0.0) | plg_editors-xtd_pagebreak (3.0.0) | Button - Sourcerer (4.2.1FREE) | plg_system_log (3.0.0) | plg_system_sef (3.0.0) | plg_system_debug (3.0.0) | plg_system_remember (3.0.0) | plg_system_cache (3.0.0) | plg_system_languagefilter (3.0.0) | Qlue 404 (3.0) | PLG_ECC (3-1) | System - S5 Flex Menu (1.0) | PLG_SYSTEM_NNFRAMEWORK (13.9.6) | PLG_SYSTEM_SOURCERER (4.2.1FREE) | plg_system_redirect (3.0.0) | plg_system_p3p (3.0.0) | plg_system_logout (3.0.0) | plg_system_highlight (3.0.0) | plg_system_languagecode (3.0.0) | plg_quickicon_extensionupdate (3.0.0) | plg_quickicon_joomlaupdate (3.0.0) | plg_editors_codemirror (1.0) | plg_editors_tinymce (3.5.6) | plg_user_contactcreator (3.0.0) | plg_user_joomla (3.0.0) | plg_user_profile (3.0.0) | plg_content_loadmodule (3.0.0) | plg_content_pagebreak (3.0.0) | plg_content_emailcloak (3.0.0) | plg_content_pagenavigation (3.0.0) | plg_content_joomla (3.0.0) | plg_content_geshi (2.5.0) | plg_content_vote (3.0.0) | plg_content_finder (3.0.0) | plg_search_weblinks (3.0.0) | Search - Freestyle FAQs: FAQs (1.11.7.1700) | Search - Freestyle FAQs: Gloss (1.11.7.1700) | plg_search_newsfeeds (3.0.0) | plg_search_categories (3.0.0) | plg_search_content (3.0.0) | plg_search_contacts (3.0.0) | plg_finder_weblinks (3.0.0) | Smart Search - Freestyle FAQs: (1.11.7.1700) | plg_finder_tags (3.0.0) | Smart Search - Freestyle FAQs: (1.11.7.1700) | plg_finder_newsfeeds (3.0.0) | plg_finder_categories (3.0.0) | plg_finder_content (3.0.0) | plg_finder_contacts (3.0.0) | plg_extension_joomla (3.0.0) |
Templates Discovered :: wrote:Templates :: SITE :: protostar (1.0) | beez5 (2.5.0) | gamers (1.0) | atomic (2.5.0) | beez3 (3.1.0) | beez_20 (2.5.0) |
Templates :: ADMIN :: isis (1.0) | hathor (3.0.0) | bluestork (2.5.0) |

Re: i can't login to my admin panel

Posted: Wed Mar 19, 2014 9:39 am
by chrisways
activ2012 wrote:I believe I found a solution.

1. I accessed phpMyAdmin
2. Accessed jos_extensions table
3. Navigated to the page of elements where the plugins are
4. I found plg_authentication_joomla was enabled as it was set to '1'
5. I found plg_user_joomla was disabled. I enabled it and was able to login

It seems I disabled this in the Admin area of Joomla and had to enable it again in phpMyAdmin
:) you put a smile on my face this morning. You are wonderful. I dont know who gave you joomla apprentice to me you are joomla expert. Thanks so much. Your solution worked for me.

Re: i can't login to my admin panel

Posted: Wed Mar 26, 2014 7:46 pm
by lifsnetwork
Go to your configuration file via FTP or cpanel
Make sure the permissions are set to write 644
Open the configuration.php file
find
public $lifetime = '720'; (Note: your may have other value here)
public $session_handler = 'database';

Change to this
public $lifetime = '720'; (Note: your may have other value here)
public $session_handler = 'none';

LEAVE YOUR CONFIG FILE OPEN AFTER SAVING CHANGES
Now go log into your Joomla admin panel and stop. Once you have logged into your admin, go back to your config file and change the none back to database. That it... now go log back into your admin panel again and your fixed.

Don't forget to make sure your configuration.php permissions file is set back to 444

Regards

Re: i can't login to my admin panel

Posted: Sun Mar 30, 2014 7:18 am
by rtRegazzo
Benderook wrote:Today I had the same problem,

If you look in phpmyadmin in your database there is a table xxx_user_usergroup_map
(xxx depends on your database)There you have to change the field with the rights for your admin. eg user 62 change 0 to 8 (8 is super user)

It works. Stange error
I used SPupgrade to upgrade 1.5 to 2.5. Maby it has something to do with that?
Thank you... that was the problem for me.

Re: i can't login to my admin panel

Posted: Sun Mar 30, 2014 7:39 am
by rtRegazzo
When you log in... pay attention to the error msg given. It will tell you if your user doesn't exist in the database or not. That way you know if joomla is able to find that user.

If joomla is just stating that you can't have access then theres a good chance you've lost your administrative rights. This might have happened for a number of reasons, sometimes after installing new modules it somehow does this. I don't know why.

In phpMyAdmin... check these 2 tables - jos_users and jos_user_usergroup_map.

Make sure your user is there and the password is salted properly. You can also change the password there.. if necessary. Here are some good [youtube] tuts to show you that.
http://www.[youtube].com/watch?v=UXlBB59orYY
and
https://www.[youtube].com/watch?v=NB-G2KzeeKs

But first make sure in jos_user_usergroup_map your userID number exists and the groupID is set to 8. That is the SuperUser setting.

Re: i can't login to my admin panel

Posted: Mon Apr 07, 2014 7:41 am
by CIWebMarketing
Check your .htaccess file. You may have added a redirect or augmentation to the original file which you have forgotten about, or a third party Joomla installer may have loaded a non-standard file that is causing this error. Easiest way to test this is to take a copy of the live .htaccess file then simply delete the live file. Can you log in now?

If this is the cause then regenerate a fresh .htaccess file from htaccess.txt and load that. Then examine the rogue file to see what is in there that could be causing it.

Remember having a missing .htaccess file will wreck your seo-friendly URLs so restore the file as soon as possible.

Cheers
Richard

Re: i can't login to my admin panel

Posted: Wed Apr 09, 2014 10:09 pm
by abolay
pixiedavis wrote:Update

After reading this thread tried the remove

public $cookie_domain = 'YourCookieDomain';
public $cookie_path = '';

and making it like this

public $cookie_domain = '';
public $cookie_path = '';

All worked well and could log in.

Noticed on other sites i have that it was set as:

public $cookie_domain = 'YourCookieDomain.com';
public $cookie_path = '/';

and the setting that was throwing up the error was

public $cookie_domain = 'http://www.YourCookieDomain.com';
public $cookie_path = '/';

Take off the "http://www."

Hope this sheds light
changed user type from deprecated to Super Administrator and then I used this MD5 hash generator to update the password.

Re: i can't login to my admin panel

Posted: Mon May 26, 2014 10:34 pm
by MSchool
Hi guys,

Solution for me was to change:
public $session_handler = 'apc';

To:
public $session_handler = 'database';

I have no idea why or how it hed been set to apc.

Re: i can't login to my admin panel

Posted: Mon Jun 09, 2014 2:44 pm
by DeluxeWarPlaya
Tried everything mentioned in this thread, nothing worked for me. Joomla 2.5.17
Things I'd tried:
  • reset administrator password in j25_users as per password recovery
  • created new admin, assigned group_id 8, cant log in with that either
  • configuration.php had cookie settings as follows;
    public $cookie_domain = '';
    public $cookie_path = '';
  • disabled/enabled Joomla authentication plugin
  • Different browser as well as different location
  • session handler set to
    public $session_handler = 'database';
What worked was this:
activ2012 wrote:I believe I found a solution.

1. I accessed phpMyAdmin
2. Accessed jos_extensions table
3. Navigated to the page of elements where the plugins are
4. I found plg_authentication_joomla was enabled as it was set to '1'
5. I found plg_user_joomla was disabled. I enabled it and was able to login

It seems I disabled this in the Admin area of Joomla and had to enable it again in phpMyAdmin
Anyone else having this problem, this worked.

Re: i can't login to my admin panel

Posted: Sat Jul 19, 2014 11:33 am
by tstedel
In addition to all these steps, something weird must have happened for me.

I went into jos_extensions(I think jos_plugins was renamed to this) and set everything to enabled = 1.
I still couldn't log in and it wasn't giving me an error message. I had to disable the cache plugin(com_cache) before it would let me log in again.

Re: i can't login to my admin panel

Posted: Sun Aug 03, 2014 10:42 pm
by Cindymurphy
When I try to log in it error 500

Re: i can't login to my admin panel

Posted: Sun Aug 10, 2014 7:49 pm
by rutin

Re: i can't login to my admin panel

Posted: Tue Aug 12, 2014 10:42 pm
by ombion
I have similar issue with Joomla 3.3. I couldn't get in the admin area. There was no error message but the login box doesn't go away.
It seems there are variations for a solution to this problem. I could fix it by doing combination of the suggestions above:

1. delete browser cookie
2. Make sure config file has the lines [ public $cookie_domain = ''; ] and [ public $cookie_path = ''; ]
3. The most interesting part for me is in the database, Enabled value is 1 but Access value is 6 to which I changed it to 1. I don't know how value of 6 got there to begin with. In the end I can log in now.

Thanks for all the previous suggestions, guys.

Re: i can't login to my admin panel

Posted: Sat Aug 30, 2014 4:08 pm
by ressac
i have same problems with joomla 3.3.3
login page again reload again, and no warning

what more interesting that i'ma able to login with chrome browser where cache and cookies not cleaned, but on clean browser login page just reloads without any message

any suggestion?

Re: i can't login to my admin panel

Posted: Fri Nov 14, 2014 11:27 am
by lemon_head
Posting what worked for me just in case it can help someone!

I tried absolutely everything in this thread and nothing worked for me. What eventually solved my problem was:

1) delete all the jos_ files from my database. Those were the base Joomla installation on my server and may have been interferring with my uploaded database files (in my case, aee_)

2) in my aee_users table, my SuperUser account was registered, but 'activation' was set to '0' (meaning unactivated). By opening the table and replacing 0 with 1, I was able to log in!

I hope this helps someone :)