404 Bild Fel

Diskutera allmänna frågor rörande Joomla! 1.7 / Joomla! 1.6

Moderators: Zello, chrille

Forum rules
Forumregler
Locked
kalsson1
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Thu May 20, 2010 9:24 pm

404 Bild Fel

Post by kalsson1 » Mon Dec 05, 2011 4:42 pm

Tja!

En snabb fråga. Jag har laddat upp mina egna bilder i min (images) mapp och bifogat dom i mina artiklar. För en veckan sedan fungera dom perfekt men nu så får jag bara ett 404 error och kan inte visa bilderna? Vad är fel? Har jag råkat stänga av en inställning?

Tack på förhand...

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: 404 Bild Fel

Post by EE Photo » Mon Dec 05, 2011 4:57 pm

Kan du länka till ett exempel?
Besök gärna min webbplats: http://www.fotoforalla.se/

kalsson1
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Thu May 20, 2010 9:24 pm

Re: 404 Bild Fel

Post by kalsson1 » Mon Dec 05, 2011 6:55 pm


EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: 404 Bild Fel

Post by EE Photo » Mon Dec 05, 2011 7:04 pm

Du menar att det är ett kryss istället för en bild? Gå in i artikeln och se till så att url:n till bilden är rätt.
Besök gärna min webbplats: http://www.fotoforalla.se/

kalsson1
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Thu May 20, 2010 9:24 pm

Re: 404 Bild Fel

Post by kalsson1 » Mon Dec 05, 2011 7:28 pm

Ja men det borde den ju va. Det fungera för en vecka sen ju.. Jag bifogar den från mappen i min ftp, den måste väl hitta sökvägen själv?

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: 404 Bild Fel

Post by EE Photo » Mon Dec 05, 2011 7:32 pm

Om sökvägen ändras så kan den ju inte hitta den själv. Testa att ta bort bilden och sen lägga till den igen då borde du få den nya sökvägen om den har ändrats.
Besök gärna min webbplats: http://www.fotoforalla.se/

kalsson1
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Thu May 20, 2010 9:24 pm

Re: 404 Bild Fel

Post by kalsson1 » Mon Dec 05, 2011 7:36 pm

har redan testat det flera gånger och det händer inget.. Har också gjort en ny mapp i min ftp och lagt dom i den fungerar inte.. Har även testa Joomlas egna bilder, fungerar ej...

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: 404 Bild Fel

Post by EE Photo » Mon Dec 05, 2011 7:44 pm

Kan du testa att stänga av all SEO i Joomla och se om det fungerar bättre då?
Besök gärna min webbplats: http://www.fotoforalla.se/

kalsson1
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Thu May 20, 2010 9:24 pm

Re: 404 Bild Fel

Post by kalsson1 » Mon Dec 05, 2011 7:45 pm

Ja absolut. Hur gör man?

kalsson1
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Thu May 20, 2010 9:24 pm

Re: 404 Bild Fel

Post by kalsson1 » Mon Dec 05, 2011 7:46 pm

Jag har provat nu och det fungerar nu. Vad seo med detta att göra?

kalsson1
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Thu May 20, 2010 9:24 pm

Re: 404 Bild Fel

Post by kalsson1 » Mon Dec 05, 2011 7:54 pm

Sitter och läser att andra har samma problem typ... E det en bugg i Joomla?

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: 404 Bild Fel

Post by EE Photo » Mon Dec 05, 2011 7:59 pm

SEO ändrar ju länkar och det krävs ju en länk för att bilden ska hittas och kunna visas.

Sätt på SEO igen och gör så här. Jag säg att du hade med index.php i dina webbadresser. För att få bort det (det kan vara problemet jag vet inte) gå då in med FTP på din sajt och hitta filen htaccess.txt i din Joomla root. Ändra det filnamnet till .htaccess
Besök gärna min webbplats: http://www.fotoforalla.se/

kalsson1
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Thu May 20, 2010 9:24 pm

Re: 404 Bild Fel

Post by kalsson1 » Mon Dec 05, 2011 8:13 pm

Fungera inte riktigt och nu ser min sajt ut så här: http://svflash.se/administrator/index.p ... rticle.add

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: 404 Bild Fel

Post by EE Photo » Mon Dec 05, 2011 8:22 pm

Edit: Jag fick ett felmeddelande första gången jag klickade på din länk men nu får jag upp admin inloggningssidan så allt verkar funka nu.
Besök gärna min webbplats: http://www.fotoforalla.se/

kalsson1
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Thu May 20, 2010 9:24 pm

Re: 404 Bild Fel

Post by kalsson1 » Mon Dec 05, 2011 8:26 pm

Jadå det fungerar igen ;).. Men att ändra htaccess.txt till .htaccess.txt fungera inte. Om jag tar bort alla meta beskrivningar och meta taggar på artiklarna så kanske det fungerar.. Men om du kollar på min första sida (Hem) så fungerar den artiklen med bild men inte mina andra.

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: 404 Bild Fel

Post by EE Photo » Mon Dec 05, 2011 8:31 pm

Det fungerar inte eftersom du gjorde fel. Du ska ändra ifrån htaccess.txt till .htaccess du ska ta bort ".txt" också.
Besök gärna min webbplats: http://www.fotoforalla.se/

kalsson1
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Thu May 20, 2010 9:24 pm

Re: 404 Bild Fel

Post by kalsson1 » Mon Dec 05, 2011 8:43 pm

Okej ändrar jag till .htaccess så blir sidan blank som jag visa dig så det fungerar inte. Va fan kan det vara för fel haha..

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: 404 Bild Fel

Post by EE Photo » Mon Dec 05, 2011 8:45 pm

Om du vill så kan du PM:a mig med tillgång till back-end och FTP så kan jag ta en titt på problemet imorgon.
Besök gärna min webbplats: http://www.fotoforalla.se/

kalsson1
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Thu May 20, 2010 9:24 pm

Re: 404 Bild Fel

Post by kalsson1 » Tue Dec 06, 2011 6:32 pm

Javisst kan du få det. Förklara gärna för mig vad du gjorde om du fixar det ;)

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: 404 Bild Fel

Post by EE Photo » Tue Dec 06, 2011 7:29 pm

Jag testade att ändra från htaccess.txt till .htaccess och som du säger det funka inte så jag ändra tillbaka. Men av någon konstig anledning så får jag fortfarande ett 500 internal server error meddelande, vad gjorde du sist för att få bort det meddelandet?
Besök gärna min webbplats: http://www.fotoforalla.se/

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: 404 Bild Fel

Post by EE Photo » Tue Dec 06, 2011 7:36 pm

Det tog visst bara en liten stund innan sajten kom tillbaka igen.

Du borde verkligen fråga one.com varför du inte kan använda .htaccess
Besök gärna min webbplats: http://www.fotoforalla.se/

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: 404 Bild Fel

Post by EE Photo » Tue Dec 06, 2011 7:38 pm

För jag tror lösningen på problemet är att få igång sökmotorsvänliga url:er som inte har index.php i sig.
Besök gärna min webbplats: http://www.fotoforalla.se/


Locked

Return to “Allmänna frågor”