Page 1 of 1

404 Bild Fel

Posted: Mon Dec 05, 2011 4:42 pm
by kalsson1
Tja!

En snabb fråga. Jag har laddat upp mina egna bilder i min (images) mapp och bifogat dom i mina artiklar. För en veckan sedan fungera dom perfekt men nu så får jag bara ett 404 error och kan inte visa bilderna? Vad är fel? Har jag råkat stänga av en inställning?

Tack på förhand...

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 4:57 pm
by EE Photo
Kan du länka till ett exempel?

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 6:55 pm
by kalsson1

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 7:04 pm
by EE Photo
Du menar att det är ett kryss istället för en bild? Gå in i artikeln och se till så att url:n till bilden är rätt.

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 7:28 pm
by kalsson1
Ja men det borde den ju va. Det fungera för en vecka sen ju.. Jag bifogar den från mappen i min ftp, den måste väl hitta sökvägen själv?

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 7:32 pm
by EE Photo
Om sökvägen ändras så kan den ju inte hitta den själv. Testa att ta bort bilden och sen lägga till den igen då borde du få den nya sökvägen om den har ändrats.

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 7:36 pm
by kalsson1
har redan testat det flera gånger och det händer inget.. Har också gjort en ny mapp i min ftp och lagt dom i den fungerar inte.. Har även testa Joomlas egna bilder, fungerar ej...

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 7:44 pm
by EE Photo
Kan du testa att stänga av all SEO i Joomla och se om det fungerar bättre då?

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 7:45 pm
by kalsson1
Ja absolut. Hur gör man?

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 7:46 pm
by kalsson1
Jag har provat nu och det fungerar nu. Vad seo med detta att göra?

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 7:54 pm
by kalsson1
Sitter och läser att andra har samma problem typ... E det en bugg i Joomla?

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 7:59 pm
by EE Photo
SEO ändrar ju länkar och det krävs ju en länk för att bilden ska hittas och kunna visas.

Sätt på SEO igen och gör så här. Jag säg att du hade med index.php i dina webbadresser. För att få bort det (det kan vara problemet jag vet inte) gå då in med FTP på din sajt och hitta filen htaccess.txt i din Joomla root. Ändra det filnamnet till .htaccess

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 8:13 pm
by kalsson1
Fungera inte riktigt och nu ser min sajt ut så här: http://svflash.se/administrator/index.p ... rticle.add

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 8:22 pm
by EE Photo
Edit: Jag fick ett felmeddelande första gången jag klickade på din länk men nu får jag upp admin inloggningssidan så allt verkar funka nu.

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 8:26 pm
by kalsson1
Jadå det fungerar igen ;).. Men att ändra htaccess.txt till .htaccess.txt fungera inte. Om jag tar bort alla meta beskrivningar och meta taggar på artiklarna så kanske det fungerar.. Men om du kollar på min första sida (Hem) så fungerar den artiklen med bild men inte mina andra.

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 8:31 pm
by EE Photo
Det fungerar inte eftersom du gjorde fel. Du ska ändra ifrån htaccess.txt till .htaccess du ska ta bort ".txt" också.

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 8:43 pm
by kalsson1
Okej ändrar jag till .htaccess så blir sidan blank som jag visa dig så det fungerar inte. Va fan kan det vara för fel haha..

Re: 404 Bild Fel

Posted: Mon Dec 05, 2011 8:45 pm
by EE Photo
Om du vill så kan du PM:a mig med tillgång till back-end och FTP så kan jag ta en titt på problemet imorgon.

Re: 404 Bild Fel

Posted: Tue Dec 06, 2011 6:32 pm
by kalsson1
Javisst kan du få det. Förklara gärna för mig vad du gjorde om du fixar det ;)

Re: 404 Bild Fel

Posted: Tue Dec 06, 2011 7:29 pm
by EE Photo
Jag testade att ändra från htaccess.txt till .htaccess och som du säger det funka inte så jag ändra tillbaka. Men av någon konstig anledning så får jag fortfarande ett 500 internal server error meddelande, vad gjorde du sist för att få bort det meddelandet?

Re: 404 Bild Fel

Posted: Tue Dec 06, 2011 7:36 pm
by EE Photo
Det tog visst bara en liten stund innan sajten kom tillbaka igen.

Du borde verkligen fråga one.com varför du inte kan använda .htaccess

Re: 404 Bild Fel

Posted: Tue Dec 06, 2011 7:38 pm
by EE Photo
För jag tror lösningen på problemet är att få igång sökmotorsvänliga url:er som inte har index.php i sig.